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About This Guide 

Purpose of This Guide 
This guide describes the UWS DECwindows Desktop Applications. 

Who Should Use This Guide 
This guide is intended for all ULTRIX DECwindows users. This 
guide assumes the user has read the DECwindows User's Guide to 
become familiar with DECwindows terms and the techniques for 
manipulating windows. In addition, the user should have some 
experience using the DECwindows Session Manager and User 
Executive applications. 

Structure of This Guide 
This guide includes the following chapters: 

• Chapter 1 -Using the Calculator 

• Chapter 2 -Using the Calendar 

• Chapter 3 -Using the Cardfiler 

• Chapter 6 -Using the CDA Viewer 

• Chapter 4 -Using the Clock 

• Chapter 5 -Using DECterm 

• Chapter 7 -Using Mail 

• Chapter 8 -Using the Notepad Editor 

• Chapter 9 -Using Paint 

• Chapter lO-Using the PostScript Previewer 

xi 



• Chapter II-Using the Puzzle 

• Appendix A-Composing Characters 

• Appendix B-National Replacement Character Sets 

Related Documentation 

Conventions 

xii 

You may wish to have the following manuals at hand: 

• DECwindows User's Guide 

• DECterm Text Programming Manual 

• DECterm Graphics Programming Manual 

mouse 

MBl, MB2, and MB3 

blue-green ink 

boldface text 

I Return I 

The term mouse refers to any pointing device, 
such as a mouse, a puck, or a stylus. 

MB 1 indicates the left mouse button. MB2 
indicates the middle mouse button. MB3 
indicates the right mouse button. (The 
buttons can be redefined by the user.) 

Indicates information that you enter from the 
keyboard or a screen object that you must 
choose or click on. 

Represents the introduction of a new term 

A key name is shown enclosed to indicate that 
you press a key on the keyboard. 

A sequence such as I Ctrl/x I indicates that you 
must hold down the key labeled Ctrl while 
you press another key or a pointing device 
button. 

A sequence such as ~ indicates that you 
must first press and release the key labeled 
PFl, then press and release another key or a 
pointing device button. 

A vertical ellipsis indicates the omission 
of items from a code example or command 
format; the items are omitted because they 
are not important to the topic being discussed. 



1 
Using the Calculator 

The Calculator performs simple arithmetic functions-addition, 
subtraction, multiplication, division-and computes percentages 
and square roots. In addition, the Calculator performs 
trigonometric and inverse trigonometric functions, generates 
random numbers, and performs other more advanced operations. 

Unlike a handheld calculator, it has two displays. The top display 
is the accumulator, which shows the number being entered or the 
current result, and the bottom display is the memory. 

This chapter describes how to: 

• Start the Calculator 

• Enter data 

• Perform arithmetic functions 

• Use the memory 

• Transfer data to or from the clipboard 

• Exit from the Calculator 

Starting the Calculator 
To start the Calculator, choose Calculator from the Session 
Manager Applications menu or enter the following command in a 
DECterm window: 

% dxcalc & 
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A small calculator is displayed on your screen. You can move and 
change the size of the Calculator window as you wish. 

Calculato." I 

1IIIall 1 0·1 
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E] 
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Operating the Calculator 
You can use the Calculator with either the mouse or the keyboard. 
With the mouse, point to the appropriate button and click 
MBl. With the keyboard, enter the numbers 0 to 9 from the 
main keyboard or the keypad. Press the Shift key to enter the 
arithmetic functions (+, -, *, /, %, =) on the main keyboard. 
From the keypad, pressing the following keys produces the 
corresponding functions: 

Press . .. To Produce . .. 

IPFll / 

IPF21 ..;a;b 
IPF31 * 
IPF41 % 

comma key + 

IEnterlor~ 

1F171 Me 

[ff8] MR 

[ffi] M+ 

1F201 M-
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Clear Memory 

Clear Accumulator 

Clear Last Entry 
from Accumulator 

Accumulator 

Memory 

Subtract Contents of 
Accumulator from Memory 

Add Contents of 
Accumulator to Memory 

Add Contents of 
Memory to Accumulator 
Clear Sign of 
Accumulator 

When you enter data into the accumulator, notice that the 
Calculator uses a decimal point to distinguish between random 
digits and an operand. See what happens as you enter the 
following data: 

Enter 1134. Notice that no decimal point appears in the 
accumulator. 

2 Enter a plus sign (+). The Calculator inserts a decimal point 
after the digits 1134 to signify the completion of an operand. 

Depending on the contents of the accumulator, you can use one of 
the following methods to correct mistakes in computation: 

• Press the Delete key to erase the last digits entered in the 
accumulator. 

• Click on the CE button to void the last operand entered. 

• Choose Undo from the Edit menu to reverse the last operation, 
for exam pIe, to restore the last operand or to remove the 
previous paste operation. 
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Performing Arithmetic Functions 
The Calculator displays numbers in the range of plus or minus 
999,999,999. It performs all calculations in left to right order and 
treats operators with equal importance. 

For example, to evaluate the equation 6 + 5 * 3: 

Find the sum of 6 + 5. 

Calculator displays an 11. 

2 Find the product of 11 * 3. 
The result is 33. 

Also note the way the Calculator computes percentages. For 
example, to determine 6 percent of 195: 

Enter 195. 

The Calculator displays the digits in the accumulator. 

2 Enter * and the Calculator inserts a decimal point. 

3 Enter 6. 

The number 6 is displayed in the accumulator. 

4 Enter %. 

The result, 11. 7, is displayed in the accumulator. 

Storing Values in Memory 
Use the memory display to store results and values for later 
computation. The figure in memory starts out as zero. You can 
add the contents of the accumulator to memory or subtract the 
contents of the accumulator from memory, using the M+ and 
M - buttons respectively. To enter the contents of memory into 
the accumulator, click on the MR button. Clear the contents of 
memory with the MC button. 

Performing Special Functions 
The Calculator performs trigonometric and inverse trigonometric 
functions as well as other special functions. 

The special function keys are as follows: 
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Key 

deg 

xl 

l/x 

Rnd 

Inv 

sin 

cos 

tan 

log 

In 

square 
root 

yl\x 

Description 

Degree key. Selects the units for angular measurement. By 
default, the Calculator is in the degree mode. Clicking on the 
Idegl key once places the Calculator in the radian mode. This 
is indicated by the key label "rad". Clicking on the key again 
places the Calculator into gradian mode. This is indicated by 
the key label "grad". The angular mode has no effect on the 
Calculator unless trigonometric functions are being used. 

Factorial key. Calculates the factorial (x)(x - l)(x - 2) ... (2)(1) 
of the value x in the display for integers O::;x::;69.0! = 1 by 
definition. 

Reciprocal key. Divides the displayed value x into 1. The 
value x cannot equal be to o. 
Random number generator key. Generates a random number 
between 1 and the integer of the display. It does not generate 
negative numbers or numbers less than 1. 

Inversion key. By default, the Calculator performs non­
inverted trigonometric functions. When you click on the 
inversion key, the Calculator performs inverted trigonometric 
functions. 

Sine key. Instructs the Calculator to find the sine of the 
displayed value. 

Cosine key. Instructs the Calculator to find the cosine of the 
displayed value. 

Instructs the Calculator to find the tangent of the displayed 
value. 

Common logarithm key. Calculates the common logarithm 
(base 10) of the number x in the display. x> o. 
Natural logarithm key. Calculates the natural logarithm (base 
e) of the number x in the display. x > o. 
Square root key. Calculates the square root of the number x in 
the display. The x value cannot be negative. 

Raises the displayed value y to the xth power. Order of entry 
is y lyAxl x. The y value cannot be negative, but both x and y 
can be fractional. 

:opying Text with the Calculator 

Unli!) ,~IVl. 

Copy Alt/C I 
Paste Alt/V 

You can copy numbers from other applications into the 
Calculator's accumulator and from the Calculator accumulator or 
memory into another application. 

Use the Copy menu item from the Edit menu to transfer data 
from the active display in the Calculator window to another 
application window. For example: 

Click on the accumulator display. 
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2 Enter a number into the accumulator. 

3 Choose Copy from the Edit menu. Or, for greater speed, press 
and hold MB2 to display a pop-up menu and choose Copy 
menu item. 

Now you can paste the data from the clipboard to another 
application window. 

Use the Paste menu item from the Edit menu to copy data from 
the clipboard. This data can be copied directly from another 
window, or it can be the result of an equation copied from another 
window. Calculator treats the contents of a paste operation just 
as if you typed in the data from the keyboard yourself. 

~ Card: OcLlnventory 

File Edit Search Card Help 

Brand X 4147.4'24= 6 

Help [ File Edit 

99537.6 

1IIIalD 1 0·1 
[BD [}!D OEJ DE] 

I~LD[KJ~I 
~~~~ 
~~LLl[EJ 

EJ 
G 

[?J[IJ[IJ 00 
[IJ[IJ[TI c:J~ 
[IJ[IJ[D on 
~D[ill 0U 

Exiting from the Calculator 
,..... _______ ----,. If you modified the screen placement and size of the Calculator 

Save Ceometry 

Use System Defaults 
during your session and would like to save those settings, choose 
Save Geometry from the File menu before exiting. The next time 

l........;.Qu_it _____ A....;ltI....;Q;...J you start the Calculator, it will have the size and placement you 
specified .. 

To restore the default size and placement of the Calculator, choose 
Use System Defaults from the File menu. 

To exit from the Calculator, choose Quit from the File menu. 
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2 
Using the Calendar 

The Calendar combines the functions of a desktop calendar and 
an appointment book to help you keep track of your meetings and 
plan your time. The Calendar lets you look at a year or month 
display, or review your scheduled appointments a day at a time. 

You can also create several different calendars to use for specific 
purposes. For example, you could create one calendar to keep 
track of your personal enagagements and another calendar 
to be used by a group of people to schedule conference room 
reservations. 

This chapter describes how to: 

• Start the Calendar 

• Move around the Calendar 

• Create and delete entries 

• Set alarms and repeat entries 

• Move entries 

• Use the Calendar's clock 

• Mark special days 

• Print part of a calendar 

• Work with multiple calendars 

• Create, rename, and delete a calendar 

• Customize a calendar 

• Exit from the Calendar 
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Starting the Calendar 
To start the Calendar, choose Calendar from the Session Manager 
Applications menu or enter the following command in a DECterm 
window: 

% dxcalendar& 

The month display appears on your screen. 

Iml Calendar X2.0: IQj6J] 
File Edit View Customize Help 

October, 1989 .Q 

Wk Sun Mon Tue Wed Thu Fri Sat 

41 8 9 i''''1 11 12 13 14 

42 15 16 17 18 19 20 21 

43 22 23 24 25 26 27 28 

44 29 30 31 
rT 

" 1 2 3 4 

45 5 6 7 8 9 10 11 '-' 

Q 

The month display shows the current month and year, with the 
days in the month arranged by week in rows. The current day has 
a box around it. 

Moving Around Calendar 

Oaobcr,~t9 

~fi~i;!~*i! 

Calendar has three main displays: the month display, the day 
display, and the year display, which looks like 12 small month 
displays set out in a 4 by 3 matrix. 

Scroll bars let you move backwards and forwards within a display, 
for example, to look at a future or a previous month when you are 
in a month display. 

To move from one type of display to another, double click on the 
appropriate item in the current display. For example, double 
clicking on one of the days visible in the month display opens the 
day display for that day. Alternately, double clicking on a month 
in the year display opens the display for that month. 

From the View menu, you can choose the Selected, Today, Day, 
Month, and Year menu items. Choosing the Today menu item 
displays the current day. To choose the Selected, Day, Month, and 
Year menu items, you must first select a day. 
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:reating an Entry 
By double clicking on a particular day, you can open a display that 
shows timeslots from 8:00 a.m. to 5:30 p.m. 

ItOlI Calendar X2.0: 

File Edit View Entry Customize Help 

October, 1989 
¥Ik Sun Mon Tut Wed Thu Fli Sat 

401234567 
41 8 9 lmiJ11 12 13 14 
42 15 16 17 18 19 20 21 
43 22 23 24 25 26 27 28 
44 29 30 31 

November, 1989 
\Ilk Sun Mon Tut Wed Thu Fli Sat 

44 1 2 3 4 
45 5 6 7 8 9 10 11 
46 12 13 1415 16 17 18 
47 1 9 20 21 22 23 24 25 
48 26 27 28 29 30 

Tuesday the 10th of October, 1989 

~ 6 
~t""'"''''''''''''''''''T''''''''''''''''''''''''''''''''''''''''' ............................................................................................ r-::& 

~i 12:00 i ~ 
~f"·············i······································ ............................. ~ 
~! 30 i ~ ~ , ~ 
~t············ .. ·· ..................................................................................................................... ~ 

~i 1:00 ~ 

f2;~;F:---:-:::-----~::-:::<~:-~:-::: : 
~! 30 ! I ... ':00 ... 1 .=~-~-~--~~-~-~----~-~~-----~-~- I 
~i 30 i ~ 
~f·················· .. ········f·············· .. ····· .. ··· ......................................................... ································· .. ········· .. ·····v~ 

I Previous Day I I 2:28pm I Next Day 

Use the scroll bars to display timeslots earlier or later than the 
times shown. You can type entries, such as an appointment, 
directly into the timeslots. Or, by using the timeslot editor, 
you can type longer entries, activate alarms to remind you of 
appointments, and cause messages to repeat at regular intervals. 

To record a short entry directly into a day display: 

Display the day in which you want to make the entry. 

2 Click (and drag to resize, if necessary) on the desired time in 
the day display. 

3 Enter the text in the timeslot. 
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4 Click on the time again. 

When a day has at least one entry in it, its day number 
changes from a normal font (nn) to an italic font (nn) 
wherever it is displayed. You can then distinguish between 
days containing appointments and free days in the month and 
year displays. 

To create a longer entry using the entry editor: 

1 Click on the desired timeslot in the day display. 

2 Choose Edit ... from the Entry menu or double click on the 
desired timeslot. 
The entry editor is displayed: 

___ E_llt_rY_E_d_ito_r __________________________ I_~ __ 
File Edit Help 

Tuesday the 10th of October, 1989 
From: 9:00am To: 9:30am 

\I 

~At Entry Time ~@ 8:55am ~(.': 8:30am 

~O lm~ '! nth Oct 1:{!(IHIU ~O 'l'm~ 31'11 Gct !~:!}!}am 

5 

Minutes 

w " ~ ~ ~ ~ 2 ~ / ~ 0 ~ 
• WI + $ i ? ~ P 0 it w 

Repeat 1-1 _No_n_e ____ --'I [::::~:~:~!.:::~E~?::::f~:~~:I~:::::::::::::::::::~:::::::::::::::::::::1 
C:i !~111:, L:IE~::~~i.~::.:i!.~~~:~::~?:~~i] [:::~E~i~::~~~~:::::::::::::::::::::::::::::::::::::::::::J 

/j) Flag day 

OK I Delete Entry I I Reset I I Cancel 

.(} ,.... 

'-

Q 

3 Enter the text and adjust the alarms and repeat intervals as 
required (see Setting Alarms and Making Repeat Entries). 
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4 Click on any icon that you want to associate with your entry. 

These icons are symbols that can represent the contents of the 
entry, thus serving as a reminder for you. Calendar attaches 
no particular meaning to them. 
The icons you select will appear in the handle of your entry. 
The handle is the area of an entry between the timeslot and 
the vertical resize bar. 

S Click on the OK button to confirm the entry and to dismiss 
the entry editor. 

If you exit the editor without having entered any text, or if 
you delete all the text describing a previous entry, the timeslot 
remains unscheduled. 

Changing the Size of a Timeslot 
To change the size of a timeslot, press MBI on the time you want 
to use as a starting point and drag the top edge of the timeslot up, 
or the bottom edge of the timeslot down. The timeslot is redrawn 
to the new size. 

You can use this method to reduce or expand the time allocated 
for an entry. If you reduce the size of a timeslot, some text may 
no longer fit in the display, but it is not lost. The text reappears if 
you expand the timeslot again. 

SeHing Alarms 
Normally, Calendar rings an alarm and displays a message five 
minutes before, and again at the time you specify. 

The timeslot editor lets you modify the way the Calendar sets 
alarms. You can set alarms to ring at one or all of the following 
times: 

• At the time of the sceduled appointment (on by default) 

• One to sixty minutes before the time you specified for the 
entry 

• One to twenty-four hours before the time you specified for the 
entry 

To set one or more alarms: 

Click on the desired timeslot in the day display. 

2 Choose Edit... from the Entry menu. The timeslot editor is 
displayed. 
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3 Write the entry if you have not already done so. 

4 Click on the toggle button to set an alarm. 

By default, alarms ring five minutes before the entry time and 
at the entry time. 

S Move the arrow in the scale to adjust to the time you want. 

6 Click on the OK button to save the settings and to dismiss the 
timeslot editor. 

You can also set alarms to ring at any of the following times by 
displaying the repeat options menu and choosing the desired 
option: 

Daily 
Weekly 
Biweekly 
Monthly 
Bimonthly 
Quarterly 
Annually 
Biannually 
Triannually 

When you choose an option, you can further customize when the 
alarm will ring. By enabling the But option and displaying the 
corresponding option menus, you can cause the alarms to skip or 
move forward or backward according to whether or not the day in 
question is a work day. 

To modify the default intervals for all alarms, choose Alarms ... 
from the Customize menu and make the desired changes in 
the Alarms dialog box. When you change the defaults, you can 
save them for future Calendar sessions. To save your settings, 
choose the Save Settings menu item from the Customize menu. 
To restore the default settings, choose Use Defaults from the 
Customize menu. To restore settings to the previous settings 
(other than default), choose Restore Settings from the Customize 
menu. 
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Close 

Delete ... 

Reset 

Deleting an Entry 
To remove or clear the contents of a timeslot: 

Click on the timeslot in the day display that contains the 
entry you want to delete. 

2 Choose Edit. .. from the Entry menu. The timeslot editor is 
displayed. 

3 Click on the Delete Entry button. 
A dialog box is displayed, asking you to confirm that you want 
to delete the entry. 

4 Click on Yes to confirm that you want to delete the entry. 

Making Repeat Entries 
Often, entries in a calendar are regular events. The Calendar 
makes it easy to schedule these events by allowing you to specify 
the time interval at which the entry should be repeated. 

You can repeat an entry at the following intervals: 

• None 

• Daily 

• Weekly 

• Every two weeks 

• Every four weeks 

These settings are made from the timeslot editor. To set a repeat 
interval for an entry: 

Click on the timeslot in the day display that has the first 
occurrence of the entry. 

2 Choose Edit... from the Entry menu. The timeslot editor is 
displayed. 

3 Write the entry if you have not already done so. 

4 Choose the repeat interval you want by clicking on the 
appropriate option button. 

You can choose only one repeat interval at a time. The preset 
option is None. 

S Click on the OK button to save the settings and to dismiss the 
timeslot editor. 
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If you change or delete an entry that is repeated, a dialog box is 
displayed, asking if you want to make the change or deletion in 
just this instance, from this point on, or every time, including past 
instances. 

Moving an Entry from One Timeslot to Another 
You can copy or move the entire contents of an entry, or just a 
piece of text, to another timeslot. If you select the time, then 
any alarms or repeat intervals associated with the entry are 
transferred, along with the text, to the new timeslot. Selecting 
just the text from the timeslot transfers just the text. 

To move an entry from one timeslot to another: 

1 Display the day that has the timeslot you want to move. 

2 To select the entire entry from a timeslot, click on the handle. 

The handle is the area in an entry between the time and the 
vertical resize bar. By pressing and dragging MB 1 in the 
handle, you can move an entry up and down through the day 
display to the desired timeslot. 
To copy just a piece of text, select it by clicking and dragging 
the pointer over the portion of text you want. 

3 Choose Cut or Copy from the Edit menu. 
If you want the entry to remain in the original timeslot, 
choose the Copy menu item. If you want to delete the entry 
from the original timeslot, use the Cut menu item. 

4 If you are moving the entry to a different day, display the new 
day. 

S Click on the time to which you want to move or copy the entry 
or text. 

6 Choose Paste from the Edit menu to insert the entry or text in 
the new location. 

If you are moving the whole entry (time and text) and want to 
move it to the same time on a different day, you do not have to 
display the new day. After selecting the desired day in the month 
display, choose the Paste menu item from the Edit menu. This 
causes the entry to be inserted on that day, at the same time. 
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IDl CalendarX2.0: MI:i1 
Flle Edit View Entry CUstomize Help 

10 1 101 

Wednesday the 11th of October. 1989 

1/\ 

9:00 QIQlstaffMeetJng 

l., 

Creating Overlapping Entries 
You can create an entry at a time partially or completely occupied 
by an existing entry. To create overlapping entries, Press MBI 
and drag on the timeslot as if there were no overlap. Calendar 
opens a new entry for you at the specified time. You can overlap 
as many entries as you like. 

Normally, overlapping entries are stacked so that the left side 
of each entry is always visible. To cause Calendar to stack 
overlapping entries so that the first line of each entry is visible, 
choose Day View ... from the Customize menu to display the Day 
View dialog box. Then, choose Show text from the Stacking option 
menu. With Show text enabled, even if you have two entries 
starting at the same time, Calendar leaves a gap to display at 
least some of the text assoicated with the hidden entry. 

Clicking on the handle of the entry that is overlapped makes it 
pop to the front. 

Entering Day Notes 
Information which is specific to a particular day, but not to a 
particular time, can be entered in a day note. Day notes are 
identical to ordinary calendar entries, except that they are not 
associated with a particular time. They are useful for denoting 
occasions like birthdays. 

To enter a brief day note, click on the entry box below the date 
in the day display. The day note becomes highlighted, indicating 
that you can enter text in the text area. To complete your entry, 
click on the day note. The highlighting dispappears. 

To enter a longer day note, double click on the day note to display 
the entry editor. You can enter text, modify an existing entry, or 
adjust the alarm settings and repeat intervals. 

Using the Clock in the Day Display 

I 2:56pm I The Clock provides a digital display of the current time. In 
addition to showing the current time, the clock allows the current 
Day view to autoscroll. The clock has no border when it is 
autoscrolling. 

To start autoscrolling, click on the clock. The timeslots visible 
in the Day view adjust, so that the current time is within the 
first timeslot. This process continues: as a timeslot passes, it is 
scrolled off the top of the window. Thus, the view is kept as up 
to date as possible. This is convenient if you significantly reduce 

Using the Calendar 2-9 



the size of the day display, because it keeps the most immediate 
timeslots in view. 

The clock performs this function only for the current day. If the 
Day view is not the current day, clicking on the clock first causes 
the displayed day to be replaced by the current day. Autoscrolling 
then takes place as usual. 

To stop this automatic scrolling, move the timeslot by any other 
method, such as adjusting the scroll bar. Autoscrolling is turned 
off at the end of the day. 

If you are making an entry in a timeslot when it is due to be 
scrolled, it does not disappear. The scroll mechanism waits until 
the next interval is over and then catches up. 

The Show AMlPM customizing option allows you to choose 
between a 12-hour and 24-hour clock. Whichever clock you choose 
is reflected by all Calendar-displayed times and clocks. 

Marking Special Days 
You can mark days of particular importance, such as major project 
milestones, holidays, or birthdays. Marking particular days alters 
the display font so that those days can be distinguished from 
other days in the various Calendar displays. 

To mark a day: 

Select the desired day from any of the Calendar displays. 

2 Pull down the Edit menu and drag the pointer to the submenu 
icon next to the Mark menu item to view the submenu. 
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Work Day 

Non- Work Day 

N(trllHd 

Special 

The menu item currently in use for the selected day is dimmed 
in the submenu. 



3 Choose the desired menu item from the Mark submenu: 

Choose 

Work Day 

Nonwork Day 

Special 

Default 

To Produce 

Bold font 

Standard Calendar font 

Bold, larger font; on color workstations, displayed 
in red font 

The standard Calendar font the day had before it 
was previously marked with Work Day, Nonwork 
Day, or Special menu item. 

The day is now marked in the specified manner. 

Sending and Receiving Calendar Entries Through Mail 
You can send and receive calendar entries through electronic 
mail. To send an entry, display both the calendar entry and a 
DECwindows Mail Create-Send window on your workstation 
screen. Use MB3 to select the entry from the Calendar. The entry 
is automatically pasted in the Mail Send window. 

To receive an entry through DECwindows Mail, open the Day 
View and click on the desired timeslot. Use MB3 to select the text 
from an existing mail message. The entry is automatically pasted 
into the Calendar at the timeslot you selected. 

Printing a Part of a Calendar 

Open .•• 

Open in New ••. 

Include ••• 

Name As ••• 

Delete ..• ........................ 
I Print ... 

Exit 

You can print a timeslot entry or all of the entries in a day or a 
week by copying the entry or entries to a printable file. 

To print a part of a Calendar display: 

2 

3 

Display the day that relates to the entry or entries you want 
printed. 
For example, if you are printing a timeslot, display the day 
that contains the timeslot. If you are printing the entries in 
a day, display the day itself; to print the entries in a week, 
display a day that falls in that week. YOl) can also select the 
day or week number you want to print, from any display in 
which it appears. 

Click on the time, day number, or week number, as 
appropriate. 

Choose Print... from the File menu. 
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Calendar displays a dialog box. 

I Calendar: Print ~i 

Tuesday the 10th of October, 1989 

"I 

o III::I::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::! 
Ull(~ Umi1 

o Send File To Printer 

/ldxcalendar.ps 

/CQKJI I Cancel I / Options ... I 

The dialog box shows the time period you have selected and 
provides a default name for the file to be sent to the printer. 
It also lets you limit the number of lines you want printed for 
each entry by clicking on the Limit Lines Per Entry option 
and moving the arrow in the scale to set the desired limit. 

4 The default file name dxcalendar.ps is displayed. Change 
the name provided by the dialog box, if you want, and then 
confirm your request by clicking on the OK button. 
The requested section (timeslot, day, or week) is copied to the 
named file. You are now ready to send the file to the printer. 

Working with Multiple Calendars 
I'n1 caJendarX2.0:personal ~Iru 

File 'Edit View CUstomize Help 

October, 1989 Igl 
Wk Il1I calendarK2.0:8I'1)UP ~6i 
41 Ria Edit Ylew CUstomize Help 

~ :: ~ :t~r~9:: : ;~ ~C; 
~ ~ ~ ~ ~ ~ ~ V ~ 

'-- 44 29 30 31 

.. 1 2 3 4 

4S 5 e 7 8 9 10 11 Q 

You can create, open, save, print, and delete calendars. You 
can create different calendars to use for specific purposes. For 
example, you could designate some calendars for your personal 
use and other calendars for use by a group. 

You can use the Open... menu item from the Calendar's File menu 
to open a calendar, even if you do not have privileges to modify it. 
This makes it possible to use a calendar for informal sharing of 
information. For example, a group secretary can create a calendar 
for events of group-wide interest, so that everyone on a team can 
see when group activities are going on. Only one person at a time 
can write in this calendar, and the calendar cannot be read while 
it is being modified. If no one is modifying the file, an unlimited 
number of people can read it simultaneously. 
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Creating a New Calendar 
To create a new calendar: 

Choose Open... from the File menu. Calendar displays a 
dialog box. 

File Filter 

l~dWC'" 
Files in 

61 Filter I 
I~I 
1 Cancel I 

Q-

<JDI>D 
Selection 

I 

2 Type a unique file name for the new calendar in the Selection 
text entry field and click on the OK button. By default, 
Calendar adds the file extension .dwc to calendar file names. 
A dialog box is displayed, asking if the calendar currently 
being displayed should be removed before displaying the 
new calendar, or if you want to keep both calendars on the 
screen at the same time. Click on Replace to display the new 
calendar in place of the old calendar. Click on New to display 
both Calendars simultaneously. 

3 Calendar asks if you want to create a new file. Click on Yes to 
create a new calendar. 

By default, the new calendar is presented in a month display 
containing the current day. 

The calendar file name can always be changed again (see 
Renaming an Existing Calendar). 
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Opening an Existing Calendar 
To open an existing calendar: 

Choose Open... from the File menu. 
Calendar displays a dialog box that prompts you for the name 
of the calendar you want to open. The file list box lists the 
names of any calendar files in the current directory; that is, 
files that have the extension .dwc. 

2 Select the file name you want to view and click on OK. 

If you want to open a calendar file that is not listed, type the 
name of that file in the Selection text entry field and click on 
the OK button. Or, use the File Filter text entry field to list a 
subset of files that you can then select from. For example, to 
list all files in another directory with the file extension .dwc, 
type the complete directory specification, /jones/staff/*.dwc, in 
the File Filter text entry field and click on the Filter button. 
Then, double click on the file name of the calendar you want 
to open. 
A dialog box is displayed, asking if the calendar currently 
being displayed should be removed before displaying the new 
calendar, or if you want to keep both calendars on the screen 
at the same time. Click on New or Remove to make your 
choice. 
If you specify the name of a calendar that you are not allowed 
to read, the Open operation fails and a message box is 
displayed, explaining the cause of the failure. 

3 The calendar is opened. 

Renaming an Existing Calendar 
To rename the current calendar, choose Name As... from the File 
menu. 

A dialog box is displayed: 

I Cancel I 

Type in the new calendar name. Calendar adds the file extension 
.dwc to calendar file names by default. You can rename only those 
calendars in which you are allowed to write. 
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Closing a Calendar 
Choose Close from the File menu to close the current calendar. 

Deleting a Calendar 
Choose Delete... from the File menu to delete a calendar. 
Calendar displays a dialog box, asking whether you really want 
to delete the calendar. If you do not have sufficient privileges to 
delete the specified calendar, an error message is displayed. 

:usfomizing a Calendar 

General. .. 

Day View .. . 

Icon box .. . 

Alarms .. . 

Save Settings 

Restore Settings 

Use Defaults 

General .•. 

Day View •.• 

Icon box •.• 

Alarms •.• 

Save Settings 

Restore Settings 

Use Defaults 

Use the Customize menu to customize the appearance and 
behavior of your calendar. With the Customize menu, you can 
change the appearance and behavior of many of Calendar's 
displays, including the: 

• General Settings 

• Day View Settings 

• Icon Box Settings 

• Alarm Settings 

Use the Save Settings menu item to save your customized settings 
from one session to the next. The size and placement of all 
windows are also saved. 

Use the Restore Settings menu item to cancel any unsaved 
changes you make and restore the current saved settings of all 
customization options. 

In dialog boxes, shaded buttons indicate the current settings. 
Click on a button or its label to change the setting. Click on the 
Apply button to apply your changes without closing the dialog box. 
Click on the OK button to apply your changes and close the dialog 
box. 

Customizing the General Display 
Choose General... from the Customize menu. Calendar displays 
the General dialog box. 
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Genet"al I~ 

Work Week II Show Week Numbers III Show AM/PM 
D Sunday 4 o 'Live' Scrolling II Monday I [!] 
II Tuesday o Right to Left 
II Wednesday 

Date for Week No.1 

II Thursday I January 
D Fill Blank Days 

II Friday ........................................... III Print Blank Days 
D saturday 

First View I Month I III BOK Current Day 
First Day of Week I Don't Mark Past Days I I Sunday I D Start Iconized 

~ I Reset I I Cancel I 

From the General Settings dialog box, you can modify any of the 
following calendar features: 

Work Week 
Normally, Calendar designates Monday through Friday as the 
work week, as indicated by the shaded toggle buttons immediately 
to the left of the days. You can change the settings by clicking on 
the days you want to use for your work week. 

First Day of Week 
Unless you specify otherwise, the first day of the week is Sunday, 
as indicated by a shaded option button. You can designate another 
day as the first day of the week by clicking on it. 

Show Week Numbers 
Unless you specify otherwise, the leftmost column in every month 
display lists the number of each week, starting with the first week 
of January as week number one. You can disable this feature by 
turning off the Show Week Numbers option. 

Date for Week No. 1 
In every month display, the leftmost column lists the number of 
each week. This is in effect as long as the Include Week Numbers 
option is turned on. By default, weeks are numbered starting 
with the first week of January as week number one. The following 
weeks are numbered accordingly, ending with the last week in 
December as number 52. 

The Date for Week No. 1 option enables you to set the week you 
want to designate as the first week of the year by choosing the 
desired month and moving the arrow in the scale to the desired 
date. For example, if your fiscal year starts the first week of July 
and you want to designate that week as the first week of the year, 
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choose July from the list of months and choose a date number that 
falls in the first week of July. To ensure that the date you choose 
falls in the first full week of the month, you may want to choose a 
date such as July 6. 

The date January 4 is the preset option, which ensures that the 
first full week in January is used as the first week of the year. 

First View 
When you start Calendar, the month display appears on your 
screen by default. You can click on Year Display or Day Display to 
choose either of those options to be the first display you see when 
you start Calendar. 

Start Iconized 
Normally, when you start Calendar you see a display of the 
current month. By turning on the Start Iconized option, you can 
cause Calendar to start as an icon. 

Show AM/PM 
By default, Calendar has a 12-hour time system that uses AM and 
PM in its day display to differentiate timeslots. If you disable the 
Show AMlPM option, Calendar uses a 24-hour time system in its 
day display-for example, 1 p.m. becomes 13:00, and so on. 

'Live'Scrolling 
Normally, when you move the slider on the scroll bars in the day, 
month, and year displays, the displays don't move until after you 
have moved the slider. When you enable this option, the displays 
change dynamically when you move the slider. 

Right to Left 
Normally, timeslots appear on the left side of the day view and the 
vertical scroll bar appears in the right side. 

You can reverse the position of these elements, including the 
timebars, by enabling the Right to Left option. 

Fill Blank Days 
Unless you specify otherwise, Calendar leaves the days not filled 
by the current month blank. When you turn on the Fill Blank 
Days in Month Display option, Calendar fills the blank days at 
the beginning and end of the current month with the dates of the 
preceding and following months. 

Print Blank Days 
Normally, when you print out a week from your calendar, all days 
are printed out whether or not you have entries in them. 
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General ••• 

II Day View •.. 

Icon box ••• 

Alarms ••• 

Save Settings 

Restore Settings 

Use Defaults 

You can disable the Print Blank Days option by clicking on it, 
which causes only those days that have entries in them to be 
printed out. 

Box Current Day 
Normally, Calendar boxes the current day in the day display. You 
can disable this feature by clicking on it. 

Don't Mark Past Days 
Normally, Calendar does not distinguish past days from future 
days. You can direct calendar to cross out or strike out past days 
by choosing the appropriate option from the Don't Mark Past Days 
options menu. 

Customizing the Day Display 
You can customize the day display by choosing Day View... from 
the Customize menu. 

Calendar displays the Day View dialog box. 

Day View I~ 

Timeslot Size! Half Hour Vertical Stacking! Show Length ! 
Spacing 

Increment 5 Minutes 

~' 
3 

Font size Icon size ffl 
o small .0. Horizontal Spacing 

@ Medium !1 4 

o Large £1 ffl 
Timebar Width 

Working Hours Lunch Hours o Times on the Line 
start 00 am [!!] [!2] pm o Show Full Times 

Finish [!] 0 pm QJ[!2] pm [II Show Day Notes 
[II Show Months 

Flag: Icon: .--_____ =[II<...:.A=U=to'-'C=li=ck;:..;;o=nc...::C=lo=;ck 

[II Day Notes / iJj 14 ,<:1 I») ~ ~ 3: r::::J / ~ 0 [± 

[II Entries iJj ~ WI + $ i ! ? ~ P 0 it w 

I~I ~ I Reset I I Cancel I 

Use this dialog box to modify any of the following day display 
features: 
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Day Display: Timeslot Size 
By default, the day display has timeslots broken up into 30 
minute intervals. You can choose 1 hour, 15 minute or 5 minutes 
intervals instead. 

Increment 
The resize bar lets you create a Calendar entry that is larger or 
smaller than the timeslot size. Normally, the resize bar expands 
or contracts a timeslot in 5-minute increments. 

Change this increment by choosing a different option from the 
Increment option menu. 

The resize bar time increment is always smaller than the timeslot 
size. For example, if your timeslot size is 30 minutes, the Hour 
option on the Increment option menu is dimmed since you can 
only resize the entry in increments smaller than or equal to the 
timeslot itself. 

Font Size 
Normally, Calendar uses a medium font size for timeslots and 
entries. You can change the font size by clicking on one of the font 
size option buttons. 

Icon Size 
Normally, Calendar displays medium-sized icons in the handles of 
Calendar: entries. You can change the icon size by clicking on one 
of the Icon size options. 

Working Hours 
Calendar uses the preset options 8:30 a.m. to 5:30 p.m. for 
working hours, which determine the timeslots it uses in the 
day display. You can change these values by clicking on the 
appropriate box to set the time you want. 

Lunch Hours 
Normally, Calendar uses 12:00 p.m. to 1:00 p.m. for lunch hours. 
You can change these values by clicking on the appropriate box to 
set the time you want. 

Flag 
Normally, when you create a day note or entry, the corresponding 
day is flagged. This means that the font of the specified day is 
changed in the month view to make it stand out. 

Disable this flagging by clicking on the corresponding button. 
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Icon 
Normally, the meeting icon appears in the handle of a Calendar 
entry. The pencil icon is normally ~ssociated with the day note. 

With this option, you define the default icon that will be applied 
when you create a new entry. This option also allows you to define 
the default icon to be used when you create Daynotes. You can 
later override these defaults using the associated entry editor. 

You can associate multiple icons with a particular entry by using 
the entry editor. For more information, see Creating an Entry. 

Vertical Spacing 
This option lets you set the relative height of the timeslots-the 
greater the value, the more the white space. Larger values tend 
to be more readable, smaller values allow more timeslots to be 
displayed in the same space. 

To modify the timeslot height, press and drag MB 1 to move the 
arrow in the scale to the desired value. 

Horizontal Spacing 
This option lets you adjust the width of the timeslots. 

To midify the timeslot width, press and drag MB 1 to move the 
arrow in the scale to the desired value. 

Timebar Width 
This option controls the thickness of the two timebars. A greater 
value will produce thicker timebars. A value of 0 will remove 
them completely. 

Stacking 
Normally, overlapping entries are stacked so that the left side of 
each entry is always visible. This is the effect of the Show Length 
option in the Stacking option menu. 

To cause Calendar to stack overlapping entries so that the first 
line of each entry is visible, choose Show Text from the Stacking 
option menu. When Show Text is enabled, Calendar leaves a gap 
to display some of the text associated with a hidden entry. 

Calendar does not save any changes you make to the stacking 
order for a given set of entries. 

Times on the Line 
Normally, the starting time of a timeslot is centered between the 
top and bottom lines of the timeslot. 
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General ... 

Day View ... 

I Icon box ... 

Alarms .•. 

Save Settings 

Restore Settings 

Use Defaults 

You can cause the starting time of a timeslot to be centered in the 
top line of the timeslot by enabling the Times on the Line option. 

Show Full Times 
Normally, timeslots that are not on the full hour are displayed 
as the number of minutes after the full hour. For example, the 
timeslot for 2:00 would be displayed as 2:00, but the timeslot for 
2:30 would be displayed as 30. 

To cause Calendar to display the hour as well as the minutes for 
a timeslot, enable the Show Full Times option. This would cause 
2:30 to be displayed as 2:30. 

Show Day Notes 
Normally, the day note entry box appears below the date in the 
day display. 

To remove the day note entry box, disable the Show Day Notes 
option by clicking on it. Old day notes are not deleted if you 
disable day notes; they just are not visible. 

Show Months 
Unless you specify otherwise, Calendar displays the current and 
next month at the top of a day display. You can disable this option 
by turning off the Show Months option. 

Autoclick on Clock 
The standard Calendar requires you to start autoscrolling by 
clicking on the clock when you display the Day View. By setting 
the autoclick option on, autoscrolling will happen automatically 
when you first open the day view. 

Customizing Calendar Icons 
You can customize the Calendar icon that appears in the 
DECwindows Icon box by choosing Icon Box ... from the Customize 
menu. 

Calendar displays the Icon Box dialog box. 

Icon box I 

DI~ ______________ _ 
ij] Show Day Name Ij] Full Day Name Ij] New Line 

Ij] Show Time 

I~I ~ I Reset I I Cancel I 
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General •.. 

Day View .•. 

Icon box •.• 

Alarms •.. 
I s~~~o °s~Otti~~~OO 0 0 0

1 

Restore Settings 

Use Defaults 

The text entry field in the upper left corner of the dialog box lets 
you enter text that appear on the top line of the icon box. 

In addition to entering text, you can modify the following Calendar 
icon features: 

New Line 
Use the two New Line buttons to customize the layout of the 
Calendar icon. 

Enabling the top New Line button causes the text you type into 
the text entry field to appear on the top line in the icon box. 

Enabling the second New Line button causes the time of day to 
appear on a line below the day of the week. Disable this option by 
clicking on the shaded toggle button. 

Show Day Name 
Normally, the day of the week appears in the icon. You can disable 
this option by clicking on the shaded toggle button. 

Full Day Name 
Normally, the day of the week that appears in the icon is in an 
unabbreviated form. You can cause day names to be abbreviated 
by disabling this option. 

Show Time 
Normally, the time appears in the icon. You can disable this 
option by clicking on the shaded toggle button. 

Saving Customized Features 
To save your customized features, choose Save Settings from 
the Customize menu. This causes your new settings to be used 
whenever you start a Calendar session. The size and placement of 
all displays are also saved. 

To restore your settings to the currently saved defaults, drag the 
pointer to the submenu icon next to the Customize menu item, 
and release MBI over the Restore Settings menu item. 

To restore your settings to the system defaults, drag the pointer to 
the submenu icon next to the Customize menu item, and release 
MBI over the Use Defaults menu item. 
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Changing the Shape of a Display 
You can change the size of any Calendar display by using the 
window's size button. If you resize the display to be smaller than 
the elements inside it, Calendar will try to rearrange the elements 
to fit the new size, but some of the elements may not be visible. 
For example, if you resize the year display so that is only big 
enough to display eight months, Calendar will display only the 
next 8 months. 

To save the size settings from one session to the next, use the 
Save Settings menu item on the Customize menu. 

Exiting from the Calendar 
m 

Open ... 

Open in New ... 

Include ... 

Name As ... 

Delete ... 

Print... 

I Exit 

To exit from Calendar and close all open calendars, choose the 
Exit menu item from the File menu. 
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3 
Using the Cardfiler 

The Cardfiler lets you create an electronic box of index cards. This 
electronic file box is called a card file. Card files contain cards, 
which can hold any kind of information you like, such as names, 
addresses, and telephone numbers. For example, you could have 
a card file called Food filled with cards that contain recipes and 
names of restaurants. 

By organizing your index cards into sets (card files), you can keep 
one group of cards separate from another group, for example, your 
business cards and your personal cards. 

This chapter describes how to: . 

• Start the Cardfiler 

• Create and add cards to a card file 

• View topics in a card file 

• Search a card file for text 

• Edit a card 

• Incorporate graphics 

• Open an existing card file 

• Save a card file 

• Merge two card files 

• Exit from the Cardfiler 
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Starting the Cardfiler 
To start the Cardfiler, choose Cardfiler from the Session Manager 
Applications menu, or enter the following command in a DECterm 
window: 

% dxcardfiler & 

The Cardfiler displays an empty card file in the Cardfiler window. 
Initially, the card file is empty, but it fills up with index topics as 
you add cards. 

~I Card filer: untitled IbBl611 
File Search Card Help 

0 
,-

'-
Q 

Opening a Card File 
You can either create a card file and then add cards to it, or you 
can create cards and then save them into a card file. For example, 
you can create a card file called "Clients" and then fill it with 
cards that contain names and telephone numbers of your business 
clients. To create a new card file or open an existing one: 
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Cardfiler displays a dialog box. 



I Carofiler: Open I~ 
File filter 

I *·ctard 

Files in 

.0 I Filter I 
~II OK II 

I Cancel I 
'0 

<lCJr> 0 

Selection 

I·caret 

2 To create a new card file, click on the Selection text field 
and enter the name of the card file you want to create, for 
example, Clients. By default, Card:filer adds the extension 
.card to card file names. 
Click on OK. Card:filer displays a message telling you the file 
was not found and that a new file is being opened. Click on 
the Acknowledged button to dismiss this message. 
To open an existing card file, select the name of the file you 
want to open. 

Use the scroll bars to view a complete list of your card files. 
The card file name you select is displayed in the text field. 
The new card file is displayed. 

If you try to open another card file without first saving any 
changes you made to the current file, a dialog box is displayed, 
asking whether you want to save your changes. Click on the Yes 
button to save your changes. Click on the No button to discard 
your changes. 

Adding a Card 
You start a file of index cards by adding a card. As you add cards, 
they are sorted alphabetically according to the topic you type in 
the card's index field. By displaying the topic of each index card, 
the card file window lists the contents of the card file. To add a 
card: 

Choose Create Card... from the Card menu. 
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II 

The Cardfiler displays a blank index card in the Card window. 
The dialog box prompts you to type the topic of the new index 
card. 

Create Card I~I 

Index for this card 

I Cancel I 

2 Enter the new topic under which you want the card filed. 

3 Press I Return lor click on the OK button. 

The text you just typed is added to the title bar at the top of 
the Card window and to the contents of the Cardfiler window. 
You can add information to the new card. 

4 Type any information belonging on the index card, for 
example, an address. 

Type the text as you want it to appear, using the Return key, 
space bar, and Tab key to format it. Cards can contain up to 
4000 characters and up to 64K bytes of graphics. 

5 When you are finished with the index card, choose Close menu 
from the file menu. 

The Card window is closed and the contents of the index card are 
added to your card file. 

You can open another index card in the card file without closing 
the current card. When you choose the Create Card ... menu 
item from the Card menu in the Cardfiler window, the Cardfiler 
automatically saves any changes you made to the current index 
card and returns it to the card file before it opens a new card in 
the file. 

If you create a series of cards before you have created the card file 
in which you want to place them, you can save them into a new 
cardfile. 

To save cards into a new card file: 

From the empty, untitled card file you see when you start the 
Cardfiler, create your cards. 

2 Choose either Save or Save As... from the File menu. 
Cardfiler displays a dialog box. 
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3 In the Selection text field, enter the name of the card file you 
want to put your cards in. 

For example, if you created a series of cards about famous 
baseball players, you could create a card file called Baseball. 

4 Click on' OK. 
The new card file name is displayed at the top of the Cardfiler 
window with a list of all the index cards in that card file. 

liewing the Contents of a Card File 
Although you can look at only one index card at a time, you can 
easily switch from one card to another by selecting a card from 
the card file window. When your card file contains too many cards 
to list in a window at a time, you can use the scroll bar to move 
through the file. You can also search the contents of a card file for 
a given text string. 

Opening an Existing Card 
To display the contents of a card you have already created, select 
the card from the card file window by pointing to its index line 
and clicking MBI. 

The card's index topic becomes shaded and the contents of the 
card are displayed in the Card window. 

Scrolling Through a Card File 
As you accumulate cards, they cannot be listed all at once in the 
card file window. The scroll bar along the left side of the card file 
lets you scroll through the list of the index cards in your file. To 
scroll through the list of index cards in your file, click and hold 
MBI on the stepping arrow. 

Finding Text 
You can search a card file for any text string. The text can be a 
word, a number, or any other characters that you can type on your 
keyboard. Because the Cardfiler treats spaces as text, you can 
search for two or more words. 

The Cardfiler searches either the index topics or the contents of 
the index cards. 

To search the index topics in a card file for specific text: 

Choose Search Index... from the Search menu in the card file 
window. 
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Cardfiler displays a dialog box. 

Search Index I !!ill 

II 
Go to Card 

I Cancel I 

2 Type the text string you want located. 

3 Press I Return lor click on the OK button. 

The Cardfiler searches the topics of all index cards in the file and 
displays the first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text in its index field. 

To search the contents of each card in the file for specific text: 

II 

Choose Search Card... from the Search menu in the card file 
window. 

Cardfiler displays a dialog box. 

Seal'Ch Card I !!ill 

Find Text 

I Cancel I 

2 Type the text string you want located. 

3 Press Return or click on the OK button. 

The Cardfiler searches all index cards in the file and displays the 
first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text. 
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Editing a Card 

Create Card .•. Alt/N 

Duplicate 

Rename ••• 

Delete Alt/D 

Undelete 

Next Next 

Previous Prev 

The Cardfiler editing commands let you copy, delete, and 
rearrange text on an index card. If you decide you do not want to 
save your edits, Cardfiler can restore the card to its original state. 

Renaming a Card 
To change the topic of an index card, you modify the index line: 

Select the card you want to rename from the card file window 
by pointing to it and clicking MB1. 

2 Choose Rename... from the Card menu on the Card window. 

3 Use the arrow keys to move the text cursor and the Delete key 
to erase unwanted text. 

4 Type the new topic under which you want the card filed. 

5 Click on the OK button. 

The card is renamed and remains open. If you want to close the 
card, choose the Close menu item from the card's File menu. 

Moving the Text Cursor 
When you create a new card, the text cursor appears in the upper 
left corner of the card window. When you open an existing card, 
the text cursor remains where it was when you last edited the 
card. 

If you are creating a new card and want to move the text cursor, 
use the Return key or place the pointer where you want the text 
cursor and click MB 1. You can use this method to move the text 
cursor on an existing card, or you can use the arrow keys to move 
the text cursor anywhere in the existing text (except to the index 
line). 

Selecting Text 
In order to delete, move, or copy text, you must first select that 
text. Select the text by pressing and holding MB1, dragging the 
pointer over the text, and releasing MB1. This highlights the 
selected text. The Cardfiler stores this text until you tell it what 
to do. 
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File Edit Search Card 

A must for any visitor. Pike Place Market is a 
bustling mil( of fish and farmer's markets, 
arts and craft shops, 
and street musician 

Take the Stewart St. el(it off 1-5 South, 
head down Stewart until you can't go any 
further; that's Pike Place Market. 

I Previous I I Nel(t I 

Deleting Text 
To delete small amounts of text on your card, use the Delete 
key. If you selected text for deletion, press any key to delete the 
highlighted text. 

Moving Text 
Because the Cardfiler saves the last text you selected and deleted, 
you can move text from one location to another on a card or 
between cards. 

To move text on a card: 

Select the text you want moved to another location on the 
card. 

2 Choose Cut from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MB l. 

4 Choose Paste from the Edit menu. 
The deleted text appears in the new location. 

To move text from one card to another: 

1 Select the text you want to move to another card. 

2 Choose Cut from the Edit menu. 

3 From the card file window, click on the card to which you want 
to move the text. 
The new card is opened. 
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4 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MBI. 

5 Choose Paste from the Edit menu. 
The selected text is inserted in the new location. 

Copying Text 
Because the Cardfiler keeps track of your selected text, you can 
copy text from one location to another on a card and between 
cards. 

To copy text on a card: 

Select the text you want copied to another location on the 
card. 

2 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MBI. 

3 Click MB2. 

The selected text is copied to the new location. 

To copy text from one card to another: 

Select the text you want copied to another card. 

2 Choose Copy from the Edit menu to store the copied text. 

3 From the card file, click on the card to which you want to 
move the text. 
The new card is opened. 

4 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MB l. 

5 Choose Paste from the Edit menu. 

The text is copied to the new location. 
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Print 
Print... Alt/p 

I Include Image ... Alt/O I .................................... 
Close Alt/Q 

Incorporating Graphics 
You can add graphics, such as those you create with the Paint 
program, to Cardfiler index cards. The Cardfiler places a graphic 
at the top of a card, keeping the picture's original size, and 
relocates text to the remaining space. 

To incorporate a graphic that has been saved as a file into a card: 

1 Open a card. 

2 Choose Include Image... from the Card window's File menu . 

Cardfiler displays a dialog box that lists all files in the curren1 
directory that have the file name extension DDIF. (DDIF files 
are created by the Paint application by default.) 

3 Select one of the listed files, display a different set of files 
using the file filter, or type the name of the file you want in 
the Selection text entry field. 
The graphic is displayed on your card. If it is larger than the 
current size of your index card, you can display the entire 
graphic by enlarging the card with the resize button. 

To copy part or all of a graphic directly from the Paint application: 

Display the graphic you want to use in the Paint application 

2 Select the portion of the graphic you want to copy to your open 
card. 

3 Choose Cut or Copy from Paint's Edit menu. Cut causes the 
graphic to disappear from the Paint window, whereas Copy 
simply makes a copy of it. 

4 Give your open index card input focus by clicking on it. 
Choose Paste from the Edit menu. 
The graphic is displayed on your card. If it larger than the 
current size of the card, you can display the entire graphic by 
enlarging the card with the resize button. 

To erase a graphic from your card: 

Select the graphic by clicking on it. 

You can unselect a graphic by clicking in the text portion of 
the card. 

2 Choose Clear from the Edit menu. 

Cardfiler erases the graphic. You can restore it by 
immediately choosing Undo from the Edit menu. 
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_aving a Card File 

Open .. . 

Merge .. . 

Save 

Save As ... 

Print 

Print ... 

Save Geometry 
Use System Defaults .................................. 
Quit 

Whether you create a new card file or make changes to an existing 
card file, such as adding or deleting a card or changing any 
information on a card, you need to save that card file when you 
are done working with it. 

To save a new card file or change the name of an existing one: 

Choose Save As... from the File menu in the card file window. 
Cardfiler displays a dialog box, prompting you for the name of 
the file. 

Cardfiler: Save As l[g 
File filter 

\ *·tJard 

Files in 

61 Filter I 

~oq I Cancel I 
0 

<:JD[)O 

Selection 

\. car4 

2 U sing the I Delete I and arrow keys, delete any text in the 
Selection text field and type the name of file. The default file 
type for card file names is card. 
Give the file a name that you can easily recognize. For 
example, if the card file contains the numbers of your business 
associates in Rome, you might name the file rome. card. 
Giving the file name an extension of .card lets you recognize 
that this is a card file. 

3 Press I Return I or click on the OK button. 
You are returned to the card file window. If you saved a new 
card file, notice that the name of the card file in the title 
bar has changed from untitled to rome.card. If you saved an 
existing card file, the card file name is replaced by rome.card. 

To save the current card file, choose Save from the File menu in 
the card file window. 
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To save the current card file under a new file name: 

1 Choose Save As... from the File menu in the card file window. 

2 Using the Delete and arrow keys, delete any text in the text 
field and type the file's new name. 

3 Press I Return I or click on the OK button. 

You are returned to the card file window. Notice that the title bar 
contains the new card file name. 

Merging Card Files 
You can merge the contents of the current file with another file, 
resulting in a card file that combines and sorts the contents of 
both files. The card file whose contents were merged with the 
current card file remains unchanged. 

Choose Merge... from the File menu on the card file window. 

Cardfiler displays a dialog box. 

Card filer: Merge I~ 
File filter 

, *·clard 

Files in 

61 Filter I 

~ I OK ~ 
1 Cancel I 

0 
<jCJI) 0 

Selection 

,.car4 

2 Select the name of the file you want to merge with the current 
file. Use the scroll bars to view a complete list of your files. 

The file name you selected is displayed in the text field. 

3 Press I Return I or click on the OK button. 

The contents of the two card files are merged and sorted 
alphabetically. 
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Exiting from the Cardfiler 

Open ••• 

Merge ••. 

Save 

Save As .•• 

Print 

Print ... 

Save Geometry 

Use System Defaults 

I Q~it'"'''''''''''''''''''''''' 

If you changed the size or screen position of the Cardfiler and 
would like to save those settings, choose Save Geometry from the 
File menu before exiting. To restore the system default settings, 
choose Use System Defaults from the File menu. 

To exit from the Cardfiler, choose Quit from the File menu in the 
card file window. 

If you have not saved any changes or additions to the current 
file, Cardfiler displays a dialog box, asking whether you want to 
save your changes. Click on the Cancel button to return to the 
Cardfiler window. 

Caution I~I 

o 
Do you want to save the current data 

before quitting? 

[EJ [!!] I Cancel I 

Click on the Yes button to save your changes and exit from the 
Cardfiler, or Click on the No button to exit from the Cardfiler 
without saving your changes. To return to the Cardfiler window, 
click on the Cancel button. 
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4 
Using the Clock 

The Clock displays the time (in analog or in 12- or 24-hour 
digital formats) and the date. You can change this display to suit 
your needs. You can also set the Clock's alarm to remind you of 
appointments. 

This chapter describes how to: 

• Start the Clock 

• Customize the Clock display 

• Set the alarm 

• Exit from the Clock 

Starting the Clock 
To start the Clock, choose Clock from the Session Manager 
Applications menu, or enter the following command from a 
DECterm window: 

% dxclock& 

The Clock is displayed on your screen. You can move and change 
the size of the Clock as you wish. 

Ell Clock 1h!]1Iii] 

Oct 11 Wed 
............. '. 

2:50 pm 
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Changing the Clock Display 
You can customize the Clock display to include any combination of 
the date and time areas. 

To change the Clock display: 

1 Place the pointer anywhere in the Clock display. 

2 Press and hold MB2. 

Clock displays a pop-up menu. 

::~I Clock 10161 

.. ',-". Oct 11 Wed 

Settings .•• 

Save Settings 

Use System Settings 

Help [~ 

Quit 

3 Choose the Settings... menu item. 

Clock displays a dialog box. 

I Clock Settings ~I 

I 

Components 

III Analog [I Digital III Date 

o 24 Hour Digital Time 

Alarm Settings 

OAlarm ~ ~ 

Alarm Message 

@AM 

OPM 

I Cancel I 

Shaded toggle buttons indicate the current settings. Click MBI on 
a toggle button or its label to change the setting. For example, if 
you want only the analog clock displayed and the Analog, Digital, 
and Date toggle buttons are shaded, click on the Digital and Date 
toggle buttons to disable those settings. If you want the clock 
to display 24-hour digital (military) time, enable that setting by 
clicking on 24 Hour Digital Time. 

Click on the OK button to save any changed settings. Click on 
the Cancel button to return to the date and time display without 
changing any settings. 



You can also display the Settings ... dialog box directly, without 
first displaying the pop-up menu by double-clicking MBI 
anywhere on the Clock display. 

To save your customized settings and the size and placement of 
the clock on the screen: 

Make any desired changes to the size, position, and settings of 
the clock. 

2 Click MBI on the OK button. 

3 Press and hold MB2 to display the pop-up menu. 

4 Choose Save Settings. 

To restore the system defaults, choose Use System Settings 
from the pop-up menu. 

Setting the Alarm 
You can set the alarm to remind you of an appointment. To set 
the alarm from the Settings dialog box: 

Click MBI on the alarm toggle button to switch the alarm on. 

2 Move to the hours field and type the hour at which you want 
the alarm to go off. You can either use a 12-hour clock, in 
which case you need to specify AM or PM, or you can use a 
24-hour clock (military time). 
Use I Delete I to erase any number already entered or to correct 
typing mistakes. 

3 Move to the minutes field and finish entering the time you 
want the alarm to go off. 

4 If you are using a 12-hour clock, click on either the AM or PM 
option button. 

S To display a message on your screen when the alarm goes 
off, move to the alarm message field and type your message. 
Alarm messages may contain up to 200 characters. 

6 Click on the OK button to save the settings. Click on the 
Cancel button to return to the date and time display without 
changing any settings. 

When the alarm goes off, a box displays the alarm message on 
your screen. Click on the Acknowledged button to clear the alarm 
message from your screen. 
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Exiting from the Clock 
Settings ... 
Save Settings 
Use System Settings 
Help 

QUit 
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To exit from the Clock, choose the Quit menu item from the 
Clock's pop-up menu. 



5 
Using the CDA Viewer 

The CDA Viewer lets you view DDIF (DIGITAL Document 
Interchange Format) files. DDIF is a standard format for the 
storage and interchange of compound documents as defined by 
Digital's Compound Document Architecture (CDA). Compound 
documents contain multiple elements, for example, text and 
graphics. DDIF files cannot be viewed in the same way as 
ordinary text files. 

The CDA Viewer displays only DDIF files. If you specify a file 
that is not a DDIF file, for example, a text (ASCII) file, the file is 
converted to DDIF before it is displayed. 

This chapter describes how to: 

• Start the CDA Viewer 

• Display DDIF files 

• Change processing options 

• Exit from the CDA Viewer 

Starting the CDA Viewer 
To start the CDA Viewer and view a file, choose CDA Viewer from 
the Session Manager Applications menu or enter the following 
command in a DECterm window: 

% dxvdoc & 
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The CDA Viewer displays its main window and its Open file dialog 
box. The main window is where you view DDIF files. 

iP CDA Viewer: ® Digital Equipment Corporation. 1988, 1989. All Rights Reserved. b!:I'6: 
File Help 

<II 

Open II!iI 
File Filter 

I~·ddif 

Files in 

<lDI>D 

Open File 

II 

File Format 

I ddi~ _0 
dtif n 
text U 

'0 

I Options File... II Paper Size... I 

Filter 

I[J[JI 

I Cancel I 

.c 

II> 
Page 0 of 0 

Viewing DDIF Files 
When the Viewer starts, it displays the Open file dialog box that 
prompts you for the name of the file you want to view. The files 
list box lists the names of any DDIF files in the current directory. 

To open and view a file in the CDA Viewer window, you must 

In the File Format text field, type in the format of the file you 
want to view. 
Type TEXT if you want to view a TEXT file. Type DDIF if you 
want to view a DDIF file. 
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2 Double-click on the file name you want to view, and then click 
on the OK button. 
The CDA Viewer displays the contents of the file you specified. 
The title bar contains the name of the file currently viewed. 

If you want to view a DDIF or text file that is not listed, type the 
name of that file in the Open File text field and click on the OK 
button. Or, use the File Filter text entry field to list a subset of 
files that you can then select from. For example, to list all files in 
another directory with the file extension .ddif, type the complete 
directory specification, for example, Ijones/project/*.ddif, in the 
File Filter text entry field and click on the Filter button. Then 
double click on the file name of the file you want to view. 

To display information about the file you are currently viewing, 
choose Document Information... from the File menu. The CDA 
Viewer displays the product name, title, author, version, and date 
the file was created. 

To display diagnostic information about the file you are viewing, 
such as warnings and errors that occurred while you were 
formatting the file, choose Diagnostic Information... from the File 
menu. 

Changing Processing Options 
See the UWS 
r-eference page 
rlxvdoc(lX) 
ror more 
information 
2bout processing 
')ptions. 

By means of an options file, you can change the way the CDA 
Viewer processes a file for viewing. You specify the options file, 
which contains the various options you want applied, by clicking 
on the Options File... button in the Open dialog box. The Options 
File dialog box is displayed. 

Options rill' I~ 

Options File Filter 

1~·cda_oPtions 

Files in 

6 I Filter I 
[~ OK I 
Q I Cancel I 

<)01> 0 

Options File 

II 
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The Files list box lists the option files available in the current 
directory. Double click on the options file you want applied and 
then click on the OK button. These options will be used when the 
Viewer converts your file to DDIF format. 

If you do not specify an options file, preset processing options are 
used. 

Changing the Paper Size 
In addition to setting different processing options, you can specify 
paper size formatting options for the next document that you 
open. To specify the paper size, click on the Paper Size ... button 
in the Open dialog box. The Paper Size dialog box is displayed. 

_ Paper Size I~ 

Default Paper Size 

0. Width L 
~ Height L 
U @ characters 
Q 0 inches 

A2 

AO 

Al 

A3 
'-------'--' 0 mm 

o Override Document Format 

I Cancel I 

By default, the CDA Viewer formats a document according to the 
information stored in the file. If you want to look at a document 
and override the format information stored in the file, click on 
the Override Document Format toggle button. If you want to see 
what the document would look like specifying a default paper size, 
click on one of the paper sizes in the Paper Size list box, or enter 
a paper size of your own. 

The processing options, paper size, and override format choice 
only apply to the next file you open. They do not immediately 
change the appearance of the document currently displayed. Click 
on the OK button to use these options for the next document that 
you open. 
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:Iosing a File 
When you have finished viewing a file, close it by choosing the 
Close menu item from the File menu. This keeps the CDA Viewer 
active for you to open another file. If you open another file without 
closing the current one, the CDA Viewer closes the current file 
before opening the next one. 

:xiting from the CDA Viewer 

Open ••• 

l)otIll'M~nt IlIfoI'llHUion." 

niagnostil: lui"OrllH\tion ... 

Quit 

To exit from the CDA Viewer, choose the Quit menu item from the 
File menu. If you did not close the last file you viewed, the CDA 
Viewer closes it before exiting. 
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6 
Using DECterm 

DECterm is a VT300-series terminal emulator. 

This chapter describes how to: 

• Create a DECterm window 

• Customize DECterm operating features 

• Copy information 

• Clear and resize DECterm windows 

• Compose special characters 

• Exit from DECterm 

In addition to using these features, you can program DECterm 
text features and ReGIS and sixel graphics. See the DECterm Text 
Programming Manual and the DECterm Graphics Programming 
Manual for detailed information about using these features. 

:reating a DECterm Window 
To create a DECterm window, choose DECterm from the Session 
Manager Applications menu. 

A DECterm window is displayed. 
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DECterlll - Copyright 1£1 1988. 1989 Digital Equipment Corporation. All Rights Reserved. I 
Commands Edit Customize Help 

Give DECterm input focus by pointing to it and clicking MBl. 

Customizing DECterm 

Window ... 

Display ••• 

General .•. 

Keyboard ••. 

7-Bit NRCS Selection ... 

Graphics ••. 

Use Last Saved Settings 

Use System Defaults 

Use Saved Settings From ... 

Save Current Settings 

Save Current Settings As •.• 
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The DECterm customize menu lets you choose operating features 
for your DECterm window and lets you save those features. With 
the Customize menu, you can change: 

• Window features, such as font used to display text, or the 
window size 

• Display features, such as the shape of the cursor or whether 
scroll bars appear 

• General features, such as your terminal type and character 
set 

• Keyboard features, such as margin and warning bells or the 
behavior of certain keys (like ~) 

• The 7-Bit National Replacement Character Set (NRCS) that 
corresponds to your keyboard 

• Graphics features, such as as color map entries and color 
planes 

Choosing an item from the Customize menu causes DECterm to 
display a dialog box. In all DECterm dialog boxes, shaded buttons 
indicate the current settings. 



In DECterm dialog boxes: 

• Click MBI on a button or its label to change the setting. 

• Click on the Apply button to view your changes without 
closing the dialog box. 

• Click on the OK button to apply your changes and close the 
dialog box. 

• Click on the Cancel button to cancel your changes. 

Customizing a DECterm Window 
Choose Window... from the Customize menu to change DECterm 
window features such as font or terminal size. DECterm displays 
a dialog box. 

_ DECtenn: Window ~ 

o Auto Resize Terminal 
iii Auto Resize Window 
iii Terminal Driver Resize 

o Big Font 
@ Little Font 

o Normal Font (80 Columns) 
o Condensed Font (132 Columns) 
@ Normal/BO, Condensed/132 

, DEcterni 

Window Title 

Terminal Size 

~ Rows 

G 
o 
o 

l!1. Columns 

~ 
~ 

,-I D_Ect_e_r_ni________ I~I I Apply II Cancel I 
Icon Name • - -

From the Window dialog box, you can customize the following 
features: 

Auto Resize Terminal 
Normally, changing the window size does not change the size of 
DECterm. Clicking on Auto Resize Terminal causes the size of 
DECterm to match the window size, if you resize the window. 

Auto Resize Window 
Normally, changing the size of DECterm (the number of rows and 
columns) automatically changes the window size. You disable this 
option by clicking on Auto Resize Window. When Auto Resize 
Window is disabled, a change in the size of DECterm does not 
result in a change in the window size. If DECterm is larger than 
the window, information may be outside the window boundary; 
this information is not displayed. 
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Terminal Driver Resize 
Normally, when you modify the terminal driver, the terminal size 
also changes. Clicking on Terminal Driver Resize disables this 
option. 

Big Font 
Normally, DECterm displays a 14-point font (10-point font on 100 
dots-per-inch systems). Clicking on the Big Font option causes 
DECterm to display an lS-point font. 

Little Font 
Normally, DECterm displays a 14-point font. Clicking on the Big 
Font option causes DECterm to display a larger font. 

Normal Font (80 Columns) 
Clicking on the Normal Font (SO Columns) option causes the so 
column font to be used, regardless of the number of columns. The 
default option is Normal Font/SO, Condensedl132. 

Condensed Font (132 Columns) 
Clicking on the Condensed Font (132 Columns) option causes a 
condensed font to be used, regardless of the number of columns 
selected. The default font size is Normal/SO, Condensedl132. 

NormaV8~ Condensed/132 
The default font size is Normal/SO, Condensedl132. This option 
causes the font size to adjust to match the terminal width. The 
Normal Font is used when there are SO columns or less and the 
condensed font is used when there are more than SO columns. 

Window Title 
Normally, the DECterm title appears in the title bar. You can 
change what appears in the title bar by entering text in this field. 

Icon Name 
Normally, the DECterm name appears in the icon. You can change 
what appears in the icon by entering text in this field. 

Terminal Size 
The default terminal size is 24 rows and SO columns. You can 
change the terminal size by entering a number in the row or 
column field. You can also set the column and row to be any 
number from 1 to 132 by clicking on the text entry field, deleting 
any existing numbers, and entering the new settings. 



Customizing a Display 
Choose Display... from the Customize menu to modify display 
features such as the type of cursor or scroll bars. DECterm 
displays a dialog box. 

I DECtenn: Display II!Il 

o Record Lines Off Top 
D Vertical Scroll Bar 
D Horizontal Scroll Bar 
[j] Vertical Cursor Coupling 
o Horizontal Cursor Coupling 
o Auto Wrap 
III Display Cursor 
[j] Cursor Blink 

Batch Scroll 1,00 Lines 

Record 1 50~ Lines Off Top 

@ Dark Text, Light Background 
o Light Text, Dark Background 

@ No Status Display 
o Host Status Display 

@ Block Cursor 
o Underline Cursor 

iQiJI I Apply I 1 Cancel I 

From the Display dialog box, you can customize the following 
features: 

Record Lines Off Top 
Normally, lines that are scrolled off the top of the DECterm 
window are saved. To view these lines, use the vertical scroll bar. 
Click on Record Lines Off Top to disable this option. 

Vertical Scroll Bar 
Normally, DECterm displays vertical scroll bars. Click on Vertical 
Scroll Bar to disable this option. 

Horizontal Scroll Bar 
Normally, DECterm does not display horizontal scroll bars. Click 
on Horizontal Scroll Bar to display a horizontal scroll bar at the 
bottom of your DECterm window. 

Vertical Cursor Coupling 
Normally, when you change the vertical size of a window or 
terminal, the cursor remains visible. For example, if the display 
contains 24 rows and you shrink it to 5 rows, the cursor remains 
visible; you can still enter text. Click on Vertical Cursor Coupling 
to disable this option. 

Horizontal Cursor Coupling 
Normally, when you change the horizontal size of the window 
or terminal (for example, from 132 columns to 80 columns), the 
cursor is not visible. Click on Horizontal Cursor Coupling to 
change this option. 
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Auto Wrap 
Normally, when the cursor reaches the right margin of the window 
it stops. Subsequent characters you type will delete the existing 
character. Clicking on Auto Wrap causes the cursor to move, start 
a new line, and display new characters. 

Display Cursor 
Normally, DECterm displays a cursor. Click on Display Cursor to 
disable the cursor. 

Cursor Blink 
Normally, the DECterm cursor is a blinking cursor. Click on 
Cursor Blink to display a steady cursor. 

Batch Scroll 0 Lines 
Normally, you cannot scroll a specified number of lines. Entering 
a number in place of zero (0) increases the number of lines you 
can scroll to match the terminal size. 

Record 500 Lines Off Top 
Normally, you can save 500 lines that are scrolled off the top of 
your DECterm window (when the Record Lines Off Top option is 
enabled). Enter a number from 1 to 9999 to change the number of 
lines to be saved. 

Dark Text, Light Background 
Normally, DECterm displays dark text and a light screen 
background. 

Light Text, Dark Background 
Clicking on the Light Text, Dark Background option causes 
DECterm to display dark text and a light screen background. 

No Status Display 
Normally, you do not receive host status messages when you use 
DECterm to log onto a host system. Host status messages, when 
this option is enabled, appear on the bottom line of your terminal 
window display. 

Host Status Display 
Click on Host Status Display to receive host status messages. 
These messages appear on the bottom line of your terminal 
display. This option is available only on VT300-series terminals. 

Block Cursor 
Normally, the cursor displayed in your DECterm window is 
shaped like a block. 



For detailed 
information 
about defining 
keys, see the 
DECterm Text 
Programming 
Manual. 

Underline Cursor 
The default cursor shape for DECterm is a block. Click on the 
Underline Cursor option to get an underline cursor. 

Customizing General Features 
Choose General... from the Customize menu to change general 
features such as the type of terminal and character set. DECterm 
displays a dialog box. 

DECtenn: General ~I 

o Newline 

o Lock UOKs 

o Lock User Features 

@ Normal Cursor Keys 

o Appl Cursor Keys 

TerminallD 

@ OEcterm 10 

o VT340 ID 
o VT330 ID 

o VT320 ID 
o VT240 10 

o VT220 ID 
o VT125 ID 

o VT102 10 

o VT101 10 

o VT100 ID 

@ Numeric Keypad 

o Application Keypad 

@ UPSS OEC Supplemental 

o UPSS ISO Latin 1 

@ 8-Bit Multinational Characters 

o 7-Bit NRCS Characters 

o VT300 Mode, 8-Bit Controls 
@ VT300 Mode, 7-Bit Controls 

o VT100 Mode 
o VT52 Mode 

1001 I Apply I I Cancel I 

From the General dialog box, you can set the following features: 

Newline 
Normally, when DECterm receives a line feed (LF), form feed (FF), 
or vertical tab (VT) character, the cursor moves to the first column 
of the next line. When you press the Return key, DECterm sends 
both a carriage return (CR) and line feed. 

Click on Newline to disable this option. When disabled, if 
DECterm receives an LF, FF, or VT character, the cursor moves to 
the current column of the next line. When you press the Return 
key, DECterm sends only a carriage return. 

Lock UDKs (User Defined Keys) 
Your keyboard contains keys you can define for your own use. 
Normally, the host system can change the function of the key you 
have defined back to the default. Clicking on Lock UDKs sets 
the user-defined keys so that the host system cannot change your 
definitions. 
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Lock User Features 
DECterm lets you change the Auto Repeat option and the 
Foreground and Background Display option. The host system 
can override theses options unless you click on the Lock User 
Features option. 

Normal Cursor Keys 
By default, the Normal Cursor Keys option is on. This causes the 
arrow keys to move the cursor up, down, left, and right. 

Appl Cursor Keys 
By clicking on Application Cursor Keys, you can override the 
Normal Cursor Keys default to set the arrow keys to application­
specific functions. 

TerminallD 
You can let the host system know specific terminal operating 
attributes by clicking on a Terminal ID option. The default is 
DECterm ID. 

You can choose the following terminal IDs: 

DECterm ID 

VT220 ID 

VT340 ID 

VT125 ID 

Numeric Keypad 

VT330 ID 

VT102 ID 

VT320 ID 

VT101 ID 

VT240 ID 

VT100 ID 

Normally, the Numeric Keypad option is set. This means that 
pressing a numeric key displays the character that appear on that 
key. 

Application Keypad 
Click on Application Keypad to cause user- or application-defined 
characters to be displayed. 

UPSS DEC Supplemental 
Normally, DECterm uses the DEC Multinational Character Set. 

The ASCII character set makes up the first half of the DEC 
Multinational Character Set. Figure 6-1 illustrates the ASCII 
character set (characters with decimal values 0 through 127). 

The first column identifies the character as you would enter it on 
a VT300-, VT200-, or VT100-series terminal or as you would see it 
on a printer (except for the nonprintable characters). The second 
half of each column identifies the character by the binary value 
of the byte; the value is stated in three radixes: octal, decimal, 
and hexadecimal. For example, the letter A has a storage value 



of hexadecimal 41 (a bit configuration of 01000001), equivalent to 
101 in octal notation and 65 in decimal notation. 

Figure 6-1 DEC Multinational Character Set, Part I 

Column 0 1 2 3 4 5 6 7 
b8 Bits 0 0 0 0 0 0 0 0 

b7 0 0 0 0 1 1 1 1 
b6 0 0 1 1 0 0 1 1 

b5 0 1 0 1 0 1 0 1 
Row b4b3 b2 b1 

0 20 40 60 100 120 140 160 
0 o 0 0 0 NUL 0 DLE 16 SP 32 0 48 @ 64 P 80 96 P 112 

G 10 20 30 40 50 60 70 
1 21 41 61 101 121 141 161 

1 o 0 0 1 SOH 1 DC1 17 I 33 1 49 A 65 Q 81 a 97 q 113 
1 11 21 31 41 51 61 71 
2 22 

" 
42 62 102 122 142 162 

2 o 0 1 0 STX 2 DC2 18 34 2 50 B 66 R 82 b 98 r 114 
2 12 22 32 42 52 62 72 
3 23 43 63 103 123 143 163 

3 o 0 1 1 ETX 3 DC3 19 # 36 3 51 C 67 S 83 C 99 s 115 
3 13 23 33 43 53 63 73 
4 24 44 64 104 124 144 164 

4 o 1 o 0 EOT 4 DC4 20 $ 36 4 52 D 68 T 84 d 100 t 116 
4 14 24 34 44 54 64 74 
5 25 45 65 105 125 145 165 

5 o 1 o 1 ENQ 5 NAK 21 % 37 5 53 E 69 U 85 e 101 U 117 
5 15 25 35 45 56 65 75 
6 26 46 66 106 126 146 166 

6 o 1 1 0 ACK 6 SYN 22 & 38 6 54 F 70 V 86 f 102 V 118 
6 16 26 36 46 56 66 76 
7 27 47 67 107 127 147 167 

7 o 1 1 1 BEL 7 ETB 23 39 7 55 G 71 W 87 9 103 W 119 
7 17 27 37 47 57 67 77 
10 30 50 70 110 130 150 170 

8 1 0 0 0 BS 8 CAN 24 ( 40 8 56 H 72 X 88 h 104 X 120 
8 18 28 38 48 58 68 78 
11 31 51 71 111 131 151 171 

9 1 0 0 1 HT 9 EM 25 ) 41 9 57 I 73 Y 89 i 105 Y 121 
9 19 29 39 49 59 69 79 
12 32 52 72 112 132 152 172 

* 10 1 0 1 0 LF 10 SUB 26 42 : 58 J 74 Z 90 j 106 Z 122 
A 1A 2A 3A 4A 5A 6A 7A 
13 33 53 73 113 133 153 173 

11 1 o 1 1 VT 11 ESC 27 + 43 ; 59 K 75 [ 91 k 107 { 123 
8 18 28 38 48 58 68 78 
14 34 54 74 114 134 154 174 

12 1 1 o 0 FF 12 FS 28 44 < 60 L 76 \ 92 I 108 I 124 
C 1C 2C 3C 4C 5C 6C 7C 
15 35 56 75 115 135 156 175 

13 1 1 0 1 CR 13 GS 29 - 45 = 61 M 77 ] 93 m 109 } 125 
D 1D 2D 3D 4D 5D 6D 7D 
16 36 56 76 116 136 156 176 

14 1 1 1 0 SO 14 RS 30 46 > 62 N 78 1\ 94 n 110 - 126 
E 1E 2E 3E 4E 5E 6E 7E 
17 37 57 77 117 137 157 177 

15 1 11 1 SI 15 US 31 I ~~ ? 63 0 79 - ~~ 0 111 DEL 127 
F 1F 3F 4F 6F 7F 

Key ~ CO Codes -~.""I.t---------(As~~i~r~~~iC) ----------91.1 
Character I 133 I Octal ESC 27 Decimal 

L------1...!.l18oW Hex ZK-0347A-GE 

Figure 6-2 illustrates the second half of the DEC Multinational 
Character Set (characters with decimal values 128 through 255). 
The first half of each of the numbered columns identifies the 
character as you would see it on a VT300- or VT200-series 
terminal or printer (these characters cannot be output on a 
VT100-series terminal). 
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Figure 6-2 DEC Multinational Character Set, Part II 

8 9 10 11 12 13 14 15 Column 
1 1 1 1 1 1 1 1 b8 Bits 

0 0 0 0 1 1 1 1 b7 
0 0 1 1 0 0 1 1 b6 

0 1 0 1 0 1 0 1 b5 
b4b3 b2 b1 Row 

~~~ DCS ~~ ~~~ 0 ~~~ A ~~~ ~~~ a ~~~ ~~~ o 0 0 0 0 
80 90 AO BO CO DO EO FO 

~~~ m 241 261 
A ~~~ N ~g~ ~~~ 361 

PU1 I 161 ± 1n it i'i 241 o 0 0 1 1 
81 91 A1 B1 C1 D1 E1 F1 

~~~ ~~~ 242 ~~~ A ~~~ 0 ~~~ ~~~ 362 
PU2 ¢ 162 2 it 0 242 o 0 1 0 2 

82 92 A2 B2 C2 D2 E2 F2 
203 223 243 263 

A 
303 

6 
323 343 363 

131 STS 147 £ 163 3 179 195 211 a 227 6 242 o 0 11 3 
83 93 A3 B3 C3 D3 E3 F3 

~~~ 224 ~~ 264 
A ~~~ 0 

324 
~~ 364 

INO CCH 148 180 212 a 0 244 o 1 o 0 4 
84 94 A4 B4 C4 D4 E4 F4 

NEL ~~ MIt! m ¥ ~: IJ ~~~ A ~~~ 0 ~~~ it ~~~ 0 m o 1 o 1 5 
85 95 AS B5 C5 D5 E5 F5 

SSA ~~~ SPA ~~g ~~~ 11 m IE ~~~ 6 ~~~ ae ~~g () ~~~ o 1 1 0 6 
86 96 A6 B6 C6 D6 E6 F6 

ESA ~g~ EPA ~5~ § ~~~ ~~~ C; ~~~ CE ~~~ c; ~~i ce ~~~ o 1 1 1 7 
87 97 A7 B7 C7 D7 E7 F7 

HTS ~~~ ~~~ ~~ ~~~ E ~6g 0 
33U 

e ~~~ ~~ 8 XI 216 B 1 0 0 0 
88 98 A8 B8 C8 D8 E8 F8 

HTS ~~~ ~~~ © ~~~ , ~~~ E ~~~ U ~~~ e 
3:.1 

U ~~~ 9 233 1 0 0 1 
89 99 A9 B9 C9 D9 E9 F9 

VTS ~~~ ~~~ I ~~~ 2 ~~~ ~ g6~ u ~~~ A ~~~ U ~~~ 1 0 1 0 10 
8A 9A AA BA CA DA EA FA 
213 233 ~~~ ~~~ E 

313 
0 ~~~ ~~~ ~~~ PLO 139 CSI 155 cc " 203 e Q 1 0 1 1 11 

88 98 AB BB CB DB EB FB 
214 234 ~~~ 274 

i 
314 

0 
334 ~~~ ~~~ PLU 140 ST 156 1JI 188 204 220 i 0 1 1 0 0 12 

8C 9C AC BC CC DC EC FC 

RI m osc ~~~ m V2 ~~~ i ~6~ 'Y ~~~ ( ~~~ y m 1 1 0 1 13 
8D 90 AD BD CD DD ED FD 
216 236 ~~~ m i 316 336 ~~~ ~~~ SS2 142 PM 158 206 222 i 1 1 1 0 14 
8E 9E AE BE CE DE EE FE 

SS3 m APe ~~~ m ~ ~~i I ~~~ B ~~~ r ~~~ ~~~ 1111 15 
8F 9F AF BF CF DF EF FF 

j.--C1 codes--... I .... ------(DEC su~~~ri;IGraPhic)-------.j'1 
ZK-0348A-GE 

UPSS ISO Latin 1 
You can override the DEC Multinational Character Set by clicking 
on the UPSS ISO Latin 1 option. This causes the International 
Standards Organization (ISO) Latin 1 Character Set to be used. 
Figure 6-3 illustrates the ISO Latin 1 Supplemental Character 
Set. 



Figure 6-3 ISO Latin 1 Supplemental Character Set 

8 9 10 11 12 13 14 15 Column 

1 1 1 1 1 1 1 1 b8 Bits 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 b6 
0 1 0 1 0 1 0 1 b5 

b4 b3b2 b1 Row 

~~g DCS ~~ NBSP ~~g . ~~~ A ~~~ D ~~~ III ~~~ 6 ~~g o 0 0 0 0 
80 90 AO BO CO DO EO FO 
201 221 241 261 

A 
301 

tit 
321 341 361 

129 PU1 145 i 161 ± 177 193 209 a 225 Ii 241 o 0 0 1 1 
81 91 A1 B1 C1 01 E1 F1 
202 222 242 262 

A 
302 

0 
322 342 362 

130 PU2 146 ¢ 162 2 178 194 210 a 226 0 242 o 0 1 0 2 
82 92 A2 B2 C2 02 E2 F2 
203 223 243 

3 
263 

A 
303 

6 
323 343 363 

131 STS 147 £ 163 179 195 211 a 227 6 243 o 0 1 1 3 
83 93 A3 B3 C3 03 E3 F3 
210 224 244 264 

A 
304 

6 
324 344 364 

INO 132 CCH 148 J:I 164 180 196 212 a 228 0 244 o 1 o 0 4 
84 94 A4 B4 C4 04 E4 F4 
205 225 245 265 

A 
305 

6 
325 345 365 

NEL 133 MN 149 ¥ 165 1.1 181 197 213 II 229 0 245 o 1 o 1 5 
85 95 AS B5 C5 05 E5 F5 
206 226 246 266 306 

6 
326 346 366 

SSA 134 SPA 150 
, 

166 11 182 IE 198 214 IB 230 0 246 o 1 1 0 6 
86 96 

, 
A6 B6 C6 06 E6 F6 

207 227 247 267 307 327 347 367 
ESA 135 EPA 151 § 167 183 C 199 x 215 Q 231 + 247 o 1 1 1 7 

87 97 A7 B7 C7 07 E7 F7 
210 230 .. 250 270 

E 
310 330 350 370 

HTS 136 152 168 184 200 0 216 II 232 9 248 1 0 0 0 8 
88 9J AS B8 C8 08 E8 F8 
211 231 251 271 

E 
311 

U 
331 351 371 

HTS 137 153 © 169 
, 

185 201 217 e 233 iI 249 1 0 0 1 9 
89 99 A9 B9 C9 09 E9 F9 
212 232 252 

2 
272 

~ 
312 

U 
332 352 372 

VTS 138 154 • 170 186 302 218 ~ 234 U 250 1 0 1 0 10 
BA 9A AA BA CA OA EA FA 
213 233 253 273 

E 
313 

0 
333 353 373 

OLP 139 CSI 155 « 171 » 187 203 219 4i 235 Q 251 1 0 1 1 11 
8B 98 AB BB CB DB EB FB 
214 234 254 274 

i 
314 

0 
334 354 374 

PLU 140 ST 156 .. 172 1A 188 204 220 I 236 (j 252 1 1 0 0 12 
8C 9C AC BC CC DC EC FC 
215 235 255 275 

f 
315 

V 
335 355 375 

RI 141 OSC 157 - 173 % 189 205 221 f 237 Y 253 1 1 o 1 13 
80 90 AD BO CD OD ED FD 
216 236 256 276 

i 
316 336 356 376 

SS2 142 PM 158 ® 174 % 190 206 I> 222 i 238 I> 254 1 1 1 0 14 
8E 9E AE BE CE DE EE FE 
217 237 257 277 

"j m 337 357 377 
SS3 143 M1C 159 - 175 i. 191 B 223 r 239 9 255 1 1 1 1 15 

8F 9F AF BF CF OF EF FF 

I---C1 Codes ---1,,,..14r-------,SO Latin-1 ~~~I~r::ntal Graphic -------.1,1 
ZK-0329A-GE 

Note To use these character sets you must set the Character Set mode 
option to 8-Bit Characters. 

8-Bit Multinational Characters 
Normally, the character mode is set to 8 bits for use with the DEC 
Supplemental or ISO Latin 1 Supplemental Character Set. 

7-Bit NRCS Characters 
To use National Replacement Character Sets, click on the 
7-Bit NRCS Character Mode option. This option lets DECterm 
operate in 7 -bit mode, using the national character set selected in 
the 7-Bit NRCS dialog box. The default is the 8-bit Multinational 
Character Set. Figure 6-4 shows the characters in each NRC set 
that differ from the ASCII set. 
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Figure 6-4 National Replacement Character Sets 

National Replacement Character Sets 

Character 
Set 213 4/0 5/11 5/12 5/13 5/14 5/15 6/0 7/11 7/12 7/13 7/14 

ASCII # @ 1\ , 
United £ @ 1\ , 
Kingdom 

Dutch £ % Y Y2 1\ , f 1A " 
Finnish # @ A 0 A 0 e Ii 0 A 0 

French £ Ii ~ § 1\ , e u e 
French # Ii A ~ e 6 e u e Q 
Canadian 

German # § A 0 0 1\ , Ii 0 0 B 

Italian £ § ~ e 1\ u Ii 0 e 
Norwegian! # @ RE. 0 A 1\ , Ee f(} A 
Danish 

Portuguese # @ A C; 0 1\ , Ii ~ 0 

Spanish £ § N t- 1\ , , Ii ~ 

Swedish # E A 0 A 0 e Ii 0 A 0 

Swiss U Ii e ~ e e 6 Ii 0 0 Q 
ZK-1327A-GE 

VT300 Mode, 8-Bit Controls 
Normally, DECterm emulates a VT300-series terminal, using 7-bit 
control characters (codes 0-31). You can change this to VT300 
Mode with 8-bit control characters by clicking on the VT300 
Mode, 8-Bit Controls option. This causes DECterm to translate 
8-bit control characters (codes 128 to 159) for function keys. 
For example, CSIA for the up arrow key. Not all applications 
understand 8-bit control characters. 

VT300 Mode, 7-Bit Controls 
Normally, DECterm operates in VT300 mode with 7-bit control 
characters. This means that function keys are transmitted in 7 -bit 
form. For example, ESC OA for the up arrow key. 

VT100 Mode 
Click on VT100 Mode to cause DECterm to emulate a VT100 
terminal. DECterm operates in 7-bit mode and VT300 terminal 
features are in operation. 

VT52 Mode 
Click on VT52 Mode to override the VT300 Mode and cause 
DECterm to emulate a VT52 terminal. 



Customizing a Keyboard 
Choose Keyboard... from the Customize menu to set keyboard 
features. DECterm displays a dialog box. 

I DECterm: Keylloarrl II!il 

[j] Warning Bell 
D Margin Bell 
II Auto Repeat 
II ctrl-Q, ctrl-S = Hold 

@ <X] Delete 
o <X] Backspace 

@ Comma Key Sends" 
o Comma Key Sends ,< 

@ Tilde Key Sends '­
o Tilde Key Sends ESC 

@ Angle Brackets Key Sends <> 
o Angle Brackets Key Sends '-

ILJiiCJI I Apply II Cancel I 

From the Keyboard dialog box, you can set the following keyboard 
features: 

Warning Bell 
Normally, the keyboard warning bell rings when errors occur. 
Click on Warning Bell to disable this option. 

Margin Bell 
Normally, the margin bell does not ring when the cursor reaches 
the right margin. You can cause it to ring by clicking on Margin 
Bell. 

Auto Repeat 
Normally, continuing to press a key causes the character to be 
displayed repeatedly. Clicking on the Auto Repeat option causes 
only one character to be displayed. 

ctrl-Q, ctrl-S = Hold 
Normally, pressing CtrllS causes the display to stop scrolling and 
pressing CtrllQ causes the display to resume scrolling. Click on 
Ctrl-Q, Ctrl-S = Hold) to disable this option. 

-Q] Delete 
Normally, the <XI Delete key functions as a delete key, deleting 
the character to the left of the cursor. 

-Q] Backspace 
You can override the <XI Delete default by clicking on <XI 
Backspace option. This causes the <XI key to function as a 
nondestructive backspace key. 
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Comma Key Sends" . 
On the North American and Dutch keyboards, the Comma Key 
Sends " option is set. This causes a comma ( ,) to be displayed 
when you press the comma key, whether or not the key is shifted. 

Comma Key Sends ,< 
On the North American and Dutch keyboards, you can override 
the Comma Key Sends" default by clicking on the Comma Key 
Sends ,< option. This causes a comma ( , ) to be displayed when 
you press the comma key shifted, and a left angle bracket ( <) to 
be displayed when you press the comma key unshifted. 

Tilde Key Sends ,-
On the North American and Dutch keyboards, the Tilde Key 
Sends '- option is set. This causes the '- key to display a left 
single quotation mark (') when unshifted and a tilde (- ) when 
shifted. 

Tilde Key Sends ESC 
On the North American and Dutch keyboards, you can override 
the Tilde Key Sends '- default by clicking on the Tilde Key Sends 
ESC option. This causes the '- key to function as an escape (ESC) 
key. 

Angle Brackets Key Sends <> 
On the North American and Dutch keyboards, the Angle Brackets 
Key Sends <> option is set. This causes the angle bracket key to 
display a left angle bracket ( < ) when unshifted and a right angle 
bracket (> ) when shifted. 

Angle Brackets Key Sends ,-
On the North American and Dutch keyboards, you can override 
the Angle Bracket Key Sends <> default by clicking on the Angle 
Brackets Key Sends '- option. This causes the <> key to display 
a left single quotation mark ' when unshifted and a tilde - when 
shifted. 

Choosing a National Replacement Character Set 
Choose 7-Bit NRCS Selection ... from the Customize menu to 
choose a National Replacement Character Set (NRCS) that 
corresponds to your keyboard. DECterm displays a dialog box. 

The NRCS selection is used only with the 7-Bit NRCS Character 
option in the Customize General menu. Normally, to use a 7-
bit national character set you need to choose the corresponding 
keyboard in the Session Manager and also select the 7-bit NRCS 
in DECterm. 



I DECtenn: 7-Eit NRCS Selection II!iI 

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German Apply 

Dutch Cancel 

Italian 

Swiss (French) 

You can select the following character sets and corresponding 
keyboards (see Appendix B for the keyboard illustrations): 

North American Italian 

Flemish Swiss (French) 

Canadian (French) Swiss (German) 

British Swedish 

Danish Norwegian 

Finnish BelgianlFrench 

Austrian/German Spanish 

Dutch1 Portuguese 

lSelecting the Dutch NRCS is the same as selecting the North American NRCS. 
The Dutch NRCS is not supported. 

Customizing Graphics 
Choose Graphics ... from the Customize menu to modify DECterm 
graphics features such as color map entries. DECterm displays a 
dialog box. 

I DECtenn: Graphics [!Ill 

o Share Color Map Entries 
!j] Enable Backing Store 
o Report Macrograph Contents 

IOWI I Apply I I Cancel 

~ Bit planes 
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See the DECterm 
Graphics 
Programming 
Manual for 
detailed 
information 
on macrographs. 
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From the Graphics dialog box, you can customize the following 
graphics features: 

Share Color Map Entries 
Normally, this option is enabled on single-plane and true color 
systems and disabled on GPX systems. Clicking on this option 
prevents DECterm from allocating color map entries for its 
exclusive use. Instead, DECterm allocates shared, read-only 
colors out of the default color map. This means that DECterm 
does not need to create a private color map which would prevent 
the windows from displaying in their true colors, but it also means 
that DECterm colors may not match the colors used on a real 
terminal. 

Enable Backing Store 
Normally, the Enable Backing Store option is on, causing 
DECterm to redraw graphics after the window has changed. 
Disabling this option improves performance. 

Report Macrograph Contents 
Normally, DECterm does not respond to a request by an 
application to report macrograph contents. Clicking on this 
option enables ReGIS commands to report macrograph contents. 
This feature may risk security in some environments. When 
reporting is complete, disable this feature. 

2-Bit Planes 
You can choose the number of colors available in ReGIS and sixel 
graphics by entering the number of planes supported by your 
system. With 2-bit planes DECterm can display four different 
colors at the same time; and with 4-bit planes DECterm can 
display 16 colors. 

Normally, DECterm uses 2-bit planes on 4-plane systems and 
4-bit planes on all other systems. This reduces the probability 
that DECterm must create a private color map. 

Applications written for the VT240 terminal require only 2-bit 
planes, while applications written for the VT340 may require up 
to 4-bit planes. 



Saving and Restoring Customized Features 
When you modify DECterm settings, you can save your changes. 
If you save your changes, DECterm uses these settings each time 
you create a DECterm window. If you change your mind and want 
to use the settings that came with your system, you can restore 
the defaults. 

To save customized settings: 

• Choose Save Current Settings from the Customize menu for 
routine saving of customized features. 

• Choose Save Current Settings As ... from the Customize menu 
when you want to save the current customized features with a 
new or different file name. DECterm displays a dialog box. 

DEcterm: Save Current Settings ,\s II!il 
File Filter 

!/usrlstaff/Pooter/hume/*.OEc4erm 

Select Name For Configuration File:/usrlstaff/pooter/humel 

61 Filter I 
niLiiJI 
U! Cancel I 
9' 

¢DC>D 

Selection 

!/usrlstaff/pooter/hume/default.OE 

The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
file extension .DECterm. 

To use a file name that is not listed, enter the name of that 
file in the Selection text field and click on the OK button. 

To restore customized settings, choose: 

• Use Last Saved Settings from the Customize menu to restore 
an existing file. 

• Use System Defaults from the Customize menu to restore the 
system defaults. 
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I 

• Use Saved Settings From... from the Customize menu to 
restore previously saved settings. DECterm displays a dialog 
box. 

DEcterlll: Use Saved Settings From ~I 
File Filter 

I/usrlstaff/pooter/hume/*.DEc4erm 

Select Configuration File:/usrlstaff/pooter/humel 

6 I Filter I 

~I[K] 
I Cancel I 

Q 

<:ICH> 0 

Selection 

I/usrlstaff/Pooter/hume~efault.DE 

The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box 
displays the names of any files in the current directory that 
contain customized features. By default, these files have the 
extension .DECterm. Double click on the file name of the file 
you want to use. 

Or, use the File filter text field to list a subset of files you can 
then select from. For example, to display all files in another 
directory with the file type DECterm, type the full directory 
path -/jones/customize/* .DECterm- in the File filter text field 
and click on the Filter button. Then double click on the file 
name of the file you want to use. 

Copying Information 

Copy 

Paste 

Select All 
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Choose the Edit menu to copy information within or between 
terminal windows. 

To copy information: 

Select the information you want to copy by pressing and 
holding MBl, dragging the pointer over the information, and 
releasing MBl. Or, choose the Select All menu item from the 
Edit menu to copy the entire display. 

The selected area is highlighted. 

2 Choose the Copy menu item from the Edit menu to store the 
copied information. 



3 Click on the area where you want to place the information. 

4 Choose the Paste menu item from the Edit menu. 

The selected information is copied to the new location. 

Clearing and Resizing Terminal Windows 

Clear Lines Off Top 

Clear DisplaY 

Resize Window 

Clear Communications 

Reset Terminal 

Quit 

fi'or detailed 
:nformation 
'tbout Soft 
ferminal 
fleset, see the 
'JECterm Text 
r:Jrogramming 
'v.lanual. 

From the Commands menu, you can clear or resize the terminal 
window. 

Clear Lines Off Top 
You can erase information stored in the transcript by choosing 
the Clear Lines Off Top menu item. The transcript is an area 
of memory that contains the last saved lines of your screen 
display (use the Customize Display menu to change the size of 
the transcript). You can read it by using the scroll bars. The 
transcript exists as long as the Record Lines Off Top option in the 
Window dialog box is in effect. Normally, Record Lines Off Top is 
on. 

Clear Display 
You can clear all information displayed in a terminal window by 
choosing the Clear Display menu item. 

Resize Window 
Choose the Resize Window menu item to resize the window to 
match the size (number of rows and columns) of DECterm. 

Clear Communications 
Choose the Clear Communications menu item to reset the 
communications buffers. This causes DECterm to read data to the 
host system even when DECterm has received an XOFF signal. 

Reset Terminal 
Clicking on Reset Terminal causes a Soft Terminal Reset (STR). 

Choosing Reset Terminal also restores the default color map. On 
a 4-plane system such as the VS2000/GPX, displaying ReGIS 
or sixel graphics causes DECterm to create and load its own 
hardware color map, so that other windows do not display in their 
true colors when the DECterm window has input focus. 

To restore the default hardware color map, first erase the graphics 
from the window by choosing the Clear Display menu item from 
the Commands menu, and then reset the terminal with the Reset 
Terminal menu item. 
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Normally DECterm emulates only 2 planes of graphics on a 
4-plane system; therefore, DECterm usually does not create a 
color map. 

Composing Characters 
For more 
information 
about composing 
characters, see 
AppendixA. 

Use compose sequences to create special characters. A compose 
sequence is a series of keystrokes that creates characters that do 
not exist as standard keys on your keyboard. For example, you 
can create the cents ¢ symbol, or the Japanese yen Y symbol by 
entering a compose sequence. 

You can create any character from the character set DECterm is 
currently using. 

Exiting from DECterm 

Clear Lines off Top 

Clear Display 

Resize Window 

Clear Communications 

Reset Terminal .................................... 
II Quit 
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Choose Quit from the Commands menu or enter the logout 
command to exit from DECterm and close the DECterm window. 



Starting Mail 

7 
Using Mail 

Mail allows you to exchange messages with other computer users. 
You can use Mail to send messages, read messages sent to you, 
and print, file, delete, reply to, and forward messages. 

This chapter describes how to: 

• Start Mail 

• Send messages 

• Read messages 

• Reply to messages 

• Forward messages 

• Print messages 

• Create files from messages 

• Work with folders 

• Customize your Mail environment 

• Exit from Mail 

To start Mail, cll;ooseMail from the Session Manager Applications 
Menu or enter the following command in a DECterm window: 

% dxmail & 

Mail displays its main window. 
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Folder 
Area 

Message 
Area 

PUSh~ 
Buttons 

The main Mail window uses two areas to display your mail folders 
and messages. The top area lists your folders; the bottom area 
lists the messages in the opened folder. 

Folders help you organize your mail messages. You can create as 
many folders as you need. When you enter Mail for the first time, 
three folders (inbox, drafts, and wastebasket) appear in the folder 
area. The inbox folder contains messages that have been sent to 
you. The drafts folder contains drafts of messages you create, and 
the wastebasket folder contains messages that you have deleted. 
You might file all messages on a related topic in one folder. 

The names of your folders are always displayed, regardless of 
the number of messages in the open folder. Double clicking 
MB 1 on a folder name opens the folder and displays a list of the 
messages. Only one folder can be opened at one time. To view 
lists of messages in multiple folders simultaneously, choose the 
Open folder in new menu item from the File menu. 

Folders can be opened to reveal their contents and closed to 
conceal their contents. To open a folder, double click MBI on 
the folder name. To close a folder, double click MBI on name of 
another folder. 
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The inbox is also automatically opened when you enter Mail. 
If there are any messages in the inbox, they are listed in the 
Message index. Messages are chronologically arranged by date 
received. To display messages in a different folder, open that 
folder. 

Near the bottom of the window is a row of push buttons. These 
buttons allow you to execute the tasks you most commonly 
perform with messages. Many of the push buttons are disabled 
when you first start Mail and remain so until you select a specific 
message. 

Pressing MB2 over a folder or an open message in a Mail window 
displays a pop-up menu. Pop-up menus contain many commonly 
performed tasks. The items on a pop-up menu vary according to 
the type of object (folder or message) on which you are positioned 
and act on the object on which you are positioned. 

Pop-up menu items and push buttons duplicate pull-down menu 
items. Where you can choose among a push button, pop-up menu, 
or pull-down menu to execute a task, instructions in this chapter 
list one way to accomplish the task. Depending on your working 
style, you may prefer to use one of the other methods when you 
are familiar with Mail. 

Sending Messages 
With Mail, you can create and send a mail message or an existing 
file to one user or many users. 

Sending a Message 
To send a mail message to any user on your system or another 
system, click on the Create-Send button in the main window. A 
Create-Send window opens. You can have multiple Create-Send 
windows opened at one time. 
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Use the built-
in editing 
commands, 
described in the 
DECwindows 
User's Guide, to 
enter text and 
correct mistakes. 
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~ ___ ~_la_il:_C_t"_ea_te _______________________________ I~~ 

File Edit 
To: .0 
cc: -
Subject: 
--------

9 
Cose II Reset I r Save 1 r 3mul 1 

The Create-Send window is divided into an envelope area and a 
message area. The envelope area contains the items shown in the 
following table. 

Field 

To: 

cc: 

Subject: 

Description 

In this field, you specify the person or persons to whom 
you want to send the message. You can enter a user 
name, with optional node name. Separate names with 
commas. 

In this field, if desired, you specify users to receive copies 
of the message. 

The subject of the message (optional). 

To enter text in a field, point to the field and click MBl. Enter 
your message text in the message area. 

To send the message, click on the Send button. When the message 
is sent, the Send button is dimmed until you begin composing 
another message. 

To close the window, click on the Quit button. This deletes all text 
in the window and closes the window. 



To clear the window without closing it, click on the Reset button. 
The text in the Create-Send window is erased and the window can 
be used to send another message. 

Saving a Draft of a Message 
Selecting Save allows you to save a draft of the message in the 
drafts folder. Click on the Save button to save a draft. The Save 
button dims to indicate the draft is now saved in the drafts folder. 
You can still send or cancel the message after it has been saved. 

Resuming Work on a Draft Message 
You can continue working on a draft of a message that you 
previously saved. 

To resume work on a draft message: 

1 Select a message from the main window. 

2 Choose Use as comp from the main Mail window's File menu. 

When you choose the Use as comp menu item, Mail displays a 
Create-Send window that contains the contents of the selected 
message. 

Including a File in a Message 
You can insert an existing file into a mail message. 

To include a file in a message: 

Choose Include File... from the Create-Send window's File 
menu. Mail displays a dialog box. 

m Choose file to insel1 ~ 
File Filter 

I~ 
Files in /usr/staff/almostlhume/ 

/usr/staff/almost/hume/229JNL 01 Filter I 
/usr/staff/almost/hume/92dJNL 1001 /usr/staff/almost/hume/Mail 

/usr/staff/almost/hume/bin I Cancel I 
/usr/staff/almost/hume/c3JNL 

/usr/staff/almost/hume/personal 

.... 
Q 

GO i I C> 0 

Selection 

I 
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The dialog box prompts you for the name of the file you want 
to include. The file list box lists the names of all files in the 
current directory. 

2 Double click on the name of the file you want to include. 
The contents of the file are displayed in the Create-Send 
window. You can edit the file if desired. 

You can also use the File Filter text entry field to list a subset 
of files that you can then select from. For example, to list all 
files in another directory with the file extension. TXT, type 
the full directory path, /jones/messages/*.TXT, in the File filter 
text entry field and click on the Filter button. Then, double 
click on the file name of the file you want to include. 

3 Click on the Send button to send the message. 

Selecting Messages 

7-6 Using Mail 

Message commands act on messages displayed in the Message 
area. To indicate that a message is to be acted on, you first need 
to select it. 

To select a single message, click the MB 1 on either the message or 
the envelope icon beside the message. 

To select a range of messages from the Message area, you can 
follow one of two procedures. The first procedure is to press MB 1 
on the first message to be selected, drag the mouse to the last 
message to be selected, and release MB 1. The second procedure 
is to select the first message, and then place the mouse pointer 
on the last message to be selected, and press the SHIFT key and 
MB1. 

To add a message to the current selection, first place the mouse 
pointer on the envelope icon of the message to be included in the 
selection, press and hold the SHIFT key, and click MBl. 

To select all messages in the open folder, choose Select all from 
the Edit menu in the main window. 

To cancel the selection of one object, select another object by 
clicking MB1, or position to the selected object, press and hold the 
Shift key, and click MB 1. 



Reading Messages 
You can use Mail to read an old or new mail message. New 
messages are added to the inbox folder; messages that have been 
read are held in the inbox folder until you move them elsewhere. 

Reading a New Message 
To read a new message, click on the Read New Mail button. This 
adds new messages to the inbox folder, opens the inbox folder, and 
displays the first message received since the inbox folder was last 
opened. The message is displayed in a Read window. 

File Edit Sequences Create-Send Read 

The message area displays the mail message. Use the scroll bar 
to display any text that does not fit in this area. 

The small black square on the area dividing line is called an 
adjustment knob. U sing this knob, you can adjust the relative 
size of the areas. Making one area smaller makes the other area 
larger. This allows you to view more text in either area without 
resizing the window. To use the area adjustment knob, move to 
the knob, press MBl, drag the area dividing line to the desired 
location, and release MB l. 

If you receive a message whose contents are not text (such as 
a file containing spreadsheet data), the file cannot be viewed in 
Mail. Mail displays a message informing you of the problem. 
You can print, forward, extract, or reply to the message. See the 
appropriate sections of this chapter for information on printing, 
forwarding, extracting, and replying to messages. 
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To continue to read new messages, click on the Next or Previous 
button to read the next or previous message in the folder. 

If you receive new mail while reading messages in the inbox, 
choose Read New Mail on the pop-up menu in the Read window's 
message area. This displays the first message received since the 
inbox folder was last opened. 

To close a Read window, click on the Close button. 

Displaying a List of New Messages 
You can add new messages to your inbox folder and update the 
list of new messages without reading a message. To update the 
inbox, click on the Deliver Mail button in the main window. Mail 
cannot be delivered if the inbox is open in a Read window or if you 
are replying to a message in the inbox. 

Reading an Old Message 
To read an old message (one that has already been read), point 
to the envelope symbol beside the appropriate message in the 
Message area and double click MB l. 

To read a series of old messages: 

Select the messages to be read by holding down the Shift key 
and clicking on the desired messages. 

2 Move to one of the selected messages, press MB2, and choose 
Read in Default from the pop-up menu. 

3 In the Read window, choose Next Selected or Previous Selected 
from the Read menu to display the next or previous selected 
message. 

Multiple Read Windows 
You can open more than one Read window at one time. This 
allows you to read multiple messages at once, or to read new mail 
without disrupting the message you are currently reading. 

The first Read window you display is your default Read window, 
identified by the number 1 in the window's title bar. Additional 
Read windows are identified by the number in their title bar, for 
example, Read-2, Read-3, and so on. 

The default Read window is used to display messages unless you 
specify another window. For example, clicking on the Read New 
Mail button or double clicking on a message envelope icon in 
the main window will display the message in your default Read 
window. 



To read new mail in another Read window, choose New Mail In 
New from the main window's Read menu. A new Read window is 
opened, and the first message received since inbox was last opened 
is displayed. 

To read an old message in another Read window, select the 
message and choose the In New menu item from the main 
window's Read menu. 

If you have already opened multiple Read windows, you can 
specify the window in which to read the selected message by 
pulling down the main window's Read menu, dragging the pointer 
to the submenu icon next to the In Window menu item, and 
releasing MB lover one of the listed Read windows. 

To use a different window as the default Read window, choose 
Make Default Window from the Read window's File menu. The 
number one will be displayed in the window's title bar, and will be 
removed from the previous default window's title bar. 

~eplying to Messages 
To reply to the first selected or currently displayed message in a 
Read window, click on the Reply button. 

Replying to a message opens a Create-Send window. In the To: 
field, Mail inserts the name of the sender of the original message. 
In the Subject: field, Mail inserts the subject of the original 
message preceded by RE:. 

Enter text and make any desired edits. 

To send the reply, click on the Send button. To close the Create­
Send window, click on the Close button. 

orwarding Messages 
To forward to another user the selected or currently displayed 
message in a Read window: 

Click on the Forward button. 

Mail opens a Create-Send window and inserts the forwarded 
message in the message area. The header (the address 
information) is included in the forwarded message in most 
cases. Headers are not included in messages created with 
editors that do not produce ASCII files, such as files created 
with DECwindows Paint. 

2 Enter the address and subject information and make any 
desired changes to the text. 
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3 Click on the Send button to send the message. 

4 Click on the Close button to close the window. 

Printing Messages 
You can print selected messages or the message currently 
displayed in a Read window. Messages can be printed using your 
default print settings, or you can modify the print settings for the 
messages being printed. 

To print the selected or currently displayed message using your 
default print settings, click on the Print button in the main or 
Read window. 

Creating a File from a Mail Message 
You can create files from mail messages. You can select existing 
messages to be copied to a file, or you can create a file from a 
message you are reading or creating. 

To create a file from the selected or currently displayed message: 

Choose Extract... from the File menu in the main, Create­
Send, or Read window. 

2 Enter the name of the file to be created. If you want to append 
the message to an existing file, enter the name of that file. 

3 Click on the OK button to create the file. 

Deleting and Retrieving Messages 
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You can delete mail messages and retrieve deleted messages. 

To delete selected messages or the message currently displayed in 
the Read window, click on the Delete button in the main or Read 
window. 

The index is updated to show which messages have been marked 
for deletion. Messages are not actually deleted until the folder is 
closed. You can still perform many Mail functions on messages 
that are marked for deletion, such as moving, copying, and 
printing. When the folder is closed, the messages are deleted and 
reference to them is removed. 

Once the folder is closed, deleted messages are moved to the 
wastebasket folder. 



Deleted messages collect in the wastebasket folder until you 
empty it by choosing the Empty wastebasket menu item from 
the main window's Maintenance menu. Once the wastebasket is 
emptied, the deleted messages are irretrievable. 

To reverse the delete operation in the main window, before the 
folder is closed select the messages to be retrieved, pull down the 
Edit menu, and choose the Undo move/delete menu item. 

To undo the delete operation in a Read window, choose Undo 
MovelDelete menu item from the Edit menu. 

To update the index of messages to reflect that the messages have 
been moved to the wastebasket folder, either select the Commit 
Changes menu item from the Maintenance menu in the main 
window or reopen the folder that contains the deleted message. 

If the message has already been moved to the wastebasket, you 
can retrieve the message by moving it to another folder. For more 
information about moving messages between folders, see Moving 
and Copying Messages to Another Folder. 

Norking with Folders 
You can create and delete folders, move and copy messages 
between folders, and renumber and sort messages within folders. 
These options are described in the following sections. 

Creating New Folders 
To create a new folder, choose Create folder... from the 
Maintenance menu in the main window. 

Mail displays a dialog box in which you enter the name of 
the new folder to be created. Folder names are limited to 39 
characters and can contain letters, numbers, spaces, periods, 
dashes, underscores, and dollar signs. 

Deleting Folders 
To delete folders, select the folder to be deleted, and then choose 
Delete folder... from the Maintenance menu. If the folder is not 
empty, Mail displays a dialog box in which you confirm whether to 
delete the folder or cancel the delete request. 

If you attempt to delete the inbox folder, all messages in the inbox 
are deleted but the folder is not deleted. 

When a folder is deleted, any messages that existed in the folder 
are placed in the wastebasket folder and can be retrieved until the 
wastebasket folder is emptied. 
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Moving and Copying Messages to Another Folder 
You can move or copy a message or group of messages from one 
folder to a different folder. Moving messages to another folder 
removes them from the original folder. Copying messages to 
another folder does not remove them from the original folder. 

You can move and copy messages from either the main or Read 
windows. 

To move selected messages or the message currently displayed in 
the Read window: 

Select or display the message to be moved or copied. 

2 Select the folder you are moving or copying the message to. 

3 Click on the Move or Copy button in either the main or Read 
window. 
When you click on the Move or Copy button, Mail marks the 
message appropriately. 
Messages are not actually moved or copied until the folder is 
closed. You can still perform many Mail functions on messages 
which are marked for moving or copying, such as deleting, and 
printing. When the folder is closed, the messages are moved 
or copied. 

To undo the move or copy operation in the main window, select the 
messages to be retrieved and choose Undo MovelDelete from the 
main window's Edit menu. 

To undo the move operation in a Read window, select the Undo 
MovelDelete menu item from the Read window's Edit menu. You 
cannot undo the copy operation. 

Renumbering and Sorting Messages 
To renumber your messages in the open folder so they start from 
one and increment by one, choose Renumber Messages from the 
Maintenance menu in the main window. 

To sort the messages in the open folder in increasing order by 
date, choose the Sort by Date menu item from the Maintenance 
menu in the main window. 

To cause Mail to check and make sure its information about the 
folder is correct, choose Rescan Folder from the Maintenance 
menu in the main window. 



Picking Messages 
Picking messages allows you to create a subset of the messages 
in a folder based on their having some criterion in common. 
This subset is called a message sequence. You can then perform 
functions, such as copying, moving, extracting, or reading, on the 
subset of picked messages. In addition, you can open and delete 
a specified message sequence by selecting the appropriate menu 
item from the Pick menu. 

To pick messages, first open or select the folder containing the 
messages and choose Pick from open folder... or Pick from selected 
folder... from the Edit menu in the main window. Mail displays a 
dialog box. 

~ pick 1l11l5ll 
o Skip 

o Skip 

o Skip 

o Skip 

o Skip 

o Skip 

From: 

To: 

Cc: 

Date: 

Subject: 

Search: 

<:....11 _____ EJ 
I:.-II ____ EJ 
I:.-II ____ EJ 
~----EJ 
~----EJ 
lC.-____ EJ 

o Skip 1:-11 _____ &:-____ EJ 
I -Or- I 
pick from folder: 1-1 in_bo_x ___ _ 

-
Create sequence: lL-te....;.mFl'---___ with msgs from sequence: 1I-,al....::.JI_-,I 

Date range: II - I Date field: ~ 

o Merge with old entries in sequence 

[BiloKII 

The dialog box allows you to specify the criterion for picking 
messages. For example, you could specify that you would like to 
pick those messages containing a certain word in the subject, or 
those from a certain sender. 

You can enter multiple selection criteria to further limit the 
messages to be picked. For example, you could enter text in the 
From: field and the On: field in the dialog box to pick messages 
that the specified user sent to you on the specified day. 

Only those messages in the open or selected folder are searched 
for the specified criteria. 
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When a subset of messages has been picked, the index is updated 
to list only the picked messages. When the folder is closed, the 
picking criterion is lost. All messages will again be listed in the 
index. 

Text fields, which are the first five fields in the dialog box, search 
for matching text anywhere in the field and are not case sensitive. 
For example, entering the text John in the From: field might pick 
messages from Jane Johnson, John Doe, and Olav Bejohnesson. 

Each field in the pick dialog box is described in Table 7-1. 

Table 7-1 

Field 

From: 

To: 

Cc: 

Date: 

Subject: 

Search: 

Pick Dialog Box Fields 

Function 

To pick all messages in the open folder that 
were sent from a certain user, enter the user 
name of the sender. 

To pick all messages in the open folder that 
were sent to a certain user, enter the user 
name of the addressee or the name of a 
distribution list. 

To pick all messages in the open folder that 
were sent as a courtesy copy to certain users, 
enter the user names of the addressees. 

To pick messages received on a certain date, 
enter the date in the format DD-MMM-YYYY. 

To pick messages with a common subject, 
enter the subject or text included in the 
subject. 

To pick messages containing a word or phrase 
in the body of the messages, enter the word or 
phrase. 

Next, enter the appropriate information in the text fields at the 
bottom of the dialog box. The date range specifies that messages 
received between certain dates and times are picked. Enter the 
date and, if desired, the time in the format DD-MMM-YYYY 
HH:MM:SS. 

When you have finished entering the picking criteria, select either 
the OK screen button to pick the designated messages or the 
Cancel screen button to cancel the pick. 



Opening a New Main Window 

'f:i'or more 
~nformation 

Ibout 
:ustomizing 
vour mail 
1rofile and the 
~ail window, 
~ee the UWS 
~eference page 
ixmail(lX). 

To create a new main window, first select the folder from the 
current Mail window. Next, choose Open In New from the File 
menu. A new main window is displayed, and the current folder is 
opened. 

You can perform all Mail functions on the folders and messages 
displayed in this window. You can customize certain Mail features 
to suit your working environment by modifying your mail profile. 
Modifying your mail profile allows you to alter the way your 
messages are sent, stored, and displayed. To modify your mail 
profile, choose Modify mail profile ... from the Customize menu. 

The Mail Profile dialog box has the following options: 

• Skip to next message upon deleting current one. 

• Skip to next message upon moving current one. 

• Commit changes in a folder upon closing it. 

• Renumber messages in a folder after every commit. 

• Put deleted messages into wastebasket instead of deleting 
immediately. 

• Incorporate new messages when invoking Show Unopened. 

• Buttons affect the current message if no messages are 
selected. 

• Beep instead of putting up a No New Mail dialog box. 

An option is on when the corresponding square is shaded. To turn 
an option off, click on the appropriate black square. 

Selecting the OK screen button saves the profile settings. 
Selecting the Cancel screen button returns the original settings to 
the profile, making no changes to the profile as it appeared when 
the dialog box was first displayed. 

:xiting from Mail 
To exit from the Mail application, choose Exit from the main 
Mail window's File menu. The main window and any open Read 
or Create-Send windows are closed. Open folders are closed. 
If Create-Send windows have been modified, for exam pIe, if a 
message has been created but not sent, Mail displays a dialog box 
asking if you really want to exit. 
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If multiple main windows are open, the File menu contains the 
Close menu item rather than Exit. Choosing Close closes only the 
main window from which Close is chosen. When there is only one 
remaining main window, its File menu contains the Exit menu 
item. 



8 
Using the Notepad Editor 

The Notepad is an editing program that lets you compose and 
manipulate text. You can use the Notepad editor for any writing 
task. 

This chapter describes how to: 

• Start the editor 

• Type and format text 

• Edit a file 

• Name a file 

• Open a second Notepad 

• Open an existing file 

• Find and replace text 

• Split the screen into multiple views 

• Change fonts 

• Exit from an editing session 

Starting the Notepad Editor 
To start the Notepad editor, choose Notepad from the Session 
Manager Applications menu or enter the following command in a 
DECterm window: 

% dxnotepad& 
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Notepad displays an empty editing window, in which you can 
type text from the keyboard or copy in an existing file for editing. 
Notepad is interactive, so you see the changes to a file as you 
make them. 

~ Notepad: Unt_it_le_d __________________________ ~ ___ ~ 

File Edit Search Navigate Customize Help 

6 ... 

As you are using Notepad, you will notice that key combinations 
are listed next to many menu items. These key combinations, 
called accelerators or key bindings, provide an alternative method 
for performing operations. To perform the function listed on the 
menu, you can either choose the menu item or press the key 
combination. 

For example, you can start a new Notepad by choosing the New 
menu item from the File menu, but you can also simply hold down 
the Alt key and press the N keyboard key. (The Alt key is marked 
Compose Character or Symbol on your keyboard.) 

Some accelerators combine two or more of the special defined keys, 
such as Shift, Control, and Find (which is El on some keyboards). 
To use a three-key accelerator, press and hold the first two keys, 
in order, and then press the third key. 
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Typing Text 
To enter text in the Notepad window, give the window input focus 
and begin typing text from the keyboard. Notepad enters the text 
at the position marked by the text insertion cursor. Initially, the 
insertion cursor is displayed in the upper left corner, but it moves 
right as you type. 

The Notepad inserts text into a temporary holding area called a 
buffer. The contents of the buffer appear in the Notepad window. 
At the beginning of an editing session, the buffer may contain very 
little text, but the buffer grows longer as you add information. 

A buffer exists only during the editing session. When you end an 
editing session, you direct the Notepad editor to save or discard 
the contents of the buffer. 

Formatting Text 
Use the Tab key, the space bar, and the Return key to arrange 
text in the Notepad window as you want it to appear. 

You can also size the Notepad window so it has the line width you 
want. By default, Notepad wraps text lines at the right margin 
automatically so you do not have to press the Return key at the 
end of every line. To disable word wrapping, choose Word Wrap 
from the Customize menu. When word wrapping is in effect, 
a shaded toggle button appears to the left of the Word Wrap 
menu item. When you disable word wrapping, the toggle button 
disappears. 

Scrolling the Buffer 

Editing a File 

As your text buffer grows, it extends beyond the frame of the 
Notepad window. To view text at the beginning or end of the 
buffer, use the vertical scroll bar along the right side of the 
window. The position of the slider indicates your position in the 
buffer. When the slider is at the top of the scroll bar, you are at 
the beginning of the buffer. When the slider is at the bottom of 
the scroll bar, you are at the end of the buffer. 

The Notepad navigation and editing commands let you move 
within a text buffer quickly and easily, adding or modifying 
information. 
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Positioning the Cursor 
When you insert text in the buffer, Notepad adds the text at 
the current cursor position, pushing existing text to the right. 
Therefore, the cursor is normally positioned at the spot where you 
last entered text. 

To move the text insertion cursor, position the pointer anywhere 
in the Notepad window or on your workstation screen where there 
is text or spaces and click MB1. 

With a long buffer, reposition the text cursor using menu items 
from the Navigate menu. Choose the Go To Top menu item to 
move to the top of the buffer. Choose the Go To Bottom menu item 
to move to the bottom of the buffer. 

To reposition to a specific line in the buffer: 

Choose Go To Line... from the Navigate menu. 

The Notepad displays a line dialog box. 

2 Type the line number. 

3 Press the Return key or click on OK. 

Notepad repositions the cursor to the specified line. 

Another method of positioning on a certain line is to select the line 
number somewhere on your screen and choose the Go To Selected 
Line menu item on the Navigate menu. 

For example, suppose you are reading an error listing file in 
a DECterm window and editing the program source file in a 
Notepad window. The error listing tells you that the program has 
an error on line 1019. Use the mouse cursor to select 1019 in the 
DECterm window, and then choose Go to Selected Line Number 
from Notepad's Navigate menu. Notepad places the cursor on line 
1019 of your file. 

Selecting Text 
In order to delete, move, or copy text in a buffer, you must first 
select it. Select text by pressing and holding MB1, dragging the 
pointer over the text, and releasing MB 1. This highlights the 
selected text. Notepad stores this text until you tell it what to do. 

You can select text by using mouse clicks. Double clicking MBI 
selects the current word. Clicking MB 1 three times selects the 
current line; four clicks selects the entire document. Choosing 
Select All from the Edit menu also selects all text in the buffer. 
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You can also select blocks of text that extend beyond what you can 
currently view. To select an extended block of text: 

Place the cursor at one end of the range you want to select. 

2 Scroll the file to the other end of the range. 

3 Hold down the Shift key and click MB1. 

Notepad selects the text between the two points you designated 
and places the cursor at the new insertion point. 

If you already have an active select range, Notepad selects the 
text from the insertion point (where you hold down the Shift key 
and click MB1) to the existing active select range. Notepad then 
places the cursor at the insertion point. 

If you change your mind and want to cancel the selection, position 
the pointer over any spot in the selected area and click, or choose 
the Clear menu item on the Edit menu. 

Deleting Text 
Use the Delete key to erase a few characters. To delete a line or 
a section of text, select the text and press the Delete key or begin 
inserting new text. Inserting new text causes the selected text to 
be deleted and the new text to take its place. 

To delete all of the text in a buffer, choose the Select All menu 
item and then the Clear menu item from the Edit menu. You can 
replace the text by choosing Undo from the Edit menu. 

Canceling an Edit 
To cancel your most recent edit, choose the Undo menu item on 
the Edit menu. For example, if you remove text with the Cut 
menu item, you can restore the text to its former location with the 
Undo menu item. 

Notepad keeps a detailed record of all your edits so you can undo 
a series of edits. To cancel a series of edits: 

Choose Undo ... from the Edit menu. 

Notepad displays the Undo dialog box. 

2 Click on the Undo screen button to cancel the last editing 
operation. 

Each time you click on the Undo button, the Notepad cancels 
another editing operation. 

3 If you undo an editing operation by mistake, reinstate the 
edits by clicking on the Redo screen button. 
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4 To complete the operation, click on the Dismiss screen button. 

You can cancel all the edits of an editing session in one step by 
choosing the Revert from the File menu. The Notepad restores the 
buffer to the state it was in when you first opened the file. 

Moving Text 
Because the Notepad saves the last text you selected and deleted, 
you can move text from one location in the text buffer to another 
location. There are three methods for moving text, so you can 
choose the one that feels most comfortable to you. 

To use the Edit menu to copy text: 

1 Select the text. you want moved to another location. 

2 Choose Cut from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by positioning the pointer and clicking MB1. 

4 Choose Paste from the Edit menu. 

The deleted text is moved to the new location. 

To cut and paste text, using the mouse: 

Use MBl to select a range of text. 

2 Move the text cursor to where you want the text to appear by 
positioning the pointer and clicking MB1. 

3 Hold down the Control key and click MB3. 

The selected text disappears from the old location and appears in 
the new location. 

To use the quickest method for moving text: 

Move the text cursor by positioning the pointer and clicking 
MBl. 

2 Select the text you want to move by holding down the Control 
key and pressing MB3, while dragging the mouse. The 
selected text is underlined. 

3 Release the Control key and MB3. 

The selected text disappears from the old location and appears in 
the new location. 
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Copying Text 
Because Notepad keeps track of your selected text, you can copy 
text from one location in a text buffer to another location. As with 
moving text, you can use any of three methods for copying text; 
choose the one most comfortable to you. 

To use the Edit menu to copy text: 

Select the text you want copied to another location. 

2 Choose Copy from the Edit menu to store the copied text. 

3 Move the text cursor to where you want the selected text 
copied by positioning the pointer and clicking MB 1. 

4 Choose Paste from the Edit menu. 

The selected text is copied to the new location. 

You can also use the mouse to copy text: 

Use MBI to select a range of text. 

2 Move the text cursor to where you want the selected text 
copied by positioning the pointer and clicking MB 1. 

3 Click MB3. 

The selected text appears at the new location. 

An even quicker method for copying text is as follows: 

Move the mouse pointer to where you want the text copied by 
positioning the pointer and clicking MBI. 

2 Select the text you want to copy by holding down the Control 
key and pressing MB3 while dragging the mouse. The selected 
text is underlined. 

3 Release the Control key and MB3. 

The selected text is copied to the new location. 

These copy methods let you copy text from another application 
window that supports text selection. For example, you can use 
the Calculator's Edit menu to copy the number in its accumulator. 
Then, by choosing the Paste menu item from Notepad's Edit 
menu, you can place that number into your Notepad buffer. Or, 
you can use MBI to select some text in a Mail window and use 
MB3 to paste it into a Notepad buffer. 
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Including an Existing File 
You can include an existing file in the text buffer that you are 
currently editing. 

To include a file: 

Move the text cursor to where you want the included file 
placed. 

2 Choose Include File... from the File menu. 
Notepad displays the Open File dialog box. 

3 Either select the file from the files listed in the dialog box or 
type the name of the file that you want to include. 

4 Press the Return key or click on the OK button. 

The contents of the included file appear in the editing window at 
the location you specified. 

Filling a Block of Text 
As you edit, deleting and inserting text, the lines of text will 
probably become uneven and ragged. The Fill operation 
reorganizes text so that the maximum number of whole words 
fits on an 80-character line. If your Notepad window size is 80 
characters or more, you can use this option to neaten broken 
n!:lr!:lO"1"!:Inh~ r---o--r----

To fill text: 

1 Use MBI to select the text you want to wrap. 

2 Choose Fill from the Edit menu. 

Notepad reorganizes the block of text into 80-character lines. 

Sorting Text 
If your text includes records or a list of items in which each item 
begins a new line aligned on the left, you can sort the items 
according to the leftmost characters. Choosing the Sort menu item 
is equivalent to running the ULTRIX sort command. 

To sort some lines of text: 

1 Use MB 1 to select the lines you want to sort. 

2 Choose Sort from the Edit menu. 

The text disappears and then reappears in sorted order. 
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The sort operation places numbers before alphabetic characters 
and places uppercase alphabetic characters before lowercase 
alphabetic characters. If any of the lines of text start with tabs 
or space characters, those characters affect the result of the sort 
operation. 

Changing the Left Margin 
You can change the left margin of a block of text, moving it 
to either the right or to the left. First use MBl to select the 
text. Choose Indent+4 from the Edit menu to move the text four 
columns to the right; repeat the procedure to move the text again, 
as far as you like. 

To move the margin to the left, select the text and choose Indent-4 
from the Edit menu. 

Using ULTRIX Text Filters 
Notepad lets you use the ULTRIX commands or programs on your 
system to process text. You can use any ULTRIX command that 
takes source text, filters it through a program, and writes the 
output to the original location in the Notepad buffer. To use an 
ULTRIX text filtering command: 

1 Select a block of text. 

2 Choose Filter Selection... from the Edit menu. 

The Filter Selection dialog box appears. 

I Cancel I 

3 Enter the ULTRIX command name in the text input field. 
ULTRIX commands must be entered in lowercase letters. 

4 Press OK. 

For example, while writing programs in the C language, you can 
invoke cb, the C program beautifier, which formats code so as 
to display its structure. Select the lines that need structuring, 
choose Filter Selection... from the Edit menu, and enter cb in 
the text field of the Filter Selection dialog box. The selected 
code disappears and reappears in your Notepad, now structured 
correctly. 
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Saving Text in a File 
When you add text to Notepad, the editor records the information 
in the buffer. Because a text buffer exists only for the editing 
session, if you want to save the contents of the buffer you must 
direct Notepad to write your text to a file. 

To save the text in your buffer as a file: 

Choose Save As... from the File menu. 
Notepad displays a dialog box that prompts you for the name 
of the file. 

" Notepad: Untitled 

File Edit Search Navigate Customize Help 

I Save As... I!PJ 
Save As I 

~====~------- III IDOl I Cancel I 

2 Type the name of the file, assigning a name that corresponds 
to the contents of the file so that you can easily recognize 
it. Use the Delete and arrow keys to make any necessary 
corrections. 

3 Press the Return key or click on the OK button. 

Notepad writes the contents of the buffer to the new file and post~ 
the file name in the title bar of the editing window. 

When you make changes to an existing file, it is also necessary to 
save the changes. Once a file has a name, use the Save to update 
the file. 

Opening a Second Notepad 
You can open a second Notepad window without closing the first 
window. To create a second Notepad window, choose New from thE 
File menu. A second Notepad window opens. 
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The editing you do in the second Notepad window can be 
completely independent of the first Notepad window, or you can 
copy and paste text from one notepad window to the other. 

Opening an Existing File 
To edit an existing file, you direct Notepad to open the file and 
read its contents into the Notepad buffer. 

To open an existing file: 

Choose Open... from the File menu. 
Notepad displays the Open File dialog box. 

Open ... [g 

File Filter 

1*·* 
Files in lusr/staff/almost/kosakl 

lusrlstaff/almost/kosak/meeting_notes.BAK 6 II Filter 'I 
lusrlstaff/almost/kosak/reminders.txt 

I OK I lusr/staff/almost/kosak/trip_report.txt 

I Cancel I 

'-
Q 

<JD i i [) 0 

Selection 

II 

2 Either select the file from the files listed in the dialog box or 
type the file name. 

3 Press the Return key or click on the OK button. 
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, However, if the file name appears anywhere on your screen, you 
can simply use MBl to highlight the name and then choose Open 
Selected from the file menu. 

The contents of the file appear in the editing window and Notepad 
displays the file name in the title bar. 

Searching for Text 
You can search a text buffer for any text, such as a word, a 
number, or any other characters that you can type with your 
keyboard. Because Notepad treats spaces as text, you can search 
for two or more words. The Notepad searches the buffer from the 
current cursor position and highlights the first occurrence of the 
text string. 

Choose Next... from the Search menu. 

Notepad displays the Find dialog box. 

" Notepad: Untitled 

File Edit Search Navigate customize 

2 Type the text string you want to locate. 

Help 

-6 

3 Click on the Next screen button to initiate a search from the 
current position to the end of the file. 

You can continue to search for the text string by clicking on the 
Next screen button in the Find dialog box. 

By default, the Notepad distinguishes between uppercase and 
lowercase occurrences of a letter. Click on Case Sensitive Searches 
on the Customize menu if you prefer to search for any uppercase 
or lowercase occurrence of the letter you specify. 

Notepad can also search a text buffer for a character pattern. 
You can add characters or delete characters from the search 
string during the search operation, and the Notepad returns to 
the initial search position in the buffer and looks again for the 
modified pattern. Choose the Next IncrementaL. menu item to 
search for patterns. 
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~eplacing Text 
The Notepad editor can replace one text string with another 
text string. This is especially useful if you have spelled a word 
incorrectly throughout a long file, and you want to fix every 
occurrence of the misspelled word. 

To replace a text string: 

Choose Replace All... from the Search menu. 
Notepad displays a dialog box. 

New 

I Cancel I 

2 Type the old text that you want the Notepad to replace and 
press the Tab key to move the cursor to the next text entry 
field. 

3 Type the new text that you want substituted and press the 
Return key. 

To replace one occurrence of the text at a time, choose Replace 
Once... from the Search menu. Notepad searches the buffer from 
the current cursor position and highlights the first occurrence of 
the text. Click on the Replace Once button to replace the text 
with the new text. To skip an occurrence, click on the Skip button. 

To replace text within some portion of the buffer, select a range of 
text. Then choose the Replace Within Selected Area... from the 
Search menu. 

>plitting the Work Area 
You can split your Notepad window into a number of edit 
windows. This lets you work on different portions of the same file 
simultaneously and perform editing functions between windows, 
such as cutting and pasting. This is particularly helpful with a 
long file. 

To split the window in which the cursor is currently placed, choose 
Split View from the Navigate menu. 
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To get rid of a window in which the cursor is currently placed, 
choose Delete View from the Navigate menu. 

To adjust the size of the split window, position the cursor on the 
pane adjustment knob (located between the split areas) then drag 
MBl up or down until you're satisfied with the size. 

Changing the Font 
You can select from among a number of character sizes and styles 
when you edit in Notepad. Choose Font... from the Customize 
menu. The Font Attributes dialog box appears. 

Font Attributes ~!5Il 

Family (Foundry) Size (dpi) 

'-

_I_T_C _Av_a_nt_G_a_rd_e_G_ot_hi_C _(A_d_Ob_e_) _..J....~6-' D6
Q 

Courier (Adobe) 

Helvetica (Adobe) 

Interim OM (ADOBE) 

ITC Lubalin Graph (Adobe) 

Weight Slant Width Spacing Char Set 

o 
Sample TeNt 

The quick brown fox jUl'lped over the lazy dog. 
abcdefghijkll'lnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZOl234567B9 

I Apply I 
I Cancel I 

6 

o 
Q 

The list of available styles and sizes reflects the fonts installed on 
your system. To change the font of your Notepad session: 

Click on the name of a font family to select a design. The font 
manufacturers (foundries) are shown in parentheses. 
The point sizes (heights) for that font family appear, with the 
screen resolution for which that size is designed, in dots-per­
inch. Font resolutions typically match your monitor's screen 
resolution, but you could have some other choices. 

2 Click on a point size. Choose one whose resolution matches 
your screen's (otherwise the point size appears incorrect). 
Attribute combinations for the font family in the currently 
selected size appear. 

3 Click on a line of attributes. 
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The sample text changes so that you can preview the font. 

4 Click on Apply to apply the current font attributes to your 
Notepad session. 

S Click on Cancel to remove the dialog box, preserving the last 
applied font. 

Choose Save Attributes from the Customize menu to apply 
these font attributes to future Notepad sessions; choose Restore 
Attributes to return to the last saved font. 

Recovering from an Interrupted Session 
Should some unexpected event interrupt your editing session, 
the Notepad editor can reconstruct it. Notepad keeps a record of 
your edits so that system failures do not cause you to lose them. 
(Failures can occur, for example, when a thunderstorm interrupts 
the electrical power.) This record of edits, called a journal file, 
usually exists only while an editing session is active. However, 
the journal file remains if the session ends abnormally. 

When you attempt to edit a file that has a journal file associated 
with it, Notepad displays the Recover dialog box and asks whether 
you want the previous edits restored. 

Notepad can recover a session, even if an interruption occurs 
when you are editing an untitled buffer that does not yet have a 
file name. Notepad assigns the buffer a file name. The file name 
has the format nnnnnnnnJNL, where nnnnnnnn is a process 
number that uniquely identifies the file. To recover an untitled 
buffer: 

Choose Open... from the File menu. 

2 Look at the list of files in your current directory. Find a file 
whose name has the format nnnnnnnnJNL. 

3 Enter the process number (represented by nnnnnnnn) in the 
file selection text field. Omit the JNL characters at the end. 

Notepad displays a Recover dialog box, asking you to confirm 
the recovery. 

4 Click on the Yes button. 
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Exiting from an Editing Session 
To end an editing session, choose Exit from the File menu. If you 
have modified text in the current buffer, Notepad produces a new 
version of the edited file and closes the Notepad window. 

To discard the edits from a session and close the editing window, 
choose Quit from the File menu. 
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9 
Using Paint 

Paint is a graphics program that lets you create any kind of 
simple picture, such as a sketch, an illustration, or a map. From 
an assortment of art tools, you can choose those that enhance your 
picture, adding any details and accents it requires. 

The Paint program can save your pictures for later use, print them 
on different kinds of printers, or copy them to other applications. 
You can also project these pictures on your terminal screen with 
the CDA Viewer. 

This chapter describes how to: 

• Start Paint 

• Select tools and menu items 

• Erase 

• Draw lines and shapes 

• Introduce patterns into paintings 

• Use the paintbrush 

• Edit paintings 

• Insert text 

• Size and scroll the canvas 

• Print paintings 

• Exit from Paint 
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Starting Paint 

9-2 Using Paint 

To start Paint, choose Paint from the Session Manager 
Applications menu or enter the following command in a DECterm 
window: 

% dxpaint & 

The Paint program displays a drawing window that is bordered by 
a tool palette. 
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The Paint window frames a portion of the canvas. Horizontal and 
vertical scroll bars indicate the percentage of the canvas displayed 
in the Paint window. 



.earning the Basics 
Paint is a bitmap graphics program, which means that it treats 
pictures as a collection of dots called pixels. Different drawing 
tools, such as the pencil, the paintbrush, and the text tool, edit the 
color of the pixels to either the foreground color or the background 
color to create a pattern. Because the Paint canvas has so many 
pixels in every square inch, you do not actually see patterns of 
dots. Instead you see a collection of lines, shapes, and text. 

You can begin to understand Paint by modifying a sam pIe picture 
called the Clock Tower. To display the Clock Tower: 

In the Paint window, choose the Open... menu item from the 
File menu. 
The Open Picture dialog box displays the names of any 
graphics files in the current directory. 

II Open Picture 10. 
File filter 

n"·ddif 

Picture name: 

61 Filter 1 

ICQLJI 
1 Cancel 1 

-
Q 

(I0!)O 

Selection 

II 

2 Type the following file name in the Selection field: 

/usr/examples/DDIF_graphics/clocktower.ddif 

DDIF is the standard format of a Paint file. 

3 Click on the OK button or press 1 Return I. 

Paint displays the Clock Tower picture. Use the Clock Tower to 
practice selecting tools and to experiment with some of the Paint 
menu items. 
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Selecting Tools 
The tool palette offers a variety of art tools and basic shapes. You 
can work with a pencil, a paintbrush, a can of spray paint, or a 
paint bucket. The shapes on the tool palette let you build pictures 
quickly and easily. 

When you first start Paint, the paintbrush tool is highlighted, 
indicating it is the current default. Only one tool on the tool 
palette is active at a time, and that tool remains active until you 
make another selection. 

Try changing the time on the Clock Tower. First, select the eraser 
to delete the current time. To use the eraser: 

Place the pointer in the tool palette, position it on the eraser 
tool, and click MB 1. 

2 Move the pointer into the drawing window, position it in the 
center of the clock face, and click MB 1. 

The eraser is now active in the window. 



3 Gently drag the eraser along each hand of the clock, 
eliminating the current time. Release MB 1. 

N ow, draw in the current time, usiIlg the straight line tool: 

Point to the straight line tool on the tool palette and click 
MBl. 

2 Position the pointer in the center of the clock face and press 
MBl. 

The straight line tool is now active, and one end of the line is 
anchored at the center of the clock. You can stretch and swing 
the line from the center point by moving the mouse. Try it. 

3 Drag the pointer from the center of the clock to the current 
hour postion. Once the line points to the correct time, release 
MBl. 

4 Add a second line in the same manner for the minute hand. 

If you make a mistake, choose the Undo menu item from the Edit 
menu. Undo always cancels the last action you took. 

Creating Special Effects 
Using the menu items in the Paint program, you can create 
special effects with a painting. 

For example, the Invert menu item on the Edit menu creates a 
negative image of a painting. The Paint program can reverse the 
tones of the Clock Tower, switching the foreground color and the 
background color. 

1 Click on the selection box tool. 

2 Move the pointer into the drawing window and select the 
Clock Tower. 

3 Choose the Invert menu item from the Edit menu. 

Paint repaints the Clock Tower, making a negative of the original 
image. 

Saving a Painting 
To save your version of the Clock Tower: 

Choose Save As... from the File menu. 

Using Paint 9-5 



IlYou need 
help completing 
the dialog box, 
refer to the 
DECwindows 
User's Guide. 

Erasing 

9-6 Using Paint 

Paint displays a dialog box and prompts you for a file name. 
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2 Type a file name using the form -/filename.ddif so that Paint 
saves the picture in your login directory. 

3 Click on the OK button or press the \ Return I key. 

Printing a Painting 
To print the Clock Tower, choose one of the Print Inenu iten1S fron1 
the File menu. The Print menu item sends the painting to the 
default printer, whereas the Print As... menu item displays the 
print dialog box. 

Paint supports output to both PostScript and sixel printers, such 
as the LA50 and LAI00. When printing on an LA50, set an aspect 
ratio of 2:1. All other printers have a 1:1 ratio. 

There are several ways to erase in Paint: 

• Use the eraser tool. 

• Select the area using the selection box tool or the scissors tool. 
Or, select the entire canvas using the Select All menu item 
from the Edit menu. Then choose Clear from the Edit menu. 

Select All acts only on the visible portion of the screen. 

• Choose Undo from the Edit menu to erase the last Paint 
operation. 



Drawing Lines and Shapes 
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The bottom half of the tool palette contains a collection of line and 
shape tools that you use in a similar way. Whenever you draw a 
straight line or a shape, the point where you click MBI becomes 
its reference point. That is, you can stretch and swing the line or 
shape from this reference point by dragging the pointer. When the 
shape is correct, anchor it in place by releasing MB l. 

For example, to draw a rectangle: 

Click on the rectangle tool. 

2 Position the pointer in the drawing window where you want 
one corner of the rectangle to be. Press MB 1 and drag the 
pointer diagonally across the drawing surface until the 
rectangle has the desired width and height. (Notice how you 
can stretch and shrink the rectangle, even flip it over.) 

3 Release MBI to anchor the shape. 

If you want to line up a series of shapes or draw them 
equidistant to each other, choose Grid from the Options menu. 
It superimposes a horizontal and vertical pattern of dots on the 
drawing window, as shown in the following figure, that serves as a 
guide, yet does not become part of your picture. 
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Lines drawn with the shape tools can be thick or thin. To change 
the current line width: 

Choose Line Width... from the Options menu. 
Paint displays a dialog box. 

2 Click on the line thickness you want. 

For example, to draw non-rectangular polygons with different 
width borders, choose the line width you want and then do the 
following: 

1 Click on the polyline tool to make it active. 

2 After positioning the pointer in the drawing window, drag 
the pointer to create one side of the polygon. Drag to create 
additional sides and double-click on the final corner. 
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Most of the time, geometric shapes or figures are opaque so you 
cannot see what lies behind them. However, using Transparent 
from the Options menu, you can let background images show 
through foreground images. 

Using PaHerns 
Lines and shapes do not need to be a solid color. They can be 
striped, speckled, woven, dotted, and so on. 

The line and shape tools, the spray can tool, and the paintbrush 
tool can paint patterned lines and borders. To use patterned lines: 

Choose Patterns... from the Options menu. 
Paint displays the Patterns palette, which provides a selection 
of designs. The Patterns palette is shown in Figure 9-1. 
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Figure 9-1 The Patterns Palette 

Outline Pattern 
Foreground Color 

Background Color 

1001 

Fill Pattern 

No Color 

2 Click on the outline button to change the current outline 
pattern, which is solid. 

3 Click on any pattern. 

Notice that the pattern you clicked on is displayed in the 
outline button, indicating it is the active pattern. 

4 Click on the shape tool you want to use. 

S Mter positioning the pointer in the drawing window, drag the 
pointer to create a patterned line or border. 

To create shapes with patterned centers: 

Choose Patterns... from the Options menu. 
Paint displays the Patterns palette, illustrated in Figure 9-l. 

2 Click on the Fill button to select a fill pattern. 

3 Click on any pattern on the palette. 
Notice that the pattern you click on is displayed in the Fill 
button, indicating it is the current default. 

4 Click on any tool you want to use. The geometric shape tools 
and the paint bucket tool use the current fill pattern. 

S Mter positioning the pointer in the drawing window, drag the 
pointer to create a shape with a patterned center. 
The following shows examples of patterns. 



~ paint __________________________________________ ~_~ __ 

File Edit Options Font Customize 

[:J '\0 
it) ~ 

~j 

Arl 
'" DO 
00 
O~ 

<:11 

Help 

...... , ... , .... " .. ', ............ . . , ............... , ......... ,', ... ,. 
/~~///}}ff}~?}((/}}~~} .................................. 

tItt)):??tt:::):}::t:tt: ." ... ".'.' ... ", .......... , .... ,. 

IiI\\\\\\I\\\\I\\\II\\I\\I\\\\II\I\\: 

1(>0 

You can fill existing shapes with the paint bucket tool by clicking 
MBI inside the shape you want to fill. The shape must be 
enclosed. Any opening in the border causes the paint to spill 
out onto the canvas. You can reverse filling a shape by choosing 
Undo Flood from the Edit menu. 

Filling only works on the visible part of the canvas; if you attempt 
to flood the entire canvas, only the visible portion will be affected. 

Creating Your Own Patterns 
With Paint, you can create your own patterns and store them 
on the pattern palette during a Paint session. Create your own 
pattern from any of the patterns on the palette except the solid 
foreground, solid background, and None patterns, illustrated in 
Figure 9-1. 
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To create your own pattern: 

Decide whether you want an outline or a fill pattern, and then 
click on the appropriate button on the Pattern palette. 

2 Choose a pattern from the palette that is closest to what you 
want and click on it. Paint also provides a few blank patterns 
at the end of the palette that you can customize. 

3 Choose Edit Pattern... from the Options menu. 
Paint displays a dialog box. 
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Notice that this dialog box contains two boxes. In the left­
hand box, you see the pattern you chose from the palette. In 
the right-hand box, you see the same pattern magnified. 

While you are editing a pattern, the Edit Pattern dialog box 
has input focus, and the pointer assumes the shape of a pencil. 

4 In the Edit Pattern dialog box, edit the magnified version of 
the pattern to create the effect you want. 
Use the pencil to draw over pixels or click on individual pixels. 
The pencil tool turns a background pixel to the foreground 
color and a foreground pixel to the background color. 

Refer to the pattern shown in the left-hand box to see how the 
magnified pattern looks under normal conditions. 

5 Click on the OK button to complete the pattern and return to 
the drawing window. 

The edited pattern is available on the Pattern palette for the rest 
of the session, replacing the original pattern. 

Using the Paintbrush 
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For an elegant stroke, one that creates a calligraphic effect, use 
the paintbrush. The paintbrush tool applies paint along the path 
of the pointer. 
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Initially, the paintbrush has a solid stroke, but you can choose a 
patterned stroke by changing the outline pattern on the Patterns 
palette. 

To shape the tip of the paintbrush: 

1 Click on the paintbrush tool. 

2 Choose Brush Shape... from the Options menu. 
Paint displays a dialog box. 
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3 Click on the brush shape you want. 

4 Move the pointer into the drawing window and try out the 
new brush stroke. 

:diting Paintings 
With Paint's electronic canvas, you can easily rearrange images in 
the drawing window. You can delete images entirely, move them 
to another part of the window, or copy them. The Paint program 
can also size selected images, shrinking them or enlarging them 
as you wish. It can also crop a painting, retaining one section of 
the canvas while discarding the rest. For further effect, Paint can 
invert the foreground and background colors in a selected area. 

Selecting Images 
Two selection tools, the box and the scissors, mark a portion of the 
drawing window for a graphics operation. The selection box tool 
marks a rectangular area, while the selection scissors tool marks 
an area with an arbitrary shape. You can select the entire canvas 
with the Select All menu item on the Edit menu. 

To use the selection box tool, position the pointer in one corner 
of the area to be selected and drag the pointer over the desired 
image. 
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To use the selection scissors tool, drag the pointer around the 
boundary of the desired object until you reach the starting point. 

Paint stores the selected image until you tell it what to do. 

Moving Images 
You can move an image from one location in the Paint window to 
another. To move an image: 

Select the image. 

2 Position the pointer inside the selected area and drag the 
image to the desired location. 
You can cancel the selection by clicking in another part of the 
window or by selecting another tool. 

Copying Images 
Once you select an image on the canvas, you can copy the image 
to the clipboard, leaving the original image intact. Then, paste thE 
clipboard image onto the canvas. Paint can paste graphic images 
from the clipboard, but it cannot paste text. 

To copy an image: 

1 Select the image. 

2 Choose Copy from the Edit menu. 

Paint copies the image to the clipboard. 

3 Choose Paste from the Edit menu. 
Paint takes the image from the clipboard and puts it on the 
canvas, leaving it selected. 

4 Position the pointer in the selected image and drag it to the 
proper location on the screen. 
You can cancel the selection by clicking on another tool or by 
selecting another image. 

Resizing Images 
You can also modify the proportions of selected images. Use 
the Scale menu item from the Edit menu to enlarge or shrink a 
selected image. To scale an image: 

Select the image. 

2 Choose Scale from the Edit menu. 



Paint displays a dialog box. 
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3 Click on one of the percent buttons to change the scale. For 
example, clicking on 25% reduces the selected area to 25% of 
the original size; clicking on 200% enlarges the selected area 
to twice its original size. 

If you want to specify your own percentage: enter a number 
less than 100 to shrink the figure, or a number greater than 
100 to expand the figure. 

4 Click on the OK button to complete the operation. 

To reverse the process and return to your original picture, 
choose Undo Scale from the Edit menu. 
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Cropping a Picture 
Many times, one section of a painting develops so well that you 
decide to keep it, discarding the rest of the canvas. Use the Crop 
menu item to extract a portion of the picture. To crop a picture: 

Select the section of the picture you want to keep. 

2 Choose Crop from the Edit menu. 

Paint repositions the cropped picture in the upper left corner 
of the window and discards the rest of the painting. You can 
restore the original picture with the Undo menu item. 

Working with Full Views 
By using the Full View menu item from the Options menu, you 
can display entire figures even if they are too large to fit in the 
Paint window. The Full View dialog box lets you display only a 
portion of your picture or permanently crop it. 

To display an entire picture, choose Full View... from the Options 
menu. Paint displays the Full View dialog box. 

To change modes in the Full View dialog box, display the Mode 
option menu and choose the desired option. The default mode is 
Position. 

To designate the area of your picture you want to display: 

Choose Position from the Mode option menu in the Full View 
dialog box. 

2 Press and drag MBl until the Position window frames the 
area of the canvas you want to display. 

3 Release MB l. 

4 Click on OK to display the desired portion of the canvas. 

To crop your picture: 

Choose Crop from the Mode option menu in the Full View 
dialog box. 

2 Press and drag MBl until the Crop window frames the area of 
the canvas you want to crop and save. 

The rest of the figure will be discarded. 

3 Click on the crop button. 

To reverse cropping, click on the Undo Crop button. 

4 Click on OK. 



Paint displays a dialog box that tells you the crop operation 
is irreversible and asks if you want to save the picture before 
continuing. Click on Yes to retain only the portion of the 
picture you slected, discarding the rest. Click on No to restore 
the picture to its precropped state. 

Editing in Detail 
Not only does Paint magnify patterns in the Edit Patterns dialog 
box so you can see them better, it also magnifies portions of the 
canvas with the Zoom On menu item. Zoom acts like a magnifying 
glass in the drawing window, enlarging an image to eight times 
its original size. 

To magnify a portion of a painting: 

Choose Zoom On from the Options menu. 

The Zoom window opens beside the Paint window and a 
magnifying frame is displayed in the Paint window itself. 
The magnifying frame in the Paint window demonstrates the 
size of the image that Paint magnifies in the Zoom window. 
You can resize the Zoom window to edit a larger area of the 
canvas. 
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2 Place the pointer inside the magnifying frame and drag the 
frame over the image that you want to edit. 
The Zoom window contains an enlarged version of the image 
that is defined by the magnifying frame in the Paint window. 

3 Select the pencil tool from the tool palette. 

4 Bring the pointer into the Zoom window and use the pencil to 
add fine details to the image. Either click on individual pixels 
or draw over them. 
Notice that the image in the drawing window changes as you 
edit in the Zoom window, so you can see how the modified 
figure looks in normal proportions. Continue editing pixels 
until you are satisfied with the overall effect. 

5 To edit other areas of the drawing window, drag the 
magnifying frame to the next location. 



nserting Text 

Edit the pixels in the Zoom window as before. 

To close the Zoom window, display the Options menu and click on 
the Zoom Off menu item. 

You can insert text anywhere in the Paint window. You can choose 
from an assortment of fonts, sizes, and styles when adding text. 
You can change the appearance of text in the drawing window up 
until the moment you click to complete the text entry. Mter that, 
Paint incorporates the text into the graphic image. To insert text: 

Select the text tool. 

2 Position the pointer in the Paint window where you want to 
insert text and click MB 1. 

Paint inserts a left corner bracket to mark the left margin of 
the text entry and displays the text insertion cursor next to it. 

3 Type in text from the keyboard, formatting it with the Tab 
and Return keys. 

4 To modify the text font, choose Family from the Font menu 
and display the pop-up menu. Click on the type of font that 
you want. 

S Change the text from normal to bold face by choosing Style 
from the Font menu. Display the pop-up menu from the Style 
item and click on Bold. 

6 To adjust the size of the text, choose Size and display the 
pop-up menu. Click on the pica size that you want. 

Paint applies the selections you make to the text you have 
already entered. 

7 To complete the entry with its current characteristics, either 
move the pointer to another part of the window and click MBI 
or select another tool. 

The inserted text becomes part of the picture. You can no longer 
erase text with the delete key or change its characteristics with 
items from the Font menu. 
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Sizing the Canvas 
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The default Paint window shows only a portion of the canvas. The 
scroll bars along the right side and the bottom of the window let 
you view the entire canvas. The position of the slider indicates 
your position in the' canvas. When the slider is at the top of the 
scroll bar, you are at the beginning of the canvas. When the slider 
is at the bottom of the scroll bar, you are at the end of the canvas. 

You can resize the Paint window to frame the entire canvas by 
clicking on the resize button. 

You can also tailor the size of a Paint canvas by specifying the 
height and width in pixels, inches or centimeters. 

Additionally, you can modify the number of dots per inch (DPI). 
This lets you manipulate high-resolution images. To modify the 
DPI, click on the Inches or Centimeters option and press MB1 to 
display the Resolution menu. Choose 75, 100, or 300 DPI, or the 
Non-Standard menu item. Non-Standard lets you supply your 
own resolution. The change will be evident when you print the 
picture out, rather than in the Paint display. 

To alter the canvas: 

Choose Picture Size ... from the Customize menu. 
Paint displays a dialog box. 

Picture Size II!i1 

Size I Letter 

Width: I~oo 

Height: 11750 

@ Pixels 
o Inches 
o Centimeters 

n.~s(Jlutil)n [::?I!:~:fC::~::::::::~:::::::::::::l 

~ Dots per Inch 

I Cancel I 

The Picture Size dialog box shows the current canvas size 
with its dimensions converted to pixels, inches, or centimeters, 

2 Click on Size to display the Size menu. 

Choose one of the Size menu items: Non-Standard, Letter 
(8112x11) or Screen (size of screen in pixels). Choose Non­
Standard to supply your own value. This is the default. 

3 Choose the desired canvas size. 



4 Click on the OK button. 

Using Accelerators 
Certain key combinations, called accelerators, let you quickly 
perform common DECwindows operations. The following shows 
each key combination and its corresponding function. (The ALT 
key is marked Compose Character or Symbol on your keyboard.) 

Press To Produce 

I ALI /zl Undo 

IALI/QI Quit 

I ALI/X I Cut 

I ALI/V I Paste 

IALT/pi Print 

I A LI/SI Save 

I A LI/W I Refresh Screen 

In addition to using accelerators to perform common DECwindows 
commands, you can use key combinations to manipulate Paint 
tools. You can press and hold the Shift key while you drag MBl to 
produce the following results. 

Tool 

Rectangle 

Line 

Brush 

Pencil 

Ellipse 

Polygon 

Eraser 

Exiting from Paint 

Effect 

Causes it to be a square 

Causes it to be at an angle that is a multiple of 45 
degrees 

Causes it to be horizontal or vertical 

Causes it to be horizontal or vertical 

Causes it to be a circle 

Causes angles to be multiples of 45 degrees 

Causes it to erase only vertically and horizontally 

To exit from Paint, choose Quit from the File menu. If you try to 
Quit without saving your picture, Paint asks if you want to save 
the picture before quitting. Click on Yes, No, or Cancel to state 
your choice. 
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Tool Summary 

9-22 Using Paint 

Table 9-1 lists the tools available on the Paint palette. 

Table 9-1 

Tool 

Box 

Scissors 

Spray can 

Pencil 

Eraser 

Paintbrush 

Text 

Paint bucket 

Line 

Arc 

Rectangle 

Square 

Ellipse 

Circle 

Free-hand 
stroke 

Polyline 

Tool Summary 

Action 

Select a rectangular area for editing. 

Select a shape for editing. 

Apply paint in the current outline pattern. (The 
slower the drag, the darker the coat.) 

Draw a thin line. 

Delete·the image in the path of the pointer. 

Paint a free stroke. 

Print what is typed at the keyboard. 

Fill a closed shape with the current fill pattern. 

Draw a straight line. Shift-click for a 90 degree or a 
45 degree line. 

Sketch a horizontal or vertical arc, depending on 
the initial movement after the click. Shift-click for a 
quarter circle. 

Draw a rectangle. Shift-click for a square. 

Draw a square. 

Draw an oval shape. Shift-click for a circle. 

Draw a circle. 

Draw a free-hand line in the selected line width and 
pattern. 

Draw a multisided figure with rounded corners. 
Click at each corner, double-click to complete shape. 
Shift-click for 45 or 90 degree angles. 



10 
Using the PostScript® Previewer 

The PostScript Previewer lets you view formatted PostScript files 
on your workstation screen without printing them, thus saving 
you paper and trips to the printer. 

This chapter describes how to: 

• Start the PostScript Previewer 

• View a PostScript file 

• Customize your PostScript display 

• Exit from the PostScript Previewer 

Starting the PostScript Previewer 

gee the UWS 
"eference page 
ixpsview(1X) 
~r information 
Ibout these 
~ommand 
)ptions. 

To start the Postscript Previewer, choose PostScript Previewer 
from the Session Manager Applications menu or enter the 
following command in a DECterm window: 

% dxpsview & 

You can specify several options on the command line to specify the 
file to be displayed or characteristics of the PostScript Previewer 
window. 

The PostScript Previewer displays its main window, which is 
where you view PostScript files. 

® PostScript is a registered trademark of Adobe Systems Incorporated. 
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/hI1 PostScript® Previewer lbEllill 
File Page Options Help 

Viewing a PostScript File 
To view a PostScript file in the PostScript Previewer window, you 
must open it. To open a PostScript file: 

Choose Open... from the File menu. 
The Previewer displays a dialog box that prompts you for the 
name of the file you want to view. The file list box lists the 
names of the PostScript files in the current directory. 
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Open ... ~I 
File Filter 

I"·p~ 
Files in /usr/staff/pooter/humel 

/usr/staff/pooter/hume/debu9_listing.ps 611 Filter II 
/usr/staff/pooter/hume/display-2341.ps 

1 OK I /usr/staff/pooter/hume/display-2346.ps 

/usr/staff/pooter/hume/header.ps 1 Cancel I 

Q 

¢o i i r> 0 

Selection 

II 

2 Double click on the name of the file you want to view. 
The PostScript Previewer displays the file you specified. 

If you want to view a PostScript file that is not listed, type the 
name of that file in the Selection text entry field and click on the 
OK button. Or, use the File Filter text entry field to list a subset 
of files that you can select from. For example, to list all files that 
end in . ps in another directory, type the full directory path (such 
as /jones/project/*.ps) in the File filter text entry field and click 
on the Filter button. When the list of files from the /jones/project 
directory appears in the list box, double click on the name of the 
file you want to view. 

If the name of the file you want to view appears in any other 
window, you can select that file name and view the file. To view a 
file whose file name appears in another window: 

1 Select the name of the file you want to view. 

2 Choose Open Selected from the File menu. 
The PostScript file you selected is displayed. 
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Paging Through the File 
The number of the page currently displayed appears in the Status 
area in the lower left corner of the window. To view another page 
in the displayed file, you can: 

• Specify the number of the page you want to see 

• Specify the next page 

• Specify the previous page 

To view a specific page: 

Choose Display... from the Page menu. 

The PostScript Previewer displays a dialog box. 

2 Enter the number of the page you want to see. 

3 Click on the OK button. 

The PostScript Previewer displays that page. 

To view the next page, you can either choose the third menu 
item from the Page menu or click on the Next Page button at 
the bottom of the Previewer window. You can continue to page 
through the file by choosing the appropriate menu item from the 
Page menu or by clicking on the Next Page and Previous Page 
buttons. 

If you are viewing the first page in the file, the first menu item 
on the Page menu and the Previous Page button are unavailable. 
If you are viewing the last page in the file, the last menu item on 
the Page menu and Next Page push button are unavailable. 

Revisiting the File 
If you make changes to a PostScript file based on what you see 
when you view it, you do not have to close the file to see those 
changes in effect. By revisiting the file currently displayed, you 
can see the changes you made. This means you can modify the fil. 
in one window while you are viewing it in another, reprocess the 
file to produce new PostScript output, and view the modified file. 

To revisit the currently displayed file, choose the Revisit Current 
menu item from the File menu. The file is redisplayed from the 
beginning~ 
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Customizing the PostScript Previewer 
By customizing the PostScript Previewer, you can: 

• Change the page size, page orientation, or scale of the display 

• Speed the display of pages in random order 

• View files for either format or content 

• View files that contain unsupported PostScript tray size 
directives 

• Watch the Postscript Previewer draw images to the screen 

Changing the Page Size, Page Orientation, and 
Scale 
You can change the size and orientation of a page you want to 
view. Changing the page size does not change the size of the 
PostScript Previewer window. Instead, the display is formatted (in 
length and width) for the page size you specify. Unless you specify 
otherwise, the display page size is Letter (8 1/2 x 11 inches). 

To change the page size of the file currently displayed: 

Choose Sheet Selection... from the Options menu. 
The Previewer displays a dialog box. 

Sheet Selection... I~ 

Sheet Sizes 

IIIUI 6 

Legal ~ Ledger 

Executive '0' 

1.0 

Scale Factor 

il OK II I Cancel I 

Orientation 

@{@ 
O~ 

O~ 
O~ 

2 To choose a sheet size, click on the appropriate size. 

You can choose from the following tray sizes: 

• Letter (8.5 x 11 inches) 

• Legal (8.5 x 14 inches) 
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• Ledger (11 x 17 inches) 

• Executive (7.5 x 10.5 inches) 

• A3 (297 x 420 mm) 

• A4 (210 x 297 mm) 

• A5 (148 x 210 mm) 

• B4 (257 x 364 mm) 

• B5 (182 x 257 mm) 

Unless you specify otherwise, the page is displayed upright at ° 
degrees. You can view the page at 0, 90, 180, or 270 degrees. To 
change the orientation of the page in the Previewer window, click 
on the appropriate orientation symbol. The new page orientation 
takes effect at the next page operation, when another file is 
opened, or when the current file is reopened with the Revisit 
Current menu item. 

You can also specify the factor by which the Postscript Previewer 
magnifies or shrinks the images in the file. A scale factor of 1 
creates images on screen that are the same size as those printed 
on paper. Reducing the scale factor below 1 shrinks images; 
increasing the scale factor magnifies them. 

To change the scale of the display, drag the arrow in the slider left 
or right, or move the pointer to a location on the slider and press 
MBl. The scale appears in the Status area when it is more or less 
than 1 (as 0.3X or 1.5X, for example). 

Click on the OK button in the Sheet Selection box when you have 
selected the sheet size, orientation, and scale you want. The 
options you have specified take effect immediately. 

Using Comments 
Many programs that produce Postscript files have formatting 
conventions that enable pages to be processed independently of 
each other. These "comments" in the file allow the PostScript 
Previewer to more quickly display any page in the file in random 
order; the Previewer can display the page that you request, 
without processing each previous page. This means that you 
can view page five of a file without waiting for the Previewer to 
process pages one through four. 
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The Use Comments option is in effect by default: the PostScript 
Previewer uses comments if they are present in the file, and the 
option button is shaded. However, the Use Comments option 
might occasionally cause you to receive an error message when 
you attempt to view a PostScript file. If that occurs, try correcting 
the problem by disabling the Use Comments option. 

Using Bitmap Widths 
The same PostScript file can be either printed or viewed on the 
screen, but characters look somewhat different on the printed 
page and the screen. The printer has finer resolution (more dots 
per inch) than the screen, so that images processed for printing 
appear less clear on the screen. Therefore, in order to create 
clearer, better readable characters, the PostScript Previewer can 
use spacing formulas designed for bitmaps (screen images) instead 
of those designed for print. 

The Use Bitmap Widths option is off by default. This setting 
displays format and layout correctly, with spacing between 
characters as it is on the printed page. However, there is some 
cost to the readability of actual text; characters might be dense 
and difficult to read. 

To increase the readability of text, click on the Use Bitmap Widths 
option. The display changes immediately, and the option button 
is highlighted. Text characters now appear well spaced and are 
easily read. However, the page might look slightly different than 
it would when printed. For example, columns might be slightly 
out of alignment and right justified text might appear instead 
with a ragged right margin. 

Some PostScript files contains tray size directives. These are 
device-specific PostScript programming language instructions that 
tell the printer which tray size to use. For example, a file might 
contain tray size directives that instruct the printer to switch from 
the letter tray (8 1/2 x 11) to the ledger tray (11 x 17) while that 
file is being printed. 

The Previewer does not, however, permit the addition of tray 
size directives to PostScript files in this way. If you try to view 
a file that contains PostScript tray size directives, the Previewer 
displays an error message. To continue viewing the file: 

Press I Return I to acknowledge the error message. 

2 Choose Use Fake Trays on the Options menu. 

The Use Fake Trays menu item, which is off by default, is in 
effect if its option button is highlighted. 
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3 Choose Revisit Current from the File menu 
The file is redisplayed from the beginning and the tray size 
remains the same. 

To change the tray size, use the Sheet Selection dialog box. 

Watching the Previewer's Progress 
The PostScript Previewer usually prepares one page of your 
PostScript file at a time and then draws that entire page to the 
screen. If you prefer, you can watch the Previewer draw the 
display as it progressively translates a page of the PostScript file 
into screen images. 

The Watch Progress menu item is disabled by default. To watch 
the progress of each page translation, click on the Watch Progress 
menu item. 

Exiting from the PostScript Previewer 
To exit from the PostScript Previewer, choose Exit from the File 
menu. 
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1 1 
Using the Puzzle 

The Puzzle is a video version of a number puzzle with slidable 
squares . 

Starting the Puzzle 
To start the Puzzle, choose Puzzle from the Session Manager 
Applications menu or enter the following command in a DECterm 
window: 

% dxpuzzle & 

The Puzzle is displayed. 

Playing Around with the Puzzle 
The puzzle squares are scrambled. The trick is to arrange them 
in ascending order in the fewest possible moves. The Puzzle keeps 
track of the number of moves you make. 

Using the Puzzle 11-1 



Click on the square you want to move. Although you can move 
only those squares that are adjacent to the blank square, you can 
slide an entire row at a time. 

To make the Puzzle easier or more challenging, choose the 
Settings ... menu item from the Customize menu and change the 
settings. 

Try increasing the number of squares displayed per side. To 
change the number of squares on each side, place the pointer on 
the number in the slider and drag to the left or right. Click on the 
OK button to change the settings, or the Cancel button to return 
to the Puzzle without changing any settings. 

Starting a New Game 
You do not have to win one game to start another. To start a new 
game and rescramble the squares, choose the New Game menu 
item from the File menu. 

Exiting from the Puzzle 
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To exit from the Puzzle, choose the Quit menu item from the File 
menu. 

If you changed the size, settings, or screen position of the Puzzle 
and would like to save your changes, choose Save Settings from 
the Customize menu before quitting. To restore the default 
settings, choose Use System Defaults from the Customize menu. 



A 
Composing Characters 

In a DECterm window, you can use compose sequences to create 
special characters. A compose sequence is a series of keystrokes 
that creates characters that do not exist as standard keys on your 
keyboard. You can create any character from the character set 
DECterm is currently using. (For more information on choosing a 
character set, see Chapter 6.) 

Depending on the keyboard type, you compose characters in either 
of the following ways: 

• Using three-stroke sequences on a VT320 keyboard 
including the North AmericanlUnited Kingdom, Dutch, 
and N orwegianlDanish keyboards. 

• U sing two-stroke sequences on other keyboards. 

To compose a character: 

Find the character you want to create in column 1 of the 
following tables. 

2 To compose a three-stroke sequence, simultaneously press and 
then release I Compose I and the space bar, and type the two 
characters in column 2. 

To compose a two-stroke sequence, type the two characters in 
column 3. The desired character is displayed. 

Press the Compose key and space bar, Delete key, Tab key, Return 
key, or Enter key to cancel a compose sequence. 

Note The North American, United Kingdom, and Dutch keyboards do 
not have diacritical marks. If you use a diacritical mark, DECterm 
uses an equivalent character. 
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Table A-l Composing Characters in Multinational Character 
Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

" quotation mark .. space bar .. space bar 

# number sign ++ 

apostrophe ' space bar 'space bar 

@ commercial at AA 

[ opening bracket ( ( 

\ backslash / / or / < 

] closing bracket ) ) 

/\ circumflex accent /\ space bar /\ space bar 

grave accent ' space bar ' space bar 

opening brace ( -
I vertical line //\ 

} closing brace ) -
tilde ,... space bar ,... space bar 

inverted! !! 

¢ cent sign C / or C I 

£ pound sign L- or L= 

¥ yen sign Y- or Y= 

§ section sign SO or S! or SO 

c currency sign XO orXO 

© copyright sign CO or CO 
!! feminine ordinal A_ 

« open angle brackets « 
degree sign 0/\ 

± plus or minus sign +-

superscript 2 2/\ 

superscript 3 3/\ 

J.l micro sign /U 

«j[ paragraph sign P! 

(continued on next page) 
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Table A-l (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

middle dot " 
superscript 1 1 " 
masculine ordinal 0_ 

» closed angle » 
brackets 

lh fraction one- 14 
quarter 

1;2 fraction one-half 12 

l inverted? ?? 

A A grave A' 'A 
A A acute A' 'A 
A A circumflex A" "A 
A A tilde A- -A 
A A umlaut A" oroA °A 

A A ring A* or AO °A 
(degree sign) 

lE A E diphthong AE 

Q C cedilla C, 

E E grave E' 'E 

E E acute E' 'E 

E E circumflex E" "E 

it E umlaut E" orooE oOE 

t I grave r 'I 

f I acute I' 'I 

I I circumflex I" "I 

I I umlaut I" or °1 °1 

N N tilde N- -N 
() o grave 0' '0 

6 o acute 0' '0 
(continued on next page) 
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Table A-l (Cont.) Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

6 o circumflex 01\ "0 

6 o tilde 0- .... 0 

b o umlaut 0" or "0 "0 

<E o E diphthong OE 

0 o slash 0/ 

iT U grave U' 'U 

U U acute U' 'U 

iT U circumflex UI\ "U 

U U umlaut U" or"U "U 
y y umlaut y" or"y "y 

13 German small ss 
sharp s 

a a grave a' 
, 
a 

a a acute a' 'a 

a a circumflex a" "a 

a a tilde a .... ....a 

a a umlaut a" or "a " a 

Ii a ring a* or aO °a 

(degree sign) 

re a e diphthong ae 

~ c cedilla c, (comma) 

e e grave e 
, , 

e 

e e acute e' 'e 

e e circumflex e" "e 

e e umlaut e" or "e " e 

i grave i' 'i 

i i acute i' , i 

i i circumflex i" ,,' 1 

1 i umlaut i" or "i "i 

(continued on next page; 
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Table A-l (Cont.) Composing Characters in Multinational 
Character Mode 

Character 

fi n tilde 

o o grave 

6 o acute 

0 o circumflex 

0 o tilde 

0 o umlaut 

re o e diphthong 

f/J o slash 

U u grave 

U u acute 

11 u circumflex 

ii u umlaut 

y y umlaut 

ISO Latin 1 Charactersl 

no break space 

broken vertical bar 

- logical not , 
SHY soft (syllable) 

hyphen 

RO registered 
trademark 

macron 

3/4 three quarters 

- division sign 

xx multiplication sign 

acute accent 

cedilla 

Three-Stroke 
Sequence 

n-
, 

0 

0' 

OA 

0-

0" or ··0 

oe 

0/ 

u' 

u' 

uA 

u" or··u 

y" or·y 

sp sp 

I I or! A 

* 

RO 

A 

34* 

xx 

' , 
, , 

Two-Stroke 
Sequence 

-n 
'0 

'0 

-0 

··0 

'u 

'u 

lIn the ISO Latin 1 mode, the characters re, <E, and Y are not available. 

(continued on next page) 
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Table A-l (Cont.) 

Character 

diereses 

Y' Yacute 

y' yacute 

TH capital Icelandic 
thorn 

th small Icelandic 
thorn 

-D capital Icelandic 
Eth 

Composing Characters in Multinational 
Character Mode 

Three-Stroke Two-Stroke 
Sequence Sequence 

" " .. space bar 

Y' 'Y 

y' 'y 

TH 

th 

-D 

-d small Icelandic Eth -d 

TableA-2 Composing Characters in National Replacement 
Mode Using Typewriter Keys 

Character 

British 

£ pound sign 

grave accent 

Danish 

# 

@ 

number sign 

apostrophe 

commercial at 

grave accent 

A-6 Composing Characters 

Three-Stroke 
Sequence 

L- or L= 

, space bar 

++ 

, space bar 

AA 

, space bar 

Two-Stroke 
Sequence 

(continued on next pagej 



Table A-2 (Cont.) 

Character 

Dutch 

£ pound sign 

apostrophe 

1A one quarter 

lh one half 

3/4 three quarters 

ij i j sign 

fl Florin 

grave accent 

acute accent 

diereses 

Finnish 

# number sign 

apostrophe 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke 
Sequence 

L- or L= 

, space bar 

14 

12 

34 

ij 

f-

, space bar 

" 1\ 

++ 

, space bar 

Two-Stroke 
Sequence 

Flemish and FrenchlBelgian 

£ pound sign 

apostrophe 

grave accent 

French Canadian 

a 
a 

apostrophe 

a grave 

a circumflex 

L- or L= 
, space bar 

, space bar 

, space bar 

'a 

Aa 

'a 

I\a 

(continued on next page) 
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Table A-2 (Cont.) Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke Two-Stroke 
Character Sequence Sequence 

e e grave 'e , 
e 

e e circumflex "e "e 

i i circumflex ,,' I ,,' I 
0 o circumflex "0 "0 

u u grave 
, 
u 

, 
u 

U u circumflex "u "u 

German/Austrian 

apostrophe ' space bar 

grave accent ' space bar 

Italian 

apostrophe ' space bar 

Norwegian 

apostrophe ' space bar 

grave accent ' space bar 

Portuguese 

apostrophe ' space bar 

grave accent ' space bar 

A A tilde -A 

6 o tilde -0 

it a tilde -a 

0 o tilde -0 

(continued on next pagej 
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Table A-2 (Cont.) 

Character 

Spanish 

£ pound sign 

apostrophe 

§ section sign 

grave accent 

tilde 

Swedish 

# number sign 

apostrophe 

E E acute 

e e acute 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-Stroke 
Sequence 

L- or L= 

, space bar 

!S or OS or OS 

, space bar 

- space bar 

++ 

, space bar 

'E 
, e 

Two-stroke 
Sequence 

Swiss (French) and Swiss (German) 

apostrophe ' space bar 

e e circumflex "e "e 

1 i circumflex ,,' I ,,' I 
0 o circumflex "0 "0 

u u grave u u 

U u circumflex "u "u 

Composing Characters A-9 



Table A-3 Composing Characters in National Replacement 
Mode Using Data Processing Keys 

Character 

quotation mark 

# number sign 

apostrophe 

@ commercial at 

[ opening bracket 

\ backslash 

] closing bracket 

apostrophe 

opening brace 

I vertical bar 

} closing brace 

tilde character 

A-l0 Composing Characters 

Three-Stroke 
Sequence 

" space bar 

++ 

' space bar 

aa or AA or aA 

( ( 

1< 
A space bar 

' space bar 

( -
AI 
) -
- space bar 



B 
National Replacement Keyboards 

In DECterm, you can pick a National Replacement Keyboard 
(NRCS) that corresponds to the chosen keyboard dialect by 
choosing the 7-bit NRCS Selection ... menu item from DECterm's 
Customize menu. 

The following National Replacement Character Sets are available: 

North American 

Flemish 

Canadian (French) 

British 

Danish 

Finnish 

Austrian/German 

Dutchl 

Italian 

Swiss (French) 

Swiss (German) 

Swedish 

Norwegian 

BelgianlFrench 

Spanish 

Portuguese 

lUse of the Dutch national keyboard is discouraged. It may not be supported in 
future versions of DECterm. Dutch users should use the ISO Latin 1 Keyboard 
instead. 

The following figures illustrate the corresponding keyboards. 

Figure B-1 illustrates the North American Keyboard. 

Figure B-2 illustrates the Flemish Keyboard. 

Figure B-3 illustrates the Canadian (French) Keyboard. 

Figure B-4 illustrates the British Keyboard. 

Figure B-5 illustrates the Danish Keyboard. 

Figure B-6 illustrates the Finnish Keyboard. 

National Replacement Keyboards 8-1 



Figure B-7 illustrates the Austrian/German Keyboard. 

Figure B-8 illustrates the Dutch Keyboard. 

Figure B-9 illustrates the Italian Keyboard. 

Figure B-10 illustrates the Swiss (French) Keyboard. 

Figure B-11 illustrates the Swiss (German) Keyboard. 

Figure B-12 illustrates the Swedish Keyboard. 

Figure B-13 illustrates the Norwegian Keyboard. 

Figure B-14 illustrates the BelgianlFrench Keyboard. 

Figure B-15 illustrates the Spanish Keyboard. 

Figure B-16 illustrates the Portuguese Keyboard. 

B-2 National Replacement Keyboards 
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A 

Alarm settings, 2-5 
ASCII files 

displaying, 5-1 

B 
Bitmap, 9-3 
Bitmap widths 

viewing PostScript files using, 10-7 
Buffer, 8-3 

c 
Calculator 

accumulator display, 1-1 
copying to clipboard, 1-5 
correcting mistakes, 1-3 
exiting from, 1-6 
illustrated, 1-2 
memory display, 1-1 
order of precedence, 1-4 
pasting from clipboard, 1-6 
starting, 1-1 
using, 1-2 

Calendar 
creating multiple, 2-1 
multiple, 2-12 
sharing, 2-12 

Calendar (cont'd.) 
starting application, 2-2 
using the clock in, 2-10 

Card 
adding to card file, 3-3 

Index 

opening existing in card file, 3-5 
renaming in card file, 3-7 
selecting in card file, 3-5 

Card file 
illustrated, 3-2 
opening existing, 3-3 
opening new, 3-2,3-3 
renaming, 3-11 
saving existing, 3-11 
saving new, 3-11 
searching, 3-5 

Cardfiler 
exiting, 3-13 
starting, 3-2 

Card files 
merging, 3-12 

Card File window 
viewing with scroll bar, 3-5 

CDA Viewer 
changing processing options, 5-3 
closing files with, 5-5 
exiting, 5-5 
illustrated, 5-2 
starting, 5-1 
viewing files with, 5-2 

Index-l 



Character composing, 6-20, A-I 
Clock 

using Calendar's 
customizing display, 4-2 
exiting, 4-4 
setting alarm, 4-3 
starting, 4-1 

Comments (PostScript), 10-6 
CREATE/TERMINAL command, 6-1 

o 
Day view, 2-2 
DDIF (DIGITAL Document Interchange 

Format) 
defined, 5-1 

DDIF file 
closing after viewing, 5-5 
viewing, 5-2 

DDIF file type, 9-3 
DECterm 

composing characters, 6-20, A-I 
copying information, 6-1S 
customizing, 6-2, 6-3 

options, 6-3 
display 

customizing, 6-5 
exiting from, 6-20 
general features 

customizing, 6-7 
graphics 

customizing, 6-15 
keyboard 

customizing, 6-13 
National Replacement Character Set 

choosing, 6-14 
National Replacement Keyboard, 

B-1 
option 

Angle Brackets Key Sends <>, 
6-14 

Angle Brackets Key Sends '-, 
6-14 

Appl Cursor Keys, 6-S 
Application Keypad, 6-S 

Index-2 

DECterm 
option (cont'd.) 

Auto Driver Resize, 6-4 
Auto Repeat, 6-13 
Auto Resize Terminal, 6-3 
Auto Resize Window, 6-3 
Auto Wrap, 6-6 
Batch Scroll _ Lines, 6-6 
Big Font, 6-4 
S-Bit Multinational Characters, 

6-11 
7-Bit NRCS Characters, 6-11 
_ Bit Planes, 6-16 
Block Cursor, 6-6 
Comma Key Sends '" 6-14 
Comma Key Sends ,<, 6-14 
Condensed Font, 6-4 
Ctrl-Q, Ctrl-S = Hold, 6-13 
Cursor Blink, 6-6 
Dark Text, Light Background, 

6-6 
Delete Key, 6-13 
Delete Key Backspace, 6-13 
Display Cursor, 6-6 
Enable Backing Store, 6-16 
Horizontal Cursor Coupling, 6-5 
Horizontal Scroll Bar, 6-5 
Host Status Display, 6-6 
Icon Name, 6-4 
Light Text, Dark Background, 

6-6 
Little Font, 6-4 
Lock UDKs, 6-7 
Lock User Features, 6-S 
Margin Bell, 6-13 
Newline, 6-7 
Normal/SO, Condensedl132, 6-4 
Normal Cursor Keys, 6-S 
Normal Font, 6-4 
No Status Display, 6-6 
Numeric Keypad, 6-S 
Record Lines Off Top, 6-5 
Record _ Lines Off Top, 6-6 
Report Macrograph Contents, 

6-16 



DECterm 
option (cont'd.) 

Share Color Map Entries, 6-16 
Terminal ID, 6-8 
Terminal Size, 6-4 
Tilde Key Sends ESC, 6-14 
Tilde Key Sends '-, 6-14 
Underline Cursor, 6-7 
UPSS DEC Supplemental, 6-8 
UPSS ISO Latin 1, 6-10 
Vertical Cursor Coupling, 6-5 
Vertical Scroll Bar, 6-5 
VT100 Mode, 6-12 
VT300 Mode, 8-bit Controls, 

6-12 
VT300 Terminal Mode, 7 -Bit 

Controls, 6-12 
VT52 Mode, 6-12 
Warning Bell, 6-13 
Window Title, 6-4 

restoring customized settings, 6-17 
restoring system settings, 6-17 
saving customized settings, 6-17 

DECterm window 
creating, 6-1 

F 

Files 
ASCII 

displaying, 5-1 
DDIF 

displaying, 5-1 
Font 

changing in Notepad, 8-14 

Index topic 
changing, 3-7 

K 

Keyboard 
choosing NRCS, 6-14, B-1 

M 

Mail 
Create-Send window 

described, 7-4 
illustrated, 7-3 
opening, 7-3 

exiting, 7-15 
folders 

creating, 7-11 
deleting, 7-11 
described, 7-2 

main window 
illustrated, 7-1 
opening a new, 7-15 

Read window 
closing, 7-8 
described, 7-7 
illustrated, 7-7 
opening, 7-7 

starting, 7-1 
Mail message 

copying, 7-12 
creating, 7-3 

including a draft, 7-5 
including a file, 7-5 

creating a subset of, 7-13 
creating files from a, 7-10 
deleting, 7-10 
extracting, 7-10 
forwarding, 7-9 
moving, 7-12 
picking, 7-13 
printing, 7-10 
reading, 7-7 
reading new messages, 7-7 
replying to, 7-9 
retrieving deleted, 7-11 
selecting, 7-6 
sending, 7-3, 7-4 

Mail messages 
sorting, 7-12 

Memory display 
calculator, 1-4 

Index-3 



N 
Notepad 

cancelling edits, 8-5 
changing font, 8-14 
exiting, 8-16 
filing text, 8-10 

o 

filling text, 8-8 
filtering text, 8-9 
formatting text, 8-3,8-9 
key bindings for, 8-2 
navigating, 8-4 
opening a new one, 8-10 
recovering lost edits, 8-15 
replacing text, 8-13 
scrolling, 8-3 
searching for text, 8-12 
selecting text, 8-4 
sorting text, 8-8 
splitting views, 8-13 
starting, 8-1 
typing text, 8-3 

Orientation 

p 

of PostScript Previewer display, 
10-6 

Paint 
exiting, 9-21 
starting, 9-2 

Paintbrush tool, 9-13 
Painting 

changing line width, 9-7, 9-8 
changing scale, 9-14 
copying images, 9-14 
erasing, 9-6 
inserting text, 9-19 
inverting colors, 9-5 
magnifying, 9-17 
moving images, 9-14 
opening graphics file, 9-3 

Index-4 

Painting (cont'd.) 
printing, 9-6 
saving, 9-6 
selecting an image, 9-13 
sizing the canvas, 9-20 
using a grid, 9-7 

Paint window 
clearing, 9-6 
scrolling the canvas, 9-20 

Pattern 
adding to painting, 9-10 
creating your own, 9-12 
using, 9-7, 9-10 

Pixel, 9-3 
PostScript file 

handling tray size directives in, 10-7 
paging through a, 10-4 
viewing, 10-2 

PostScript Previewer 
changing page size of display, 10-5 
customizing, 10-5 
exiting, 10-8 
illustrated, 10-1 
opening files with, 10-2 
paging through file with, 10-4 
scaling display, 10-6 
starting, 10-1 
using comments, 10-6 
viewing files for content with, 10-7 
viewing files for form with, 10-7 
watching progress of, 10-8 

Puzzle 

R 

changing settings, 11-2 
exiting, 11-2 
starting, 11-1 

Repeat intervals, 2-7 
Reposition 

Calendar display, 2-23 
Resize 

Calendar display, 2-23 
Calendar entry, 2-5 
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Scale 
of PostScript Previewer display, 

10-6 
Scaled widths 

viewing PostScript files using, 10-7 
Scroll bar 

using in the Cardfiler, 3-5 
Structured comments (PostScript), 

10-6 

T 
Terminal emulator 

creating, 6-1 
Text 

copying, 8-7 
copying in card file, 3-9 
deleting in card file, 3-8 
filtering in Notepad, 8-9 
finding in card file, 3-5 
in a painting, 9-19 
including, 8-8 
moving, 8-6 
moving in card file, 3-8 
selecting, 8-4 
selecting in card file, 3-7 

Text cursor 
moving in card file, 3-7 

Today menu item, 2-2 
Tool 

choosing in Paint, 9-4 
drawing lines and shapes, 9-5 
summary of Paint palette, 9-22 
using shapes in Paint, 9-7 

Transparent background, 9-9 

w 
Window 

creating DECterm, 6-1 
customizing DECterm, 6-2 

z 
Zoom, 9-17 
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How to Order Additional Documentation 

Technical Support 
If you need help deciding which documentation best meets your needs, call 800-343-4040 
before placing your electronic, telephone, or direct mail order. 

Electronic Orders 
To place an order at the Electronic Store, dial 800-DEC-DEMO (800-332-3366) using a 
1200- or 2400-baud modem. If you need assistance using the Electronic Store, call 
800-DIGIT AL (800-344-4825). 

Telephone and Direct Mail Orders 

Your Location 

Continental USA, 
Alaska, or Hawaii 

Puerto Rico 

Canada 

International 

* Internal 

Call 

800-DIGITAL 

809-754-7575 

800-267-6215 

Contact 

Digital Equipment Corporation 
P.O. Box CS2008 
Nashua, New Hampshire 03061 

Local Digital Subsidiary 

Digital Equipment of Canada 
Attn: DECdirect Operations KA02j2 
P.O. Box 13000 
100 Herzberg Road 
Kanata, Ontario, Canada K2K 2A6 

Local Digital subsidiary or 
approved distributor 

SSB Order Processing - WMO/E15 
or 
Software Supply Business 
Digital Equipment Corporation 
Westminster, Massachusetts 01473 

* For internal orders, you must submit an Internal Software Order Form (EN-01740-07). 





Reader's Comments UL TRIX Worksystem Software 
DECwindows Desktop Applications Guide 

AA-MA88B-TE 

Please use this postage-paid fonn to comment on this manual. If you require a written reply 
to a software problem and are eligible to receive one under Software Perfonnance Report 
(SPR) service, submit your comments on an SPR fonn. 

Thank you for your assistance. 

Please rate this manual: 
Accuracy (software works as manual says) 
Completeness (enough infonnation) 
Clarity (easy to understand) 
Organization (structure of subject matter) 
Figures (useful) 
Examples (useful) 
Index (ability to find topic) 
Page layout (easy to find infonnation) 

What would you like to see more/less of? 

What do you like best about this manual? 

What do you like least about this manual? 

Excellent 
o 
o 
o 
o 
o 
o 
o 
o 

Please list errors you have found in this manual: 

Page Description 

Additional comments or suggestions to improve this manual: 

Good 
o 
o 
o 
o 
o 
o 
o 
o 

Fair 
o 
o 
o 
o 
o 
o 
o 
o 

Poor 
o 
o 
o 
o 
o 
o 
o 
o 

What version of the software described by this manual are you using? 

Nameffitle _________________ _ Dept. 

Company Date 

Mailing Address 

Email Phone ______ _ 
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