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About This Guide 

Purpose of This Guide 
This guide describes the ULTRIX DECwindows Version 1.0 
Desktop Applications. 

Who Should Use This Guide 
This guide is intended for all ULTRIX DECwindows users. This 
guide assumes the user has read the DECwindows User's Guide to 
become familiar with DECwindows terms and the techniques for 
manipulating windows. In addition, the user should have some 
experience using the DECwindows Session Manager and User 
Executive applications. 

Structure of This Guide 
This draft includes the following chapters: 

• Chapter 1-Using the Calculator 

• Chapter 2-Using the Calendar 

• Chapter 3-Using the Cardfiler 

• Chapter 4-Using the Clock 

• Chapter 5-U sing DECterm 

• Chapter 6-Using the DDIF Viewer 

• Chapter 7-Using Mail 

• Chapter 8-Using the Notepad Editor 

• Chapter 9-Using Paint 

xi 



Conventions 

xii 

• Chapter 10-Using the PostScript Previewer 

• Chapter II-Puzzling 

mouse 

MBI, MB2, and MB3 

PBI,PB2,PB3,PB4 

SBI,SB2 

I Delete I 

The term mouse refers to any 
pointing device, such as a mouse, 
a puck, or a stylus. 

MBI indicates the left mouse 
button. MB2 indicates the middle 
mouse button, and MB3 indicates 
the right mouse button. (The 
buttons can be redefined by the 
user.) 

PBI, PB2, PB3, and PB4 indicate 
buttons on the puck. 

SBI and SB2 indicate buttons on 
the stylus. 

A sequence such as I Ctrl/x I 
indicates that you must hold down 
the key labeled Ctrl while you 
press another key or a pointing 
device button. 

A sequence such as ~ indicates 
that you must first press and 
release the key labeled PFI, then 
press and release another key or a 
pointing device button. 

A key name is shown enclosed to 
indicate that you press a key on 
the keyboard. 



In examples, a horizontal ellipsis 
indicates one of the following 
possibilities: 

• Additional optional argu­
ments in a statement have 
been omitted. 

• The preceding item or items 
can be repeated one or more 
times. 

• Additional parameters, 
values, or other information 
can be entered. 

A vertical ellipsis indicates the 
omission of items from a code 
example or command format; the 
items are omitted because they 
are not important to the topic 
being discussed. 

xiii 
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1 
Using the Calculator 

The Calculator performs simple arithmetic functions-addition, 
subtraction, multiplication, division-and computes percentages 
and square roots. Unlike a handheld calculator, it has two 
displays. The top display is the accumulator, which shows the 
number being entered or the current result, and the bottom 
display is the memory. 

This chapter describes how to 

• Start the calculator 

• Enter data 

• Perform arithmetic functions 

• Use the memory 

• Transfer data to or from the clipboard 

• Exit from the calculator 

Starting the Calculator 
To start the Calculater, choose the Calculator menu item from 
UE's Applications menu. 

A small calculator is displayed on your screen. You can move and 
change the size of the Calculator window as you wish. 
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m Calculator Nml 
File Edit Help 

ZK-010BA-GE 

Operating the Calculator 
You can use Calculator with either the mouse or the keyboard. 

With the mouse, point to the appropriate button and click MB1. 

With the keyboard, enter the numbers 0 to 9 from the main 
keyboard or the keypad. Press the Shift key to enter the 
arithmetic functions (+, -, *, /, %, =) on the main keyboard. 
From the keypad, the pressing the following keys produces the 
corresponding function: 
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Press ... 

PFI 
PF2 
PF3 
PF4 
comma key 

Enter or Do 

FI7 
FIB 
FI9 
F20 

Clear 

Clear AcclJmuliator-, 

To Produce ... 

/ 

..;a;b 

* 
% 

+ 

Me 

MR 

M+ 

M-

Accumulator 

Memory 

Subtract Contents 
of Accumulator 
from Memory 

Add Contents 
of Accumulator 
to Memory 

Add Contents 
of Memory 
to Accumulator 

When you enter data into the accumulator, notice that Calculator 
uses a decimal point to distinguish between random digits and an 
operand. See what happens as you enter the following data: 

Enter 1134 and notice that no decimal point appears in the 
accumulator. 

2 Enter a plus sign (+). Calculator inserts a decimal point after 
the digits 1134 to signify the completion of an operand. 

Depending on the contents of the accumulator, you can use one of 
the following methods to correct mistakes in computation: 

• Press the Delete key to erase the last digits entered in the 
accumulator. 
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• Click on the CE button to void the last operand entered. 

• Choose the Undo menu item from the Edit menu to reverse 
the last operation, for example, to restore the last operand or 
to remove the previous paste operation. 

Performing Arithmetic Functions 
Calculator displays numbers in the range of plus or minus 
999,999,999. It performs all calculations in left to right order and 
treats operators with equal importance. 

For example, to evaluate the equation 6 + 5 * 3: 

Find the sum of 6 + 5. 
Calculator displays an 11. 

2 Find the product of 11 * 3. 
The result is 33. 

Also note the way Calculator computes percentages. For example, 
to determine 6 percent of 195: 

Enter 195. 

Calculator displays the digits in the accumulator. 

2 Enter * and Calculator inserts a decimal point. 

3 Enter 6. 

The number 6 is displayed in the accumulator. 

4 Enter %. 

The result, 11.7, is displayed in the accumulator. 

Storing Values in Memory 
Use the memory display to store results and values for later 
computation. The figure in memory starts out as zero. You can 
add the contents of the accumulator to memory or subtract the 
contents of the accumulator from memory, using the M + and 
M- buttons respectively. To enter the contents of memory into 
the accumulator, click on the MR button. Clear the contents of 
memory with the MC button. 
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Copying Text with the Calculator 
You can copy numbers from other applications into the 
Calculator's accumulator and from the Calculator accumulator or 
memory into another application. 

Use the Copy menu item from the Edit menu to transfer data 
from the active display in the Calculator window to another 
application window. For example: 

Click on the accumulator display. 

2 Enter a number into the accumulator. 

3 Choose the Copy menu item from the Edit menu. Or, for 
greater speed, press and hold MB2 to display a pop-up menu 
and choose the Copy menu item. 

Now you can paste the data from the clipboard to another 
application window. 

Use the Paste menu item from the Edit menu to copy data from 
the clipboard. This data can be copied directly from another 
window, or it can be the result of an equation copied from another 
window. Calculator treats the contents of a paste operation just 
as if you typed in the data from the keyboard yourself. 

m Calculator IPJJml 
File Edit Help 
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Exiting trom the Calculator 
To exit from the Calculator, choose the Quit menu item from the 
File menu. 

1-6 Using the Calculator 



.:- 0 

Oct 
4 

2 
Using the Calendar 

The Calendar combines the functions of a desktop calendar and 
an appointment book to help you keep track of your meetings and 
plan your time. The Calendar enables you to look at a year or 
month display, or to review your scheduled appointments a day at 
a time. 

You can also create several different calendars to use for specific 
purposes. For example, you could create one calendar to keep 
track of your personal enagagements, and another calendar 
to be used by a group of people to schedule conference room 
reservations. 

This chapter describes how to 

• Move around Calendar 

• Create and delete entries 

• Set alarms and repeat entries 

• Move entries 

• Use Calendar's clock 

• Mark special days 

• Print part of a calendar 

• Work with multiple calendars 

• Create, rename, and delete a calendar 

• Customize a calendar 
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Starting the Calendar 
To start the Calendar, choose the Calendar menu item from UE's 
Applications menu. 

The month display appears on your screen. 

~I Cale ndat": /USt"/staff/t"O/jeatl ne/.dxcale t~b!J16iI 
Fi Ie Edit View Tinles lot Options Help 
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The month display shows the current month and year, with the 
days in the month arranged by week in rows. The current day has 
a box around it. 

Moving Around Calendar 
Calendar has three main displays: the month display, the day 
display, and the year display, which looks like 12 small month 
displays set out in a 4 by 3 matrix. 

Scroll bars allow you to move backwards and forwards within a 
display, for example, to look at a future or a previous month when 
you are in a month display. 

To move from one type of display to another, double click on the 
appropriate item in the current display. For example, double 
clicking on one of the days visible in the month display opens the 
day display. Alternately, double clicking on a month in the year 
display opens the display for that month. 
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From the View menu, you can choose the Selected, Today, Day, 
Month, and Year menu items. Choosing the Today menu item 
displays the current day. To choose the Selected, Day, Month, and 
Year menu items, you must first select a day. 

:reating an Entry 
By double clicking on a particular day, you can open a display 
that shows timeslots from 8:00 a.m. to 5:30 p.m. Use the scroll 
bars to display timeslots earlier or later than the times shown. 
You can type entries, such as an appointment, directly into the 
timeslots. Or, by using the timeslot editor, you can type longer 
entries, activate alarms to remind you of appointments, and cause 
messages to repeat at regular intervals. 

To record a short entry directly into a day display: 

1 Display the day in which you want to make the entry. 

2 Click (and drag to resize, if necessary) on the desired time in 
the day display. 

3 Enter the text in the timeslot. 

4 Click on the time again. 

When a day has at least one entry in it, its day number 
changes from a normal font (nn) to an italic font (nn) 
wherever it is displayed. You can then distinguish between 
days containing appointments and free days in the month and 
year displays. 

To create a longer entry using the timeslot editor: 

Click on the desired timeslot in the day display. 
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2 Choose the Edit... menu item from the Timeslot menu or 
double click on the desired timeslot. 
The timeslot editor is displayed: 

~I Cale ndar: /usr/staff/rO/jean ne/.dxcalendar.dwc ~I@] 
File Edit View Timeslot Options Help 
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3 Enter the text and adjust the alarms and repeat intervals as 
required (see the sections Setting Alarms and Making Repeat 
Entries). 

The timeslot editor uses standard DECwindows editing 
commands. 

4 Click on the OK button to confirm the entry and to dismiss 
the timeslot editor. 

If you exit the editor without having entered any text, or if 
you delete all the text describing a previous entry, the timeslot 
remains unscheduled. 

Changing the Size of a Timeslot 
To change the size of an entry, press MBl on the time you want to 
use as a starting point and drag the top edge of the timeslot up, 
or the bottom edge of the timeslot down. The timeslot is redrawn 
to the new size. 

You can use this method to reduce or expand the time allocated 
for an entry. If you reduce the size of a timeslot, some text may 
no longer fit in the display, but it is not lost. The text reappears if 
you expand the timeslot again. 

Setting Alarms 
The timeslot editor allows you to set alarms for an entry, which 
cause an alarm to ring and a message to be displayed at the 
times you specify. You can set alarms to ring at one or all of the 
following times: 

• At entry time 

• 1 to 15 minutes before the time you specified for the entry 

• 1 to 60 minutes before the time you specified for the entry 

• 1 to 24 hours before the time you specified for the entry 

To set one or more alarms: 

Click on the desired timeslot in the day display. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Write the entry if you have not already done so. 

4 Click on the toggle button to set an alarm. 

By default, alarms ring 5 minutes before the entry time and 
at the entry time. 
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5 Move the arrow in the scale to adjust to the time you want. 

6 Click on the OK button to save the settings and to dismiss the 
timeslot editor. 

Deleting an Entry 
To remove or clear the contents of a timeslot: 

Click on the timeslot in the day display that contains the 
entry you want to delete. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Click on the Delete Entry button. 
A dialog box is displayed, asking you to confirm that you want 
to delete the entry. 

4 Click on Yes to confirm that you want to delete the entry. 

Making Repeat Entries 
Often, entries in a calendar are regular events. Calendar makes it 
easy to schedule these events by allowing you to specify the time 
interval at which the entry should be repeated. 

You can repeat an entry at the following intervals: 

• None 

• Daily 

• Weekly 

• Every fortnight (two weeks) 

• Every four weeks 

These settings are made from the timeslot editor. To set a repeat 
interval for an entry: 

Click on the timeslot in the day display that has the first 
occurrence of the entry. 

2 Choose the Edit... menu item from the Timeslot menu. The 
timeslot editor is displayed. 

3 Write the entry if you have not already done so. 

4 Choose the repeat interval you want by clicking on the 
appropriate option button. 
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You can only choose one repeat interval at a time. The preset 
option is None. 



5 Click on the OK button to save the settings and to dismiss the 
timeslot editor. 

If you change or delete an entry that is repeated, a dialog box is 
displayed, asking if you want to make the change or deletion in 
just this instance, from this point on, or every time, including past 
instances. 

~oving an Entry from One Timeslot to Another 
You can copy or move the entire contents of an entry, or just a 
piece of text, to another timeslot. If you select the time, then 
any alarms or repeat intervals associated with the entry are 
transferred, along with the text, to the new timeslot. Selecting 
just the text from the timeslot transfers just the text. 

To move an entry from one timeslot to another: 

Display the day that has the timeslot you want to move. 

2 To select the entire entry from a timeslot, click on the time. 
To copy just a piece of text, select it by clicking and dragging 
the pointer over the portion of text you want. 

3 Choose the Cut or Copy menu item from the Edit menu. 

If you want the entry to remain in the original timeslot, 
choose the Copy menu item. If you want to delete the entry 
from the original timeslot, use the Cut menu item. 

4 If you are moving the entry to a different day, display the new 
day. 

5 Click on the time to which you want to move or copy the entry 
or text. 

6 Choose the Paste menu item from the Edit menu to insert the 
entry or text in the new location. 

If you are moving the whole entry (time and text) and you want 
to move it to the same time on a different day, you do not have to 
display the new day. Mer selecting the desired day in the month 
display, choose the Paste menu item from the Edit menu. This 
causes the entry to be inserted on that day, at the same time. 
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Using the Clock in the Day Display 
The Clock provides a digital display of the current time. If 
you click on the clock, the timeslots visible in the day display 
adjust so that the first timeslot contains the time in the current 
increment that directly precedes the actual time. For example, if 
the timeslots in the day display are set to be in half hour intervah 
and you click on the clock at 10:57, the day display will adjust so 
that the first time slot contains the time 10:30. If the day display 
is not displaying the current day, . clicking on the clock causes the 
day display to return to the current day. 

As a timeslot passes, it is scrolled off the top of the display. Thus 
the display is kept as current as possible. This is convenient if 
you significantly reduce the size of the day display, because it 
keeps the most immediate timeslots in view. 

To stop this automatic scrolling, move the timeslot by any other 
method, such as adjusting the scroll bar. 

If you are making an entry in a timeslot when it is due to be 
scrolled, it does not disappear. The scroll mechanism waits until 
the next interval is over and then catches up. 

The Show AMlPM customizing option allows you to choose 
between a 12-hour and 24-hour clock. Whichever clock you choose 
is reflected by all Calendar-displayed times and clocks. 

Marking Special Days 
You can mark days of particular importance, such as major project 
milestones, holidays, or birthdays. Marking particular days alters 
the display font so that those days can be distinguished from 
other days in the various Calendar displays. 

To mark a day: 

1 Select the desired day from any of the Calendar displays. 

2 Pull down the Options menu and drag the pointer to the 
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submenu icon next to the Mark menu item to view the 
submenu. 

Whichever menu item is currently in use for the selected day 
is dimmed in the submenu. 



3 Choose the desired menu item from the Mark submenu: 

Choose 

Work Day 

NonworkDay 

Special 

Default 

To Produce 

Bold font 

Standard Calendar font 

Bold, larger font; on color workstations, displayed 
in red font 

The standard Calendar font the day had before it 
was previously marked with Work Day, Nonwork 
Day, or Special menu item. 

The day is now marked in the specified manner. 

Printing a Part of a Calendar 
You can print a timeslot entry or all of the entries in a day or a 
week. 

To print a part of a Calendar display: 

Display the day that relates to the entry or entries you want 
printed. 

For example, if you are printing a timeslot, display the day 
that contains the timeslot. If you are printing the entries in 
a day, display the day itself; to print the entries in a week, 
display a day that falls in that week. 

2 Click on the time, day number, or week number, as 
appropriate. 

3 Choose the Print... menu item from the File menu. 
Calendar displays a dialog box. 
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Thunday the 20th of October, 1988 
From: 1:30Plll To: 2:00pm 

Output File Name L.::..I1 _____________ 11 

@l Create New Fi Ie 
o Append to File 

.~ n 
o Limit lines per entt·y L::·:::·::J:rL·::::::::·::::: ...................................... ·::·] 

Lines r~~f pntry-

I Cancel I 

The dialog box shows the time period you have selected and 
provides a default name for the file to be sent to the printer. I 
also enables you to limit the number of lines you want printe( 
per entry by clicking on the Limit Lines Per Entry option and 
moving the arrow in the scale to set the desired limit. 

4 Change the default name provided by the dialog box if you 
want, and then confirm your request by clicking on the OK 
button. 

The requested section (timeslot, day, or week) is copied to the 
named file, and the file sent to the printer. 

Working with Multiple Calendars 
You can create, open, save, print, and delete calendars. You 
can create different calendars to use for specific purposes. For 
example, you could designate some calendars for your personal 
use and other calendars for use by a group. 

You can use the Open... menu item from Calendar's File menu, 
to open a calendar even if you do not have privileges to modify it. 
This makes it possible to use a calendar for informal sharing of 
information. For example, a group secretary can create a calenda: 
for events of group-wide interest, so that everyone on a team can 
see when group activities are going on. Only one person at a time 
can write in this calendar, and the calendar cannot be read while 
it is being modified. If no one is modifying the file, an unlimited 
number of people can read it simultaneously. 
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Creating a New Calendar 
To create a new calendar: 

Choose the Open... menu item from the File menu. Calendar 
displays a dialog box. 

File filter 

I::t.* 
Fi les in /usr/stafflrO/jean ne/ 

~I Filter 

Ok II 
Cancel I 

'r-1 

<) I 1(: D 

Selection 

If 

2 Type a unique file name for the new calendar in the Selection 
text entry field, and click on the OK button. The default file 
type is DWC. 

A dialog box is displayed, asking if the calendar currently 
being displayed should be removed before displaying the new 
calendar, or if you want to keep both calendars on the screen 
at the same time. Click on Replace or New to make your 
choice. 

3 Calendar asks if you want to create a new file. Click on Yes to 
create a new calendar. 

By default, the new calendar is presented in a month display 
containing the current day. 

The calendar file name can always be changed again (see the 
section Renaming an Existing Calendar). 
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Opening an Existing Calendar 
To open an existing calendar: 

Choose the Open... menu item from the File menu. 
Calendar displays a dialog box that prompts you for the name 
of the calendar you want to open. The file list box lists the 
names of any calendar files in the current directory; that is, 
files that have the type DWC. 

2 Select the file name you want to view and click on OK. 
If you want to open a calendar file that is not listed, type the 
name of that file in the Selection text entry field and click on 
the OK button. Or, use the File Filter text entry field to list a 
subset of files that you can then select from. For example, to 
list all files in another directory with the file type DWC, type 
the complete directory specification-/jones/staffl*.dwc-in the 
File Filter text entry field and click on the Filter button. Then 
double click on the file name of the calendar you want to open. 

A dialog box is displayed, asking if the calendar currently 
being displayed should be removed before displaying the new 
calendar, or if you want to keep both calendars on the screen 
at the same time. Click on New or Remove to make your 
choice. 
If you specify the name of a calendar which you are not 
allowed to read, the Open operation fails and a message box is 
displayed, explaining the cause of the failure. 

3 The calendar is opened. 

Renaming an Existing Calendar 
To rename the current calendar, choose the Name As... menu item 
from the File menu. 

A dialog box is displayed: 

New File Name a..:.:.n _______ _ 

I Cancel I 

ZK-0238A-GE 
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Type in the new calendar name. Calendar supplies the file type 
DWC by default. You can only rename calendars in which you are 
allowed to write. 

Closing a Calendar 
Choose the Close menu item from the File menu to close the 
current calendar. 

Deleting a Calendar 
Choose the Delete... menu item from the File menu to delete a 
calendar. Calendar displays a dialog box, asking whether you 
really want to delete the calendar. If you do not have sufficient 
privileges to delete the specified calendar, an error message is 
displayed. 
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Customizing a Calendar 
Many different features can be changed to customize the 
appearance and behavior of the various displays presented 
by the Calendar. All of these changes are made by selecting iteme 
from the Options menu. 

Calendar displays a dialog box. 

m calendar Settings '. ml 

First Day Work 
of Week Week 

@ ----- 0 Sunday 
o ----- !jJ Mo nday 

o ----- !jJ Tuesday 
o ----- !jJ Wed nesday 
0----- !jJ Thursday 
o ----- !jJ Friday 
0----- 0 SatUt'day 

o Fill Blank Days in 
Month Display 

First Display 
o Veat' Display 
@ Month Display 
o Day Display 

o Stat1 Iconized 

Day Display: 
Timeslot Size 

Co 1 hour 
(j) 30 minutes 
015 minutes 
05 minutes 

!jJ Show Months 
[j] S how AM/PM 

Working Hours 

Stat1 I!l~am 

Finish [!]~pm 

Date fot' Wee k No, 1 
4 

Iff] 
(j) Jan uat'y 
() February 
() 1\'1arch 
o April 
() May 
() June 
() July 
o August 
() September 
o October 
CJ Novembet' 
o Decembet' 

!jJ Include Week Number!! 

Shaded buttons indicate the current settings. Click on a button 
or its label to change the setting. Click on the Apply button to 
apply your changes without closing the dialog box. Click on the 
OK button to apply your changes and close the dialog box. 

From the Change Settings dialog box, you can modify any of the 
following calendar features: 
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First Day of Week 
Unless you specifY otherwise, the first day of the week is Sunday, 
as indicated by a shaded option button. You can designate another 
day as the first day of the week by clicking on it. 

Work Week 
Normally, Calendar designates Monday through Friday as the 
work week, as indicated by the shaded toggle buttons immediately 
to the left of the days. You can change the settings by clicking on 
the days you want to use for your work week. 

Fill Blank Days in Month Display 
Unless you specifY otherwise, Calendar leaves the days not filled 
by the current month blank. When you turn on the Fill Blank 
Days in Month Display option, Calendar fills the blank days at 
the beginning and end of the current month with the dates of the 
preceding and following months. 

First Display 
When you start Calendar, the month display appears on your 
screen by default. You can click on Year Display or Day Display to 
choose either of those options to be the first display you see when 
you start Calendar. 

Start Iconized 
Normally, when you start Calendar you see a display of the 
current month. By turning on the Start Iconized option, you can 
cause Calendar to start as an icon. 

Day Display: Timeslot Size 
By default, the day display has timeslots broken up into 
30-minute intervals. You can choose 1-hour, 15-minute or 
5-minute intervals instead. 

Show Months 
Unless you specifY otherwise, Calendar displays the current and 
next month at the top of a day display. You can disable this option 
by turning off the Show Months option. 

ShowAMjPM 
By default, Calendar has a 12-hour time system that uses AM and 
PM in its day display to differentiate timeslots. If you disable the 
Show AMlPM option, Calendar uses a 24-hour time system in its 
day display-for example, 1 p.m. becomes 13:00, and so on. 
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Working Hours 
Calendar uses the preset options 8:30 a.m. to 5:30 p.m. for 
working hours, which determine the timeslots it uses in the 
day display. You can change these values by clicking on the 
appropriate box to set the time you want. 

Date for Week No. 1 
In every month display, the leftmost column lists the number of 
each week. This is in effect as long as the Include Week Numbers 
option is turned on. By default, weeks are numbered starting 
with the first week of January as week number one. The following 
weeks are numbered accordingly, ending with the last week in 
December as number 52. 

The Date for Week No. 1 option enables you to set the week you 
want to designate as the first week of the year by choosing the 
desired month and moving the arrow in the scale to the desired 
date. For example, if your fiscal year starts the first week of July 
and you want to designate that week as the first week of the year, 
choose July from the list of months and choose a date number thai 
falls in the first week of July. To ensure that the date you choose 
falls in the first full week of the month, you may want to choose a 
date such as July 6. 

The date January 4 is the preset option, which ensures that the 
first full week in January is used as the first week of the year. 

Include Week Numbers 
Unless you specify otherwise, the leftmost column in every month 
display lists the number of each week, starting with the first week 
of January as week number one. You can disable this feature by 
turning off the Include Week Numbers option. 

Saving Customized Features 
To save your customized features, choose the Save Settings menu 
item from the Customize menu. This causes your new settings 
to be used whenever you start a Calendar session. The size and 
placement of all displays are also saved. 

To restore your settings to the currently saved defaults, drag the 
pointer to the submenu icon next to the Customize menu item, 
and release MBl over the Restore Settings menu item. 

To restore your settings to the system defaults, drag the pointer t( 
the submenu icon next to the Customize menu item, and release 
MBl over the Use Defaults menu item. 
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Changing the Shape of a Display 
You can change the size of any Calendar display by using the 
window's size button. If you resize the display to be smaller than 
the elements inside it, Calendar will try to rearrange the elements 
to fit the new size, but some of the elements may not be visible. 
For example, if you resize the year display so that is only big 
enough to display 8 months, Calendar will display only the next 
8 months. 

To save the size settings from one session to the next, use the 
Save Settings menu item on the Customize submenu from the 
Options menu. 

Exiting from the Calendar 
To exit from Calendar and close all open calendars, choose the 
Exit menu item from the File menu. 
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3 
Using the Cardfiler 

The Cardfiler lets you create an electronic box of index cards. This 
electronic file box is called a card file. Card files contain cards, 
which can hold any kind of information you like, such as names, 
addresses, and telephone numbers. For example, you could have 
a card file called Food filled with cards that contain recipes and 
names of restaurants. 

By organizing your index cards into sets (card files), you can keep 
one group of cards separate from another group, for example, your 
business cards and your personal cards. 

This chapter describes how to 

• Start the Cardfiler 

• Create and add cards to a card file 

• View topics in a card file 

• Search a card file for text 

• Edit a card 

• Incorporate graphics 

• Open an existing card file 

• Save a card file 

• Merge two card files 

• Exit from the Cardfiler 
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Starting the Cardfiler 
To start the Cardfiler, enter the following command in a DECterm 
terminal emulator window: 

% dxcardfiler & 

The Cardfiler displays an empty card file in the Cardfiler window. 
Initially, the card file is empty, but it fills up with index topics as 
you add cards. 

~I Cardfiler: untitled 1b:!J1@J 
File Seat"Ch Cat·d Help 

6 -

'-
Q 

Adding a Card 
You start a file of index cards by adding a card. As you add cards 
they are sorted alphabetically according to the topic you type in 
the card's index field. Very likely, this topic will be the name of 
something, such as a person or business. By displaying the topic 
of each index card, the card file window lists the contents of the 
card file. To add a card: 
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Choose the Create Card... menu item from the Card menu. 
The Cardfiler displays a blank index card in the Card windoVl 
The dialog box prompts you to type the topic of the new inde)! 
card. 



~ Cardfilet": untitled ~@] 
File Search Card Help 

Inl 
Inde:-c for this card: 

Cancel I 

I~I 
2 Type the new topic under which you want the card filed. 

3 Press the Return key or click on the OK button. 

The text you just typed is added to the title bar at the top of 
the Card window and to the contents of the Cardfiler window. 
You can add information to the new card. 

4 Type any information belonging on the index card, for 
example, an address. 

Type the text as you want it to appear, using the Return key, 
space bar, and Tab key to format it. Cards can contain up to 
4000 characters, and up to 64K bytes of graphics. 

5 When you are finished with the index card, choose the Close 
menu item from the file menu. 

The Card window is closed and the contents of the index card are 
added to your card file. 

You can open another index card in the card file without closing 
the current card. When you choose the Create Card... menu 
item from the Card menu in the Cardfiler window, the Cardfiler 
automatically saves any changes you made to the current index 

Using the Cardfiler 3-3 



card and returns it to the card file before it opens a new card in 
the file. 

Viewing the Contents of a Card File 
Although you can look at only one index card at a time, you can 
easily switch from one card to another by selecting a card from 
the card file window. When your card file contains too many card~ 
to list in a window at a time, you can use the scroll bar to move 
through the file. You can also search the contents of a card file fOJ 
a given text string. 

Opening an Existing Card 
To display the contents of a card you have already created, select 
the card from the card file window by pointing to its index line 
and clicking MBI. 

The card's index topic becomes shaded and the contents of the 
card are displayed in the Card window. 

Scrolling Through a Card File 
As you accumulate cards, they cannot be listed all at once in the 
card file window. The scroll bar along the left side of the card file 
lets you scroll through the list of the index cards in your file. To 
scroll through the list of index cards in your file, click and hold 
MB:b on the stepping arrow. The position of the slider indicates 
your position in the list. When the slider is at the top of the scroll 
bar, you are at the beginning of the list. When the slider is at the 
bottom of the scroll bar, you are at the end of the list. 

Finding Text 
You can search a card file for any text string. The text can be a 
word, a number, or any other characters that you can type on yOUl 
keyboard. Because the Cardfiler treats spaces as text, you can 
search for two or more words. 

The Cardfiler searches either the index topics or the contents of 
the index cards. 

To search the index topics in a card file for specific text: 
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Choose the Search Index... menu item from the Search menu 
in the card file window. 



Cardfiler displays a dialog box. 

Search Index III 
Go to: 

II OK II Cancel I 

2 Type the text you want located. 

3 Press Return or click on the OK button. 

The Cardfiler searches the topics of all index cards in the file and 
displays the first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text in its index field. 

To search the contents of each card in the file for specific text: 

Choose the Search Card... menu item from the Search menu 
in the card file window. 
Cardfiler displays a dialog box. 
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Editing a Card 

S e arc h Card [S] 
Find: 

OK II Cancel I 

2 Type the text string you want located. 

3 Press Return or click on the OK button. 

The Cardfiler searches all index cards in the file and displays the 
first card in your file containing the text string. 

You can continue to search for a text string by choosing the Find 
Next menu item from the Search menu in the card file window. 
The Cardfiler continues to search the card file for the text and 
displays each card that contains the text. 

The Cardfiler editing commands let you copy, delete, and 
rearrange text on an index card. If you decide you do not want to 
save your edits, Cardfiler can restore the card to its original state. 

Renaming a Card 
To change the topic of an index card, you modify the index line: 

Select the card you want to rename from the card file window 
by pointing to it and clicking MB1. 

2 Choose the Rename... menu item from the Card menu on the 
Card window. 

3 Use the arrow keys to move the text cursor and the Delete ke~ 
to erase unwanted text. 

4 Type the new topic under which you want the card filed. 

5 Click on the OK button. 
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The card is renamed and remains open. If you want to close the 
card, choose the Close menu item from the card's File menu. 

Moving the Text Cursor 
When you create a new card, the text cursor appears in the upper 
left corner of the card window. When you open an existing card, 
the text cursor remains where it was when you last edited the 
card. 

If you are creating a new card and want to move the text cursor, 
use the Return key or place the pointer where you want the text 
cursor and click MB1. You can use this method to move the text 
cursor on an existing card, or you can use the arrow keys to move 
the text cursor anywhere in the existing text (except to the index 
line). 

Selecting Text 
In order to delete, move, or copy text, you must first select that 
text. Select the text by pressing and holding MB1, dragging the 
pointer over the text, and releasing MB1. This highlights the 
selected text. The Cardfiler stores this text until you tell it what 
to do. 

Deleting Text 
To delete small amounts of text on your card, use the Delete 
key. If you selected text for deletion, press any key to delete the 
highlighted text. 

Moving Text 
Because the Cardfiler saves the last text you selected and deleted, 
you can move text from one location on a card to another or 
between cards. 

To move text on a card: 

Select the text you want moved to another location on the 
card. 

2 Choose the Cut menu item from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positioning 
the pointer and clicking MB1. 

4 Choose the Paste menu item from the Edit menu. 

The deleted text appears in the new location. 
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To move text from one card to another: 

1 Select the text you want to move to another card. 

2 Choose the Cut menu item from the Edit menu. 

3 From the card file window, click on the card to which you wan 
to move the text. 

The new card is opened. 

4 Move the text cursor to where you want the deleted text 
inserted by using the Return and arrow keys or by positionin~ 
the pointer and clicking MB1. 

5 Choose the Paste menu item from the Edit menu. 

The selected text is inserted in the new location. 

Copying Text 
Because the Cardfiler keeps track of your selected text, you can 
copy text from one location on a card to another and between 
cards. 

To copy text on a card: 

Select the text you want copied to another location on the 
card. 

2 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MB1. 

3 Click MB2. 

The selected text is copied to the new location. 

To copy text from one card to another: 

Select the text you want copied to another card. 

2 Choose the Copy menu item from the Edit menu to store the 
copied text. 

3 From the card file, click on the card to which you want to 
move the text. 
The new card is opened. 

4 Move the text cursor to where you want the selected text 
copied by using the Return and arrow keys or by positioning 
the pointer and clicking MB1. 

5 Choose the Paste menu item from the Edit menu. 
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The text is copied to the new location. 

Incorporating Graphics 
You can add graphics, such as those you create with the Paint 
program, to index cards. The Cardfiler places a graphic at the top 
of a card, keeping the picture's original size, and relocates text 
to the remaining space. Choose the Read Graphic menu item to 
incorporate a graphic. Choose the Clear Graphic menu item to 
erase it. 

Opening a Card File 
You can open a new card file or reopen an existing file. If you try 
to open another card file without first saving any changes you 
made to the current file, a dialog box is displayed, asking whether 
you want to save your changes. Click on the Yes button to save 
your changes. Click on the No button to return to the current file. 

To open a card file: 

Choose the Open... menu item from the File menu. 

Cardfiler displays a dialog box. 

lEE] Cardfiler: Open !PJJ 
Fi Ie filter 

II*.cat·d 

File name: 

~:I 
Filter I 

Ok II 
I Cancel I 

Q 

(JO(> 0 

Selection 

II.~ard 

2 To open an existing card file, select the name of the file you 
want to open. 

Use the scroll bars to view a complete list of your card files. 
The card file name you select is displayed in the text field. 
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If you want to open a new file, type the file name you want to 
use in the Selection text field and click on the OK button. The 
new name is displayed in the title bar, and the Cardfiler asks 
if you want to open a new file. Click on the Acknowledged 
button to verify that you do. 
The new card file is displayed. 

Saving a Card File 
Whether you create a new card file or make changes to an existing 
card file, such as adding or deleting a card or changing any 
information on a card, you need to save that card file when you 
are done working with it. 

To save a new card file or change the name of an existing one: 

Choose the Save As... menu item from the File menu in the 
card file window. 

Cardfiler displays a dialog box, prompting you for the name of 
the file. 

W Save File I!;] 
File filter 

II*.card 

File name: 

.(). I Fi Ite t· I 

~'Fa::el II 

I 
Q-

<)0(> D 

Selectiofl 

I·card 

2 Using the Delete and arrow keys, delete any text in the 
Selection text field and type the name of file. The default file 
type for card file names is card. 
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Give the file a name that you can easily recognize. For 
example, if the card file contains the numbers of your business 
associates in Rome, you can name the file rome. card. Giving 
the file a file type of card lets you quickly recognize that this 
is a card file. 



3 Press Return or click on the OK button. 

You are returned to the card file window. If you saved a new 
card file, notice that the name of the card file in the title 
bar has changed from untitled to rome. card. If you saved an 
existing card file, the card file name is replaced by rome.card. 

To save the current card file, choose the Save menu item from the 
File menu in the card file window. 

To save the current card file under a new file name: 

Choose the Save As... menu item from the File menu in the 
card file window. 

2 Using the Delete and arrow keys, delete any text in the text 
field and type the file's new name. 

3 Press Return or click on the OK button. 

You are returned to the card file window. Notice that the title bar 
contains the new card file name. 

Merging Card Files 
You can merge the contents of the current file with another file, 
resulting in a card file that combines and sorts the contents of 
both files. The card file whose contents were merged with the 
current card file remains unchanged. 

Choose the Merge... menu item from the File menu on the 
card file window. 

Cardfiler displays a dialog box. 
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e File 

Fi Ie fi Itero 

II*ocatOd 

Fi Ie nanle: 

6- Filter I 

<)0(>· D 

Selection 

IIocatOd 

II Ok II 
I Cancel I 

2 Select the name of the file you want to merge with the curren1 
file. Use the scroll bars to view a complete list of your files. 

The file name you selected is displayed in the text field. 

3 Press Return or click on the OK button. 

The contents of the two card files are merged and sorted 
alphabetically. 

Exiting from the Cardfiler 
To exit from the Cardfiler, choose the Quit menu item from the 
File menu in the card file window. 

If you have not saved any changes or additions to the current file, 
Cardfiler displays a dialog box, asking whether you want to save 
your changes. 
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Cautio n [!I] I 

o 
Do yo u want to sa\'e the ClU"t"e nt data 

befot"e exiti ng"? 

II Yes II ~ I Cancel I 
Click on the Yes button to save your changes and exit from the 
Cardfiler or the No button to exit from the Cardfiler without 
saving your changes. To return to the Cardfiler window, click on 
the Cancel button. 
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4 
Using the Clock 

The Clock displays the time (in both analog and digital format) 
and the date. You can change this display to suit your needs. You 
can also set the Clock's alarm to remind you of appointments . 

This chapter describes how to 

• Start the Clock 

• Customize the Clock display 

• Set the alarm 

• Exit from the Clock 

Starting the Clock 
To start the Clock, choose the Clock menu item from DE's 
Applications menu. 

The Clock is displayed on your screen. You can move and change 
the size of the Clock as you wish. 
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DI Clock 101@] 
OCT • 

. ( • • 
24 . . 

• 

MON 5:04 pm 

Changing the Clock Display 
You can customize the Clock display to include any combination of 
the date and time areas. 

To change the Clock display: 

1 Place the pointer anywhere in the Clock display. 

2 Press and hold MB2. 

Clock displays a pop-up menu. 

EJI Clock 101Eill 
OCT · . . . I . . . 

24 . Setti ngs ... 

MON ~ Help [-7 
5:~ 

Quit 



3 Choose the Settings... menu item. 

Clock displays a dialog box. 

Clock Setti ngs ~ 

Components: 

[jJ Analog III Dig ital 

Alarm Settings 

D Alat"m lID 10(( 

Alarm Message 

[jJ Date 

~1 AM 
o PM 

OK I Cancel I 

Shaded toggle buttons indicate the current settings. Click MBI on 
a toggle button or its label to change the setting. For example, if 
you want only the analog clock displayed and the Analog, Digital, 
and Date toggle buttons are shaded, click on the Digital and Date 
toggle buttons to disable those settings. 

Click on the OK button to save any changed settings. Click on 
the Cancel button to return to the date and time display without 
changing any settings. 

You can also display the Settings... dialog box directly without 
first displaying the pop-up menu by double-clicking MBI 
anywhere on the Clock display. 

Setting the Alarm 
You can set the alarm to remind you of an appointment-or lunch. 

To set the alarm from the Settings dialog box: 

1 Click MBI on the alarm toggle button to switch the alarm on. 

2 Move to the hours field and type the hour at which you want 
the alarm to go off. You can either use a 12-hour clock, in 
which case you need to specify AM or PM, or you can use a 
24-hour clock (military time). 

Use the Delete key to erase any number already entered or to 
correct typing mistakes. 
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3 Move to the minutes field and finish entering the time you 
want the alarm to go off. 

4 If you are using a 12-hour clock or if the time you specify is 
less than 12:00, click on either the AM or PM option button. 

5 To display a message on your screen when the alarm goes 
off, move to the alarm message field and type your message. 
Alarm messages may contain up to 200 characters. 

6 Click on the OK button to save the settings. Click on the 
Cancel button to return to the date and time display without 
changing any settings. 

When the alarm goes off, click on the Acknowledged button to 
clear the alarm message from your screen. 

Exiting from the Clock 
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To exit from the Clock, choose the Quit menu item from the 
Clock's pop-up menu. 
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5 
Using the DDIF Viewer 

The DDIF Viewer lets you view DDIF (DIGITAL Document 
Interchange Format) files. DDIF is a standard format for the 
storage and interchange of compound documents. Compound 
documents contain multiple elements, for example, text and 
graphics. DDIF files cannot be viewed as ordinary text files . 

The DDIF Viewer displays only DDIF files. If you specify a file 
that is not a DDIF file, for example, a text (ASCII) file, the file is 
converted to DDIF before it is displayed. 

This chapter describes how to 

• Start the DDIF Viewer 

• Display DDIF files 

• Change processing options 

• Exit from the DDIF Viewer 

)tarting the DDIF Viewer 
To start the DDIF Viewer and view a file, choose the DDIF menu 
item from UE's Applications menu or enter the following command 
in a DECterm terminal emulator window: 

% dxvdoc & 

You can specify several options on the command line to specify the 
format of the file or files to be displayed, the optional processing 
to be applied, and the name of the first file. See the ULTRIX 
Worksystem Software reference page on the xvdoc(lX) command 
for information about these command options. 
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The DDIF Viewer displays its main window, which is where you 
view DDIF files. 

€PI DDIF Viewer: @ Digital Equipment Corp. 1988. All Rights Resen,elt2J@J 

File Help 

G -

<)0 1(> 

Viewing DDIF Files 
To view a DDIF file in the DDIF Viewer window, you must open 
it. To open a DDIF file: 

Choose the Open... menu item from the File menu. 

The Viewer displays a dialog box that prompts you for the 
name of the file you want to view. The file list box lists the 
names of any DDIF files in the current directory. 
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File fi Itet· 

II*.ddif 

Files in 

6 Format 

~ 
Options File 

Enter new file name 

P*·ddif 

II0 01F 

II 

2 Type in the format of the file you want to view. 

Filter I 

Cancel 

Type TEXT if you want to view a TEXT file. Type DDIF if you 
want to view a DDIF file. 

3 Optionally, enter the name of a file containing the processing 
options to be applied as your file is loaded for viewing. 
If you do not specify an options file, preset processing options 
are used. See the ULTRIX Work system Software reference 
page on the xvdoc(lX) command for information about these 
options. 

4 Double click on the file name you want to view. 
The DDIF Viewer displays the file you specified. 

If you want to view a DDIF or TEXT file that is not listed, type 
the name of that file in the Enter new file name text field and 
click on the OK button. Or, use the File filter text entry field to 
list a subset of files that you can then select from. For example, 
to list all files in another directory with the file type ddif, type the 
complete directory specification -/jones/project/* .ddif-in the File 
Filter text entry field and click on the Filter button. Then double 
click on the file name of the file you want to view. 
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The DDIF Viewer displays the contents of the file you specified. 
The title bar contains the name of the file currently viewed. 

Changing Processing Options 

Closing a File 

You can change the processing options that the DDIF Viewer uses 
to display your file. By default, the DDIF Viewer uses automatic 
word wrapping and soft directives. Soft directives consist of 
formatting information inserted into the file by a text editor or 
converter. (Form feeds and carriage returns are two kinds of soft 
directives.) If the file you are viewing was created with a tool or 
converter that does not write soft directives, the default processing 
options may produce an unclear display. By turning soft directives 
on or off, you may make an unclear display more readable. 

To change the processing options: 

Choose the Set-Up... menu item from the File menu. 
The Viewer displays a dialog box. 

(jJ Word Wrap 
~ Soft D it"ectives 

Cancel I Apply 

2 Click on the toggle buttons to change either processing option. 

3 Click on Apply. 

The DDIF Viewer closes the file and reopens it with the new 
options in effect. 

When you have finished viewing a file, close it by choosing the 
Close menu item from the File menu. This keeps the DDIF 
Viewer active for you to open another file. If you open another 
file without closing the current one, the DDIF Viewer closes the 
current file before opening the next one. 
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Exiting from the DDIF Viewer 
To exit from the DDIF Viewer, choose the Exit menu item from 
the File menu. If you did not close the last file you viewed, the 
DDIF Viewer closes it before exiting. 
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6 
Using DECterm 

DECterm creates a window that emulates a VT320 terminal. 

This chapter describes how to 

• Create a DECterm emulator window 

• Customize DECterm characteristics 

• Copy information 

• Change DECterm windows 

• Compose characters 

• Exit from a DECterm window 

Creating a DECterm Window 
To create a DECterm window, choose the Terminal Window menu 
item from the Session Manager's Create menu. 

Using DECterm 6-1 



Give the DECterm window input focus by pointing to the window 
and clicking MB1. 

Customizing DECterm 

6-2 Using DECterm 

Once you have created a DECterm window, you can choose the 
operating features you want the window to have and then save 
these features by using the DECterm Customize menu. 



Window .. . 

Display .. . 

General .. . 

Keyboard ... 

7-bit NRCS Se lectio n ... 

Use Last Saved Setti ngs 

Use Syste nl Defau Its 

Save Curre nt Settings 

Use Saved Setti ngs fro nl .. . 

Save Curre nt Setti ngs as .. . 

Customizing a Window 
You can change DECterm's window features, such as the size 
of the window, by choosing the Window... menu item from the 
Customize menu. DECterm displays a dialog box. 
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\j] record Ii nes off to p 
\j] vertical scro II bar 

Terminal Size 

~ rows I 8Q columns D horizo ntal SCt"O II bar 
\j] vetiical cursor coupling [!2J 

~ 
D horizo ntal cut"sor co u p ling 
\j] auto resize terminal 
\j] auto t"esize window 
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o big font 
@ little fo nt 

o normal font (80 columns) 
o condensed font (132 columns) 
@ normal/80, co nde nsed/132 

Apply I I Cancel 

Shaded buttons indicate the current settings" Click MBl on a 
button or its label to change the setting" Click on the Apply 
button to apply your changes without closing the dialog box. Click 
on the OK button to apply your changes and close the dialog box. 

From the Window dialog box, you can customize any of the 
following window features: 

Record Lines Off Top 
Normally, lines that are scrolled off the top of the DECterm 
display are not saved. To save lines that are scrolled off the top 
of the DECterm display, click on Record Lines Off Top. A shaded 
toggle button indicates that DECterm is saving the lines. 

To view the lines that are scrolled off the top of the display, use 
the vertical scroll bar. By default, DECterm does not have vertical 
scroll bars, so you have to turn them on from the Window dialog 
box. 

Vertical Scroll Bar 
Unless you specifY otherwise, DECterm windows do not display 
vertical scroll bars. Click on Vertical Scroll Bar to display a 
vertical scroll bar on the right-hand side of your DECterm 
window. 



Horizontal Scroll Bar 
Normally, DECterm windows do not display horizontal scroll bars. 
Click on Horizontal Scroll Bar to display a horizontal scroll bar at 
the bottom of your DECterm window. 

Vertical Cursor Coupling 
By default, when you vertically change the size of your window or 
terminal, the cursor remains visible. For example, if your screen 
display contains 24 rows and you shrink it to five rows, the cursor 
remains visible and allows you to enter text. You can disable this 
option by clicking on it. 

Horizontal Cursor Coupling 
By default, when you horizontally change the size of your window 
or terminal (for example, from 132 columns to 80 columns), the 
cursor does not remain visible. You can override this default by 
turning on the Horizontal Cursor Coupling option. 

Auto Resize Terminal 
By default, when you use the Window Set-Up dialog box to modify 
your terminal size, the window size changes to conform to it. 
Clicking on Auto Resize Terminal causes the terminal size to 
change to conform to the window size whenever you modify the 
window size. 

Auto Resize Window 
By default, when you modify the terminal size, the window size 
changes to conform to it. Disabling Auto Resize Window means 
that if your terminal characteristics cause more characters to be 
displayed than your current window size can accommodate, those 
characters will not appear in the window. 

Big Font 
Unless you specify otherwise, the Little Font option is on, which 
causes DECterm to display a 12-point font. Clicking on the Big 
Font option displays an 18-point font. 

Little Font 
Unless you specify otherwise, the Little Font option is on, which 
causes DECterm to display a 12-point font. 

Normal Font 
Clicking on the Normal Font option causes the Normal Font 
(80 columns) to be used. The preset option for font size is Normal 
Font/80, Condensedl132. 
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Condensed Font 
Clicking on the Condensed Font option causes the Condensed 
Font (132 columns) to be used. The preset option for font size is 
Normal Font/SO, Condensedl132. 

NormaIFont/S~ Condensed/132 
The preset option for font size is Normal Font/SO, Condensedl132, 
which causes the font to adjust to match the width of the terminal. 

Terminal Size 
Normally, the terminal size is set to 24 rows and SO columns. By 
clicking on the size you want, you can change the row setting 
to 4S or 72, and the column setting to 132. You can also set the 
column and row to be any number from 1 to 132 by clicking on the 
text entry field, deleting any existing numbers, and typing in the 
new settings. 

Customizing a Display 
You can modify DECterm's display features, such as the type of 
cursor, by choosing the Display... menu item from the Customize 
menu. DECterm displays a dialog box. 

D auto wrap 
!II dis p I aye u t"S 0 t" 
III cursor bl ink 

(') block Cut·SOt" 
() underline cursor 

':j) dat"k te:«, I ig ht backgt"o u nd 
() light te:-:1:, dat"k backgt"ound 

~i) no status dis play 
() host status display 

OK II Apply I I Cancel 

From the Display dialog box, you can customize any of the 
following display features: 



Auto Wrap 
Normally, when the cursor reaches the right margin, each new 
character deletes the previous character. Clicking on Auto Wrap 
causes new characters to be displayed on the next line. 

Display Cursor 
Unless you specify otherwise, a cursor is displayed in your 
DECterm window. Disabling Display Cursor causes your cursor to 
become invisible. 

Cursor Blink 
Unless you specify otherwise, your cursor blinks. Disabling Cursor 
Blink causes a non-blinking cursor to be displayed. 

Block Cursor 
Unless you specify otherwise, the cursor displayed in your 
DECterm window is block shaped. 

Underline Cursor 
The default cursor for DECterm is block shaped. Clicking on 
the Underline Cursor option causes an underline cursor to be 
displayed. 

Dark Text, Light Background 
Unless you specify otherwise, DECterm displays dark text with a 
light background. 

Light Text, Dark Background 
You can change the default of dark text with a light background 
by clicking on the Light Text, Dark Background option. 

No Status Display 
Unless you specify otherwise, you do not receive host status 
messages. Host status messages, when activated, appear on the 
bottom line of your window display. 

Host Status Display 
To receive host status messages, turn on the Host Status Display 
option, which causes the messages to appear on the bottom line of 
your window display. You can only set Host Status Display on a 
300-series terminal. 
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Customizing General Features 
You can change general features, such as the terminal type, by 
choosing the General... menu item from the Customize menu. 
DECterm displays a dialog box. 

o newline 
o lock UOKs 
o lock user features 

@ normal CUt"Sot" keys 
o appl cut"SOt" keys 

Tet"minal 10 

@ OECtenll 10 

o VT340 10 

OVT320 10 

o VT240 10 

o VT220 10 
(.) VT125 10 

o VT102 10 

o VT101 10 
o VT100 10 

(f) n u met"ic keypad 
lJ application keypad 

.:il UPSS DEC Supplemental 
CJ UPSS ISO Latin 1 

.:il 8-b it 1\.., ulti national charactet"s 
() 7-b it NRCS chat"actet"s 

() VT300 mode, 8-bit contt"ols 
C) VT300 mode, 7-b it co nb"o Is 
i.j) VT100 mode 
() VT52 mode 

OK II A P ply I I Ca n ce I I 

From the General dialog box, you can set any of the following 
terminal features: 

New Line 
Normally, pressing the Return key does not move the cursor to 
start a new line. Clicking on New Line causes the cursor to move 
to start a new line when you press the Return key. 

Lock UDKs 
Your keyboard contains keys you can define for your own use. 
Unless you specify otherwise, once you have defined a key, the 
host system can change the function of the key back to the systell 
default. Clicking on Lock UDKs locks the user defined keys so 
that the host system cannot change your definitions. 

Lock User Features 
DECterm lets you change two user features: Auto Repeat and 
Foreground and Background Display. The host system can chang 



these functions to the system default unless you click on the Lock 
User Features option to prevent it from doing so. 

Normal Cursor Keys 
Unless you specify otherwise, the Normal Cursor Keys is on, 
which causes the Arrow keys to move the cursor up, down, left, 
and right. 

Appl Cursor Keys 
By clicking on the Application Cursor Keys option, you can 
override the Normal Cursor Keys default and set the Arrow keys 
to application-specific functions. 

TerminallD 
You can set the device attributes response (Terminal ID) by using 
the Terminal ID menu item. The Terminal ID lets the host system 
know specific operating attributes of the terminal. The preset 
option is DECterm ID. 

You can choose the following Terminal IDs: 

• DECterm 

• VT340 

• VT320 

• VT240 

• VT220 

• VT125 

• VT102 

• VT101 

• VT100 

Numeric Keypad 
Unless you specify otherwise, the Numeric Keypad option is set, 
which means that pressing the numeric keypad produces the 
characters that appear on the keycaps. 

Application Keypad 
You can override the Numeric Keypad default by clicking on the 
Application Keypad option, which causes the numeric keypad to 
function as a set of user defined keys. 
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UPSS DEC Supplemental 
Unless you specify otherwise, the UPSS DEC Supplemental option 
is on, which causes the DEC Multinational Character Set to be in 
effect. 

Column 0 1 2 3 4 5 6 7 

b8 Bits 0 0 0 0 0 0 0 0 
b7 0 0 0 0 1 1 1 1 

b8 0 0 1 1 0 0 1 1 
b5 0 1 0 1 0 1 0 1 

Row b4 b3 b2 bl 

0 20 40 60 1~2 120 140 160 
0 o 0 0 0 NUL 0 OLE 16 SP 32 0 48 @ P 80 96 P 112 

0 10 20 30 40 50 60 70 
1 21 41 61 101 121 141 161 

1 o 0 0 1 SOH 1 DC1 17 I 33 1 49 A 65 Q 81 a 97 q 113 
1 11 21 31 41 51 61 71 
2 22 .. 42 62 102 122 142 162 

2 o 0 1 0 STX 2 DC2 18 34 2 50 B 66 R 82 b 38 r 114 
2 12 22 32 42 52 62 72 
3 23 43 63 103 123 143 163 

3 o 0 1 1 ETX 3 DC3 19 # 36 3 51 C 67 S 83 C 99 S 115 
3 13 23 33 43 53 63 73 
4 24 44 64 104 124 144 164 

4 o 1 0 0 EOT 4 DC4 20 $ 36 4 52 0 68 T 84 d 100 t 116 
4 14 24 34 44 54 64 74 
5 25 45 65 105 125 145 165 

5 o 1 0 1 ENQ 5 NAK 21 % 37 5 53 E 69 U 85 e 101 u 117 
5 15 25 35 45 56 65 75 
6 26 46 66 106 126 146 166 

6 o 1 1 0 ACK 6 SYN 22 & 38 6 54 F 70 V 86 f 102 V 118 
6 16 26 36 46 56 66 76 
7 27 47 67 107 127 147 167 

7 o 1 1 1 BEL 7 ETB 23 39 7 55 G 71 W 87 9 103 W 119 
7 17 27 37 47 57 67 77 
10 30 50 70 110 130 150 170 

8 1 0 0 0 BS 8 CAN 24 ( 40 8 56 H 72 X 88 h 104 X 120 
8 18 28 38 48 58 68 78 
11 31 51 71 111 131 151 171 

9 1 0 0 1 HT 9 EM 25 ) 41 9 57 I 73 Y 89 I 105 Y 121 
9 19 29 39 49 59 69 79 
12 32 . 52 72 112 132 152 172 

10 1 0 1 0 LF 10 SUB 26 42 : 58 J 74 Z 90 J 106 Z 122 
A lA 2A 3A 4A 5A 6A 7A 
13 33 53 73 113 133 153 173 

11 1 0 1 1 VT 11 ESC 27 + 43 ; 59 K 75 [ 91 k 107 { 123 
B lB 2B 3B 4B 5B 6B 7B 
14 34 54 74 114 134 154 174 

12 1 1 0 0 FF 12 FS 28 , 44 < 60 L 76 \ 92 I 108 I 124 
C lC 2C 3C 4C 5C 6C 7C 
15 35 56 75 115 135 156 175 

13 11 o 1 CR 13 GS 29 - 45 = 61 M 77 ] 93 m 109 } 125 
0 10 20 3D 40 50 60 70 
16 36 56 76 116 136 156 176 

14 1 1 1 0 SO 14 RS 30 46 > 62 N 78 1\ 94 n 110 ~ 126 
E IE 2E 3E 4E 5E 6E 7E 
17 37 57 77 117 137 157 177 

15 11 11 SI 15 US 31 I 47 ? 63 0 79 95 0 111 DEL 127 
F IF 2F 3F 4F - SF SF 7F 

Key 

Character 

j.- CO Codes ----.",..141--------- (As~11~~~~iC) ---------.1,1 
Octal 
Decimal 

'--_.J..:..=:...J H•ex ZK-0347A-GE 



8 9 10 11 12 13 14 15 Column 

1 1 1 1 1 1 1 1 be Bits 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 b6 
0 1 0 1 0 1 0 1 b6 

b4 b3 b2 b1 Row 
. 200 

DCS 
220 2..a . 260 

A 
300 320 • ~~ :g 0 128 1~ 160 176 1G2 208 o 0 0 0 

80 eo AO eo CO DO EO FO 

~~ PU1 
221 241 251 

A 
301 

N 
321 , ~~ 

..., 
1 145 I 161 :t 1n 1G3 20G fI 241 o 0 0 1 

81 G1 A1 B1 C1 01 E1 F1 

~~ PU2 ~ ~: 2 ~ A 
302 

0 ~ i ~ 0 = 2 e 1G4 o 0 1 0 
82 G2 A2 B2 C2 02 E2 F2 

~~ ~~ ~~ I ~ A 
303 

6 
323 ~ = 3 STS £ 1115 211 i 6 o 0 11 

83 G3 AS B3 C3 03 E3 F3 

IND ~~ ~ ~:: ~ A. 
304 

6 ~: ~ :: CCH 106 i {) o 1 o 0 4 
84 104 M 94 C4 04 E4 F4 

NEL ~: MW ~ ¥ 
246 266 

A 
305 

0 
325 • ~~ 6 = 5 1E16 1.1 181 1G7 213 o 1 o 1 

85 G6 AS B6 CO OS E5 F5 

SSA ~: SPA ~~ 
246 

f 
266 

Ie 
306 

0 
326 ...... 

6 
....., 

6 1fl6 182 1G8 214 • 230 2~ o 1 1 0 
86 ge A6 B6 C6 OS E5 F6 

ESA ~~ EPA ~~ § ~~ ~ 9 
-~~ CE 

327 347 :; 7 216 Ii 231 G o 1 11 
87 G7 A7 B7 C7 07 E7 F7 

HTS 
210 230 250 270 

E 
310 

" 
330 • ~~~ ~ 8 136 162 • Hi8 184 200 216 • 1 0 0 0 

88 88 AS B8 C8 DB E8 F8 

HTS 
211 231 251 , 271 

E 
311 

0 
331 

~~ ~ ; 137 163 C 1E111 186 201 217 , U 1 0 0 1 
8G gg AG Ell cg [)Q EG FG 

VTS ~~ ~ • ~~ I fe~ E ~~~ U ~ i ~~ " ~~ 1 0 1 0 10 
8A GA AA SA CA OA EA FA 

PLD ~~ ~~ ~~ ~~. E 
~13 

0 
-333 

~~ ~~ CSI .. . 203 21G i " 1 0 1 1 11 
88 88 AB B8 CB DB EB FB 

PLU 
214 

ST 
234 204 274 

I 
314 

0 
334 

I ~: ~; 12 1..a 156 172 YO 188 204 220 Q 1 1 0 0 
8C gc AC e:: cc DC EC FC 

RI 
215 

esc ~~ ~ 275 
r 

315 
V' 

335 
I ~;~ ~~ 13 141 ~ 18G 205 221 9 1 1 0 1 

80 GO AD eo CD DO ED FD 

SS2 ~: PM 
236 ~;: ~~~ i 

316 33t> 
i ;: ~: 14 158 206 222 1 1 1 0 

8E GE AE BE CE DE EE FE 

SS3 
217 ~~ ~~ ~~ T 

317 337 ~~~ ~ 15 143 APC L 207 B 223 T 11 11 
8F GF AF SF CF OF EF FF 

I-- C1 Code. ---1.*1 ... 4 --------(DEC~= GDphio) ·1 
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UPSS ISO Latin-l 
You can override the UPSS DEC Supplemental default by clickin~ 
on the UPSS ISO Latin-l option, which causes the International 
Standards Organization (ISO) Character Set to be in effect. 

8 & 10 11 12 13 14 15 Column 

1 1 1 1 1 1 1 1 be BIts 
0 0 0 0 1 1 1 1 b7 

0 0 1 1 0 0 1 1 b6 
0 1 0 1 0 1 0 1 b6 

b4 b3 b2 b1 Row 

~~ DCS ~ NBSP ~:; . ~ A ~~~ I) ~~ • ~~ II :;; o 0 o 0 0 
80 110 AO eo co DO EO FO 
201 221 241 261 

A 
301 

N 
321 341 361 

1~ PU1 145 I 181 t 177 193 209 , 226 Ii 241 o 0 o 1 1 
81 91 AI 81 Cl 01 E1 Fl 
202 222 242 262 

A 
302 

0 
322 342 362 

130 PU2 146 e 162 2 178 104 210 , 226 0 242 o 0 1 0 2 
82 02 A2 B2 C2 02 E2 F2 
203 223 243 263 

A ~~ 6 
323 343 363 

131 srs 147 £ 163 
, 

170 211 i 227 6 243 o 0 11 3 
83 03 A3 B3 C3 03 E3 F3 
210 224 244 264 

A 
304 

6 
324 344 364 

INO 132 CCH 148 a 164 180 106 212 i 228 6 244 o 1 o 0 4 
84 04 A4 B4 C4 04 E4 F4 

NEL ~~ MW f!: \' 
2046 ~ A ~~ () ~~ • ~ 0 = o 1 o 1 5 166 II 

86 05 AS B6 C6 05 E5 Fe 
206 226 

I 
246 266 306 

0 
326 346 366 

SSA 134 SPA 150 166 , 182 IE. 108 214 • 230 6 246 o 1 1 0 6 
86 06 

I 
A6 B!i C6 06 E6 Fe 

207 227 247 267 307 327 347 367 
ESA 135 EPA 161 § 167 183 ~ 190 x 216 ~ 231 + 247 o 1 11 7 

87 07 A7 B7 C7 07 E7 F7 
210 230 

" 
260 270 

E 
310 330 350 370 

HTS 136 162 166 , 184 200 " 216 • 232 • 248 1 0 0 0 8 
88 08 A8 B8 C8 08 E8 F8 
211 231 251 271 

E 
311 

I) 
331 351 371 

HTS 137 163 C 160 1 186 201 217 , 233 " 240 1 0 0 1 & 
80 00 AQ BIoi OIl DO Ell FO 

VTS ~~ f~ • ~~ I ~~~ E ~~ U r,~ i ~~ (J ~~ 1 0 1 0 10 
SA 9A AA SA CA OA EA FA 
213 233 263 273 

~ 
313 

U 
333 363 373 

OLP 139 CSI 155 .. 171 . 187 203 210 i 235 0 251 1 0 1 1 11 
88 08 AB BB CB DB EB FB 
214 234 254 274 

1 
314 

0 
334 354 374 

PLU 140 ST 166 ... 172 % 188 204 220 I 236 0 252 1 1 0 0 12 
8C gc AC e::: cc DC EC FC 

RI 
216 

CSC ~~ ~~ ¥l ~~: f 
31t> 

Y ~~ r ~~; '9 ~ 1 1 0 1 13 141 . 206 
80 00 AD SO CD DO ED FO 
216 236 256 276 

i 
316 336 356 376 

SS2 142 PM 168 ~ 174 ~ 100 206 j) 222 i 238 j) 254 11 1 0 14 
8E OE AE BE CE DE EE FE 
217 237 257 277 

T 
317 337 367 377 

SS3 143 APC 159 - 176 l. 191 207 B 223 T 239 9 255 11 11 15 
8F OF AF BF CF OF EF FF 

I-- C1 Co,* --... ~,.4------- ISO Lalln-l ;!.eo:~aI Graphic 

Zl<-0320A-GE 



Note To use these character sets, the Character Set mode menu item 
must be set to 8-bit characters. 

8-Bit Multinational Character 
Unless you specify otherwise, the character mode is set to 8 bits 
for use with the DEC Supplemental Character Set. 

7-Bit NRCS Characters 
To use the National Replacement Character Sets, click on the 
7-Bit Character Mode option. The preset option is the 8-Bit 
Multinational Character set. 

VT300 Mode, 8-Bit Controls 
Unless you specify otherwise, the terminal emulator option is 
VT300 Terminal Mode, 8-Bit Controls, which causes DECterm to 
emulate a VT300 with 8-bit control characters. 

Note For each new DECterm window, you can choose to emulate the 
same terminal or different terminals. 

VT300 Terminal Mode, 7-Bit Controls 
You can override the VT300 Terminal Mode, 8-Bit Controls default 
option by clicking on the VT300 Terminal Mode, 7-Bit Controls 
option, which causes DECterm to emulate a VT300 with 7 -bit 
control characters. 

VT100 Mode 
You can override the VT300 Terminal Mode, 8-Bit Controls default 
option by clicking on the VT100 Mode option, which causes 
DECterm to emulate a VT100 terminal. 

VT52 Mode 
You can override the VT300 Terminal Mode, 8-Bit Controls default 
option by clicking on the VT52 Terminal Mode option, which 
causes DECterm to emulate a VT52 terminal. 

Customizing a Keyboard 
You can set keyboard features, such as turning the warning 
bell on or off, by choosing the Keyboard... menu item from the 
Customize menu. DECterm displays a dialog box. 
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Keyboard Set-up [!;] 

D wat"ning bell 
D fnat"gin bell 
Ij] auto tOe peat 
Ij] Ctt"I-Q, Ctt"I-S = Ho Id 

I:j\ <X] delete 
() <X] backs pace 

1:1) caps lock 

C) shift lock 

l:i:1 comma key sends" 
() co m ma key se nds ,< 

l:i:1 ti Ide key se nds '_. 

() ti Ide key se nds ES C 

(i:1 angle bt'ackets key se nds <> 
() angle bt'ackets key sends '.~. 

OK II I Apply I I Cancel I 

From the Keyboard dialog box, you can set the following keyboard 
features: 

Warning Be// 
Unless you specify otherwise, the keyboard warning bell is set to 
ring when errors occur. You can disable this function by turning 
off the Warning Bell option. 

Margin Bell 
By default, the margin bell does not ring when the cursor reaches 
the right margin. You can cause it to ring by clicking on Margin 
Bell. 

Keyclick 
Unless you specify otherwise, the keyboard keys click when you 
press them. You can disable this function by turning off the 
Keyclick option. 

Auto Repeat 
By default, characters repeat when you hold the key down. You 
can disable this function by turning off the Auto Repeat option. 



Note If you set the Lock User Feature option, the host system cannot 
change this setting. 

Ctrl-Q, Ctrl-S = Hold 
Unless you specify otherwise, pressing CtrllS causes your screen 
display to stop scrolling, and pressing CtrllQ causes it to resume 
scrolling. 

Compose Character Key 
Normally, the Compose Character Key option is set, enabling 
you to display characters that are not standard keys on your 
keyboard by using compose sequences. See the section Composing 
Characters for detailed information on composing characters. 

Q] Delete 
By default, the <R1 Delete option is set, which causes the <R1 key 
to function as a Delete key. 

Q] Backspace 
You can override the <R1 Delete default by clicking on the 
Q] Backspace option, which causes the <R1 key to function as a 
non-destructive Backspace key. 

Caps Lock 
Unless you specify otherwise, the Caps Lock option is in effect, 
which means that the Lock key causes alphabetic keys to display 
uppercase characters, and other keys to display the bottom 
character on their keycaps. 

Shift Lock 
You can override the Caps Lock default by clicking on the Shift 
Lock option, which causes the Lock key to make all keys display 
the top character on their keycaps. 

Comma Key Sends 11 

By default the Comma Key Sends " option is set, which causes 
a comma to be displayed when you press the comma key. (This 
applies to a North American or Dutch keyboard dialect.) 

Comma Key Sends,< 
You can override the Comma Key Sends " default by clicking on 
the Comma Key Sends ,< option, which causes a comma to be 
displayed when you press the comma key shifted, and an < to be 
displayed when you press the comma key unshifted. (This applies 
to a North American or Dutch keyboard dialect.) 
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Tilde Key Sends ,-
Unless you specify otherwise, the Tilde Key Sends '- option is 
set, which causes the -' key to display a left single quote (') when 
unshifted and a tilde (-) when shifted, as the key is labeled. (This 
applies to a North American or Dutch keyboard dialect.) 

Tilde Key Sends ESC 
You can override the Tilde Key Sends -' default by clicking on the 
Tilde Key Sends ESC option, which causes the -' key to function 
as an escape (ESC). (This applies to a North American or Dutch 
keyboard dialect.) 

Angle Brackets Key Sends <> 
Normally, the Angle Bracket Key Sends <> option is set, which 
causes the angle bracket key to display a < when unshifted and 
a > when shifted. (This applies to a North American or Dutch 
keyboard dialect.) 

Angle Brackets Key Sends ,-
You can override the Angle Bracket Key Sends <> default by 
clicking on the Angle Brackets Key Sends '-, which causes the 
<> key to function as an escape (ESC). (This applies to a North 
American or Dutch keyboard dialect.) 



Choosing a National Replacement Character Set 
You can pick a National Replacement Character Set (NRCS) that 
corresponds to the chosen keyboard dialect by choosing the 7 -Bit 
NRCS Selection... menu item on the Customize menu, DECterm 
displays a dialog box. 

Notth A met"ican 6 
,-

Flemish 

Canad iarl (Ft'e neh) 

Et"itish 

Danish 

Finnish OK II 
;-

I A ustt"ian/Get"nlan Apply 

Dutch 

I Italian 
Cancel 

swiss (Ft"eneh) 
'-

Q 

From the 7 -Bit NRCS Selection dialog box, you can select the 
following character sets: 

• Austrian/German (See Figure 6-1.) 

• Dutch (See Figure 6-2.) 

• Italian (See Figure 6-3.) 

• Swiss (French) (See Figure 6-4.) 

• Swiss (German) (See Figure 6-5.) 

• Swedish (See Figure 6-6.) 

• Norwegian (See Figure 6-7.) 

• BelgianIFlemish (See Figure 6-8.) 

• BelgianlFrench (See Figure 6-9.) 
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• Spanish (See Figure 6-10.) 

• Portuguese (See Figure 6-11.) 

The following figures illustrate these character sets. 
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CD 

3 
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Figer Imprimer Mode de Donn) Couper 
eaan eaan fonet. Conn. F6 

F11 F12 
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F13 
(LF) F14 
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Saving and Restoring Customized Features 
Once you modify DECterm settings, you can save your changes. 
When you save your changes, DECterm uses these settings each 
time you create a DECterm window. If you change your mind 
and want to use the settings that came with your system, you can 
restore the original defaults. 

To save customized settings: 

• Choose the Save Current Settings menu item from the 
Customize menu for routine saving of customized features. 

• Choose the Save Current Settings As... menu item from 
the Customize menu when you want to save the current 
customized features with a new or different file name. 
DECterm displays a dialog box. 

Save Curre nt Setti ngs as Ii] 
Fi Ie fi Itet' 

I/usr/users/jeanne/*,DEct:erm 

Se lect rlame fot' co nfig ut'atio n fi le:/ust'!uset's/jean nel 

!ust'/uset's!jearl ne/defau It.D ECtenn 

~:I 
Filtet· 

Ok 

I Cancel 

Q 

<)q I 1(> D 

Selection 

I/usr!users/jean ne.t1defau It.D ECtet' 

I : 
II : 
I ! 

I 

The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box lists 
the names of any files in the current directory that contain 
customized features. By default, these files have the type 
DECTERM. 

To use a file name that is not listed, type the name of that file 
in the Selection text field and click on the OK button. 



To restore customized settings: 

• Choose the Use Last Saved Settings menu item from the 
Customize menu to restore an existing file. 

• Choose the Use System Defaults menu item from the 
Customize menu to restore the system defaults. 

• Choose the Use Saved Settings From ... menu item from 
the Customize menu to restore previously saved settings. 
DECterm displays a dialog box. 

Use Saved Setti ngs fro m Ii] 
Fi Ie fi Itet' 

I /ust'/users/jean fle/*.D EC~:enn 

Se lect co nfig ut"atio n fi le:!ust"/uset's/jean ne/ 

/ust'/uset"s/jean ne/defau It.D ECtenll 6- Filtet" I 

~ Ok II 
Cancel I 

0 
<:) q I 1(> 0 

Selection 

I /usr/users/jean ne/defau It,D ECter 

The dialog box prompts you for the name of the file you want 
to use to save your customized features. The file list box lists 
the names of any files in the current directory that contain 
customized features. By default, these files have the type 
DECTERM. Double click on the file name of the file you want 
to use. 
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Copying Information 
You can copy text using the Edit Menu. 

To copy text: 

Select the text you want to copy by pressing and holding MB1, 
dragging the pointer over the text, and releasing MB1. 

The selected area is highlighted. 

2 Choose the Copy menu item from the Edit menu to store the 
copied text. 

3 Click on the area you want to place the text. 

4 Choose the Paste menu item from the Edit menu. 

The selected text is copied to the new location. 

Altering DECterm Windows 
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You can change the size of and clear information from a DECterm 
window by using the Commands menu. 

Commands 

C lear lin e s 0 ff to p 

Clear dis play 

Resize window 

Clear comm 

Reset terminal 

Quit 



Clear Lines Off Top 
You can erase information stored in the transcript by choosing 
the Clear Lines Off Top menu item. The transcript is a memory 
buffer that contains the last 100 lines of your screen display. If 
you turned on the Record Lines Off Top option from the Customize 
menu, you can read the transcript (that is, the lines that scrolled 
off the top of your screen) by using the scroll bars. 

Clear Display 
You can clear all information displayed in a window by choosing 
the Clear Display menu item. 

Resize Window 
You can change the size of a DECterm window by choosing the 
Resize Window menu item. 

ClearComm 
You can clear the communication buffers by choosing the Clear 
Comm menu item. 

Reset Terminal 
You can reset DECterm by choosing the Reset Terminal menu 
item. Resetting DECterm restores the currently saved defaults. 

Exiting from DECterm 
To exit from DECterm and close the DECterm window, choose the 
Quit menu item or type logout. 

Composing Characters 
You can create characters that do not exist as standard keys 
on your keyboard by using compose sequences. A compose 
sequence is a series of keystrokes that creates characters. You can 
create any character from the character set DECterm is currently 
using. (To choose a character set, see the section Customizing 
DECterm.) 

Depending on your keyboard, you compose characters in either of 
the following ways: 

• You use three-stroke sequences for a VT320 keyboard. 

• You use two-stroke sequences on all keyboards except 
the North AmericanlUnited Kingdom, the Dutch, and the 
N orwegian/Danish keyboards, which all use three-stroke 
sequences. 
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To compose a character: 

Find the character you want to create in column 1 of 
Table 6-1, Table 6-2, or Table 6-3. 

2 To compose a three-stroke sequence, press the Compose key 
and space bar, and then type the two characters in column 2. 
To compose a two-stroke sequence, type the two characters in 
column 3. The desired character is displayed. 

To cancel a compose sequence, press the Compose key and space 
bar, <Rl key, Tab key, Return key, or Enter key. 

Note The North American / United Kingdom and Dutch keyboards do 
not have diacritical marks. If you use a diacritical mark, DECterm 
will use an equivalent character. 
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Table 6-1 Composing Characters in Multinational Characters 
Mode 

Character 

# 

@ 

[ 

\ 

] 

I\. 

I 

} 

quotation mark 

number sign 

apostrophe 

commercial at 

opening bracket 

backslash 

closing bracket 

circumflex accent 

grave accent 

opening brace 

vertical line 

closing brace 

tilde 

inverted! 

cent sign 

Three-stroke 
Sequence 

.. space bar 

++ 

' space bar 

AA 
( ( 

I lor / < 

) ) 

I\. space bar 

' space bar 

( -

II\. 

) -

.... space bar 

!! 

C lor C I 

Two-stroke 
Sequence 

.. space bar 

, space bar 

I\. space bar 

, space bar 

.... space bar 

(continued on next page) 



Table 6-1 (Cont.) Composing Characters in Multinational 
Characters Mode 

Three-stroke Two-stroke 
Character Sequence Sequence 

£ pound sign L- or L= 

¥ yen sign Y- or Y= 

§ section sign SO or S! or SO 
c currency sign XO orXO 

© copyright sign CO or CO 
!! feminine ordinal A_ 

« open angle brackets « 
degree sign 0" 

plus or minus sign +-

superscript 2 2" 

superscript 3 3" 

micro sign IV 

'll paragraph sign P! 

middle dot " 
superscript 1 1 " 
masculine ordinal 0_ 

» closed angle » 
brackets 

fraction one- 14 
quarter 

fraction one-half 1 2 

l inverted? ?? 

A A grave A' 'A 

A A acute A' 'A 

A A circumflex A" "A 

A A tilde A- -A 

A A umlaut A" orOOA °A 

A A ring A* orA A 

(degree sign) 

(continued on next page) 
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Table 6-1 (Cont.) Composing Characters in Multinational 
Characters Mode 

Three-stroke Two-stroke 
Character Sequence Sequence 

.IE A E diphthong AE 

Q C cedilla C, 

E E grave E' 'E 

E E acute E' 'E 

E E circumflex EA AE 

E E umlaut E" or"E ··E 

t I grave r 'I 

f I acute I' 'I 

i I circumflex IA AI 

i I umlaut I" or·1 ··1 

N N tilde N- -N 

0 o grave 0' '0 

6 o acute 0' '0 

6 o circumflex OA AO 

() o tilde 0- -0 

6 o umlaut 0" or"O ··0 

<E o E diphthong OE 

0 o slash 0/ 

U U grave U' 'U 

U U acute U' 'U 

U U circumflex UA AU 

U U umlaut U" or"U ··U 

y Y umlaut y" or·Y .y 

.B German small ss 
sharp s 

a a grave a' , 
a 

a a acute a' 'a 

a a circumflex aA Aa 

a a tilde a- -a 

(continued on next page) 
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Table 6-1 (Cont.) Composing Characters in Multinational 
Characters Mode 

Three-stroke Two-stroke 
Character Sequence Sequence 

a a umlaut a" or··a .. a 

Ii a ring a* or aO °a 

(degree sign) 

re a e diphthong ae 

s: c cedilla c, (comma) 

e e grave e 
, 

e 

e e acute e' 'e 

e e circumflex eA Ae 

e e umlaut eft or ··e .. e 

i grave i' 'i 

i i acute i' , i 

f i circumflex iA A· 1 

i i umlaut itt or ··i ··i 

ft n tilde n- -n 

0 o grave 0 
, , 

0 

6 o acute 0' , 0 

() o circumflex OA AO 

0 o tilde 0- -0 

0 o umlaut 0" or ··0 
.. 

0 

re o e diphthong oe 

~ o slash 0/ 

U u grave u' , 
u 

U u acute u' 'u 

t1 u circumflex uA AU 

ii u umlaut u" or··u .. u 

y y umlaut y" or··y .. y 

(con tin ued on next pa1e) 
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Table 6-1 (Cont.) Composing Characters in Multinational 
Characters Mode 

Character 

ISO Characters 

no break space 

broken vertical bar 

-, logical not 

SHY soft (syllable) 
hyphen 

RO registered 
trademark 

macron 

Three-stroke 
Sequence 

sp sp 

I I or! 1\ 

* 

RO 

1\ 

3/4 three-quarters 3 4 * 
-. division sign 

xx multiplication sign x x 

acute accent 

cedilla 

diereses 

Y' Yacute 

y' yacute 

TH capital Icelandic 
thorn 

, , 

" " 
y, 

y' 

TH 

th small Icelandic t h 
thorn 

-D capital Icelandic - D 
Eth 

-d small Icelandic Eth - d 

Two-stroke 
Sequence 

.. space bar 
,y 

'y 



Table 6-2 Composing Characters in National Replacement 
Mode Using Typewriter Keys 

Character 

British 

£ pound sign 

grave accent 

Danish 

# 

@ 

number sign 

apostrophe 

commercial at 

grave accent 

Dutch 

£ pound sign 

apostrophe 

one-quarter 

one-half 

3/4 three-quarters 

ij i j sign 

fl Florin 

grave accent 

acute accent 

diereses 

Finnish 

# number sign 

Three-stroke 
Sequence 

L- or L= 

, space bar 

++ 

, space bar 

AA 

, space bar 

L- or L= 

' space bar 

14 

1 2 

34 

ij 

f-

' space bar 

' , 
" A 

++ 

Two-stroke 
Sequence 

(continued on next page) 
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Table 6-2 (Cont.) 

Character 

apostrophe 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-stroke 
Sequence 

, space bar 

Two-stroke 
Sequence 

Flemish and FrenchlBelgian 

£ pound sign 

apostrophe 

grave accent 

French Canadian 

apostrophe 

a a grave 

a a circumflex 

e e grave 

e e circumflex 

i i circumflex 

0 o circumflex 

U u grave 

11 u circumflex 

German/Austrian 

apostrophe 

grave accent 

Italian 

apostrophe 

L- or L= 
, space bar 

, space bar 

, space bar 
, 
a 
Aa 

'e 

Ae 

Ai 

AO 
, 
U 

AU 

, space bar 

, space bar 

, space bar 

, 
a 
Aa 

'e 

Ae 
A· 1 

AO 
, 
U 

AU 

(continued on next page) 



Table 6-2 (Cont.) Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-stroke Two-stroke 
Character Sequence Sequence 

Norwegian 

apostrophe ' space bar 

grave accent ' space bar 

Portuguese 

apostrophe ' space bar 

grave accent ' space bar 

A A tilde -A 

<5 o tilde -0 

a a tilde -a 

0 o tilde -0 

Spanish 

£ pound sign L- or L= 

apostrophe ' space bar 

§ section sign !S or OS or OS 

grave accent ' space bar 

tilde - space bar 

Swedish 

# number sign ++ 
apostrophe ' space bar 

E E acute ' E 

e e acute ' e 

(continued on next page) 
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Table 6-2 (Cont.) 

Character 

Composing Characters in National 
Replacement Mode Using Typewriter Keys 

Three-stroke 
Sequence 

Two-stroke 
Sequence 

Swiss (French) and Swiss (German) 

apostrophe ' space bar 

e e circumflex Ae Ae 

1 i circumflex A' 1 A' 1 

0 o circumflex AO AO 

U u grave u u 

U u circumflex AU AU 

Table 6-3 Composing Characters in National Replacement 
Mode Using Data Processing Keys 

Character 

quotation mark 

# number sign 

apostrophe 
@ commercial at 

[ opening bracket 

\ backslash 

] closing bracket 

apostrophe 

opening brace 

I vertical bar 

} closing brace 

tilde character 

Three-stroke 
Sequence 

" space bar 

++ 

' space bar 

aa or AA or aA 

( ( 

1< 

A space bar 

' space bar 

( -
AI 

) -
- space bar 



.tarting Mail 

7 
Using Mail 

Mail allows you to exchange messages with other computer users. 
You can use Mail to send messages, read messages sent to you, 
and print, file, delete, reply to, and forward messages. 

This chapter describes how to 

• Send messages 

• Read messages 

• Reply to messages 

• Forward messages 

• Print messages 

• Create files from messages 

• Working with folders 

• Customize your Mail environment 

• Exit from Mail 

To start Mail, choose the Mail menu item from UE's Applications 
Menu. Mail displays the main window. 
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The main window lists your Mail folders and messages. Folders 
help you organize your mail messages. You use Mail folders as 
you would use folders in your office file cabinet. You might file all 
messages on a related topic in one folder. You can create as man) 
folders as you need. 

Folders can be opened to reveal their contents, and closed to 
conceal their contents. To open a folder, double click MBl on the 
folder name. To close a folder, double click MBl on name of an 
open folder. 



When you enter Mail for the first time, three folders, inbox, drafts, 
and wastebasket, are listed in the Folder index. The inbox folder 
contains messages that have been sent to you. The drafts folder 
contains drafts of messages you create and the wastebasket folder 
contains messages that you have deleted. 

The inbox is also automatically opened when you enter Mail. 
If there are any messages in the inbox, they are listed in the 
Message index. Messages are chronologically arranged by date 
received. To display messages in a different folder, open that 
folder. 

Near the bottom of the window is a row of push buttons. These 
buttons allow you to execute the tasks you most commonly 
perform with messages. Many of the push buttons are disabled 
when you first start Mail and remain so until you select a specific 
message. 

Pressing MB2 over an object in a Mail window displays a pop-up 
menu. Pop-up menus contain many commonly performed tasks. 
The items on a pop-up menu vary according to the type of object 
(folder or message) on which you are positioned, and act on the 
object on which you are positioned. 

Pop-up menu items and push buttons duplicate pull-down menu 
items. Where you can choose among a push button, pop-up menu, 
or pull-down menu to execute a task, instructions in this chapter 
list one way to accomplish the task. Depending on your working 
style, you may prefer to use one of the other methods once you are 
familiar with Mail. 

;ending Messages 
You can create and send a mail message or an existing file to one 
user or many users with Mail. 

Sending a Message 
To send a mail message to any user on your system or another 
system, click on the Create-Send button in the main window. A 
Create-Send window opens. You can have multiple Create-Send 
windows opened at one time. 
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call 1\'1ail: Ct·eate 

File Edit 

fu~ 6 
cc: .-
Sub,ject: 

-
19 -I aose II Reset II Save II Smld I 

The Create-Send window is divided into an envelope area and a 
message area. The envelope area contains the following items: 

Field 

To: 

cc: 

Subject: 

Description 

In this field you specify the person or persons to whom 
you want to send the message. You may enter a user 
name, with optional node name. Separate names with 
commas. 

In this field you specify users to receive copies of the 
message, if desired. 

The subject of the message (optional). 

To enter text in a field, point to the field and click MBI. Enter 
your message text in the message area. Use the built-in editing 
commands, described in the DECwindows User~s Guide, to correc1 
mistakes. 



To send the message, click on the Send button. Once the message 
is sent the Send button is dimmed until you begin composing 
another message. 

To close the window, click on the Quit button. This deletes all text 
in the window and closes the window. 

To clear the window without closing it, click on the Reset button. 
The text in the Create-Send window is erased and the window can 
be used to send another message. 

Saving a Draft of a Message 
Selecting Save allows you to save a draft of the message in the 
drafts folder. The message can still be sent or canceled after it 
has been saved. 

Resuming Work on a Draft Message 
You can continue working on a draft of a message that you 
previously saved. (See the section Sending a Message for 
information on saving a message.) 

To resume work on a draft message: 

Select a message from the main window. 

2 Choose the Use as comp menu item from the main window's 
File menu. 

When you choose the Use as comp menu item, Mail displays a 
Create-Send window that contains the contents of the selected 
message. 

Including a File in a Message 
You can insert an existing file into a mail message. 

To include a file in a message: 

Choose the Include File... menu item from the Create-Send 
window's File menu. Mail displays a dialog box. 
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[EEl Choose file to insert lPJJ 
File filter 

11* 

Files in lusrlstaff/rO/jeannel 

~/94fJNL 61 Filter I 
~/DW _STATUS.TXT;2 

II II Ok 
~/Mall 

~/addresses 1 Cancel I 
~/bin 

~/caLprint.scr 

~/cale ndat·_mail 

~/cot·e Q 

<:11 I PC> 0 

Selection 

I 

The dialog box prompts you for the name of the file you want 
to include. The file list box lists the names of all files in the 
current directory. 

2 Double click on the name of the file you want to include. 

The contents of the file are displayed in the Create-Send 
window. You can edit the file if desired. 
You can also use the File Filter text entry field to list a subse1 
of files that you can then select from. For exam pIe, to list all 
files in another directory with the file type TXT, type the full 
directory path -/jones/messages/*.txt- in the File filter text 
entry field and click on the Filter button. Then double click 01 

the file name of the file you want to include. 

3 Click on the Send button to send the message. 



Selecting Messages 
Message commands act on messages displayed in the Message 
Index pane. To indicate that a message or set of messages are to 
be acted on, you first need to select them. 

To select a single message, click the left mouse button on either 
the message or the envelope icon beside the message. 

To select a range of messages from the Message Index pane, 
you can follow one of two procedures. The first procedure is to 
press MBI on the first message to be selected, drag the mouse 
to the last message to be selected, and release MBI. The second 
procedure is to select the first message, then place the mouse 
pointer on the last message to be selected, and press the SHIFT 
key and left mouse button. 

To add a message to the current selection, first place the mouse 
pointer on the envelope icon of the message to be included in the 
selection, press and hold the SHIFT key, and click the left mouse 
button. 

To select all messages in the open folder, choose the Select all 
menu item from the Edit menu in the main window. 

To cancel the selection of one object, select another object by 
clicking MBl, or position to the selected object and press and hold 
the Shift key and click MBI. 

Reading Messages 
You can use Mail to read an old or new mail message. New 
messages are added to the inbox folder; old messages (messages 
that have been read) are held in the inbox folder until you move 
them elsewhere. 

Reading a New Message 
To read a new message, click on the Read New Mail button. This 
adds new messages to the inbox folder, opens the inbox folder, and 
displays the first message received since the inbox folder was last 
opened. The message is displayed in a Read window. 
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File Edit Sequences Create-Send Read 
{) -

-
9 

II Oose II Reply II Forward II Print II Move II Oelete II Pn:~\'·inw·. 1J nnxt 1 

The message pane displays the mail message. Use the scroll bar 
to display any text that does not fit in this pane. 

The small black square on the pane dividing line is called a pane 
adjustment knob. Using this knob you can adjust the relative 
size of the panes. Making one pane smaller makes the other pane 
larger. This allows you to view more text in either pane without 
resizing the window. To use the pane adjustment knob, move to 
the knob, press MBl, drag the pane dividing line to the desired 
location, and release MBI. 

If you receive a message whose contents are not text (such as 
a file containing spreadsheet data) the file cannot be viewed in 
Mail. Mail displays a message informing you of the problem. 
You can print, forward, extract, or reply to the message. See the 
appropriate sections of this chapter for information on printing, 
forwarding, extracting, and replying to messages. 

To continue to read new messages, click on the Next or Previous 
button to read the next or previous message in the folder. 



If you receive new mail while reading messages in the inbox, 
choose the Read New Mail menu item on the pop-up menu in the 
Read window's message pane. This displays the first message 
received since the inbox folder was last opened. 

To close a Read window, click on the Close button. 

Displaying a List of New Messages 
You can add new messages to your inbox folder and update the 
list of new messages without reading a message. To update the 
inbox, click on the Deliver Mail button in the main window. Mail 
cannot be delivered if the inbox is open in a Read window or if you 
are replying to a message in the inbox. 

Reading an Old Message 
To read an old message (one that has already been read), point 
to the envelope symbol beside the appropriate message in the 
Message Index pane and double click MBI. 

To read a series of old messages: 

Select the messages to be read by holding down the Shift key 
and clicking on the desired messages. 

2 Move to one of the selected messages, press MB2, and choose 
the Read in Default menu item from the pop-up menu. 

3 In the Read window, choose the Next Selected or Previous 
Selected menu item from the Read menu to display the next 
or previous selected message. 

Multiple Read Windows 
You can open more than one Read window at one time. This 
allows you to read multiple messages at once, or to read new mail 
without disrupting the message you are currently reading. 

The first Read window you display is your default Read window, 
identified by the number 1 in the window's title bar. Additional 
Read windows are identified by the number in their title bar, for 
example, Read-2, Read-3, and so on. 

The default Read window is used to display messages unless you 
specify another window. For example, clicking on the Read New 
Mail button or double clicking on a message envelope icon in 
the main window will display the message in your default Read 
window. 
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To read new mail in another Read window, choose the New Mail 
In New menu item from the main window's Read menu. A new 
Read window is opened and the first message received since inbox 
was last opened is displayed. 

To read an old message in another Read window, select the 
message and choose the In New menu item from the main 
window's Read menu. 

If you have already opened multiple Read windows, you can 
specify the window in which to read the selected message by 
pulling down the main window's Read menu, dragging the pointer 
to the submenu icon next to the In Window menu item, and 
releasing MBl over one of the listed Read windows. 

To use a different window as the default Read window, choose the 
Make Default Window menu item from the Read window's File 
menu. The number 1 will be displayed in the window's title bar~ 
and will be removed from the previous default window's title bar. 

Replying to Messages 
You can reply to a selected message or to the message currently 
displayed in a Read window. 

To reply to the first selected or currently displayed message, click 
on the Reply button in the main or Read window. 

Replying to a message opens a Create-Send window. In the To: 
field, Mail inserts the name of the sender of the original message. 
In the Subject: field, Mail inserts the subject of the original 
message preceded by RE:. 

Enter text and make any desired edits. 

To send the reply, click on the Send button. To close the Create­
Send window, click on the Close button. 

Forwarding Messages 
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You can forward the selected message or the message currently 
displayed in a Read window to another user. 

To forward the selected or currently displayed message, click on 
the Forward button in the main or Read window. 

The header (the address information) is included in the forwarded 
message in most cases. Headers are not included in messages 
created with editors which do not produce ASCII files, such as 
files created with DECwindows Paint. 



Forwarding a message opens a Create-Send window. In the 
Subject: field, Mail inserts the subject of the forwarded message 
preceded by FWD:. In the message area, Mail inserts the 
forwarded message. 

Enter the address information, and make any desired changes to 
the text. 

Click on the Send button to send the message. Click on the Close 
button to close the window. 

Printing Messages 
You can print selected messages or the message currently 
displayed in a Read window. Messages can be printed using your 
default print settings or you can modify the print settings for the 
messages being printed. 

To print the selected or currently displayed message using 
your default print settings, click on the Print button in the 
main or Read window. See the ULTRIX Worksystem Software 
reference page on the dxmail(lX) command for information about 
customizing the print command. 

To print the selected or currently displayed message using altered 
print settings: 

Choose the Print... menu item on the File menu in the main 
or Read window. 

The Include Message Contents button is set to indicate that 
the contents of the message are to be printed. You can disable 
this feature by clicking on it, which also disables the Include 
Header Information feature. 

The Include Header Information button is set to indicate that 
the header information (the sender's name, date, subject, 
and so on) are to be printed. You can disable this feature by 
clicking on it. 

2 To change additional print settings, click on the Options ... 
button. 

See the DECwindows User's Guide for more information about 
the Print Defaults dialog box. 

3 Click on the OK button to print the messages. 
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Creating a File from a Mail Message 
You can create files from mail messages. You can select existing 
messages to be copied to a file, or you can create a file from a 
message you are reading or creating. 

To create a file from the selected or currently displayed message: 

Choose the Extract... menu item from the File menu in the 
main, Create-Send, or Read window. 

2 Enter the name of the file to be created. If you want to append 
the message to an existing file, enter the name of that file. 

3 Click on the OK button to create the file. 

Deleting and Retrieving Messages 
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You can delete mail messages, and retrieve deleted messages. 

To delete selected messages or the message currently displayed in 
the Read window, click on the Delete button in the main or Read 
window. 

The index is updated to show which messages have been marked 
for deletion. Messages are not actually deleted until the folder is 
closed. You can still perform many Mail functions on messages 
which are marked for deletion, such as moving, copying, and 
printing. When the folder is closed, the messages are deleted and 
reference to them is removed. 

Once the wastebasket is emptied, the deleted messages are 
irretrievable. 

To reverse the delete operation in the main window, before the 
folder is closed select the messages to be retrieved, pull down the 
Edit menu, and choose the Undo MovelDelete menu item. 

To undo the delete operation in a Read window, choose Undo 
MovelDelete menu item from the Edit menu. 

To update the index of messages to reflect that the messages 
have been moved to the WASTEBASKET folder, either select 
the Cornmit Changes menu item from the Maintenance menu in 
the main window or reopen the folder that contains the deleted 
message. 

If the m~ssage has already been moved to the WASTEBASKET, 
you can retrieve the lnessage by moving it to another folder. See 
the section Moving and Copying Messages to Another Folder for 
more information about moving messages between folders. 



Working with Folders 
You can create and delete folders, move and copy messages 
between folders, an'i renumber and sort messages within folders. 
These options are described in the following sections. 

Creating New Folders 
To create a new folder, choose the Create folder... menu item from 
the Maintenance menu in the main window. 

Mail displays a dialog box in which you enter the name of the 
new folder to be created. Folder names are limited to 
39 characters and can contain letters, numbers, spaces, periods, 
dashes, underscore~, and dollar signs. 

Deleting Folders 
To delete folders, select the folder to be deleted, then choose 
the Delete folder... menu item from the Maintenance menu. If 
the folder is not empty, Mail displays a dialog box in which you 
confirm whether to delete the folder or cancel the delete request. 

If you attempt to delete the inbox folder, all messages in the inbox 
are deleted but the folder is not deleted. 

When a folder is deleted, any messages that existed in the folder 
are placed in the wastebasket folder and can be retrieved until the 
wastebasket folder is emptied. 

Moving and Copying Messages to Another Folder 
You may move or copy a message or group of messages from one 
folder to a different folder. Moving messages to another folder 
removes them from the original folder. Copying messages to 
another folder does not remove them from the original folder. 

You can move and copy messages from either the main or Read 
windows. 

To move selected messages or the message currently displayed in 
the Read window: 

1 Select or display the message to be moved or copied. 

2 Select the folder you are moving or copying the message to. 

3 Click on the Move or Copy button in either the main or Read 
window. 
When you click on the Move or Copy button, Mail marks the 
message appropriately. 
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Messages are not actually moved or copied until the folder is 
closed. You can still perform many Mail functions on messages 
which are marked for moving or copying, such as deleting, and 
printing. When the folder is closed, the messages are moved 
or copied. 

To undo the move or copy operation in the main window, select the 
messages to be retrieved and choose the Undo MovelDelete menu 
item from the main window's Edit menu. 

To undo the move operation in a Read window, select the Undo 
MovelDelete menu item from the Read window's Edit menu. You 
cannot undo the copy operation. 

Renumbering and Sorting Messages 
To renumber your messages in the open folder so they start from 
one and increment by one, choose the Renumber Messages menu 
item from the Maintenance menu in the main window. 

To sort the messages in the open folder in increasing order by 
date, choose the Sort by Date menu item from the Maintenance 
menu in the main window. 

To cause Mail to check and make sure its information about the 
folder is correct, choose the Rescan Folder menu item from the 
Maintenance menu in the main window. 

Picking Messages 
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Picking messages allows you to create a subset of the messages 
in a folder based on their having some criteria in common. This 
subset is called a message sequence. You can then perform 
functions, such as copying, moving, extracting, or reading, on the 
subset of picked messages. In addition, you can open and delete 
a specified message sequence by selecting the appropriate menu 
item from the Pick menu. 

To pick messages, first open or select the folder containing the 
messages and choose the Pick from open folder... or Pick from 
selected folder... menu item from the Edit menu in the main 
window. Mail displays a dialog box. 
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The dialog box allows you to specify the criteria for picking 
messages. For example, you could specify that you would like to 
pick those messages containing a certain word in the subject, or 
those from a certain sender. 

You can enter multiple selection criteria to further limit the 
messages to be picked. For example, you could enter text in the 
From: field and the On: field in the dialog box to pick messages 
that the specified user sent to you on the specified day. 

Only those messages in the open or selected folder are searched 
for the specified criteria. 

Once a subset of messages has been picked, the index is updated 
to list only the picked messages. When the folder is closed, the 
picking criteria is lost. All messages will again be listed in the 
index. 
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Text fields, which are the first five fields in the dialog box, search 
for matching text anywhere in the field and are not case sensitive. 
For example, entering the text John in the From: field might pick 
messages from Jane Johnson, John Doe, and Olav Bejohnesson. 

Each field in the pick dialog box is described in Table 7-1. 

Table 7-1 

Field 

From: 

To: 

Cc: 

Date: 

Subject: 

Search: 

Pick Dialog Box Fields 

Function 

To pick all messages in the open folder that 
were sent from a certain user, enter the user 
name of the sender. 

To pick all messages in the open folder that 
were sent to a certain user, enter the user 
name of the addressee or the name of a 
distribution list. 

To pick all messages in the open folder that 
were sent as a courtesy copy to certain users, 
enter the user names of the addressees. 

To pick messages received on a certain date, 
enter the date in the format DD-MMM-YYYY. 

To pick messages with a common subject, 
enter the subject or text included in the 
subject. 

To pick messages containing a word or phrase 
in the body of the messages, enter the word 
or phrase. 

Next, enter the appropriate information in the text fields at the 
bottom of the dialog box. The date range specifies that messages 
received between certain dates and times are picked. Enter the 
date and, if desired, the time in the format DD-MMM-Y¥YY 
HH:MM:SS. 

When you have finished entering the picking criteria, select either 
the OK screen button to pick the designated messages, or the 
Cancel screen button to cancel the pick. 



Opening a New Main Window 
To create a new main window, first select the folder from the 
current Mail window. Next, choose the Open In New menu item 
from the File menu. A new main window is displayed, and the 
current folder is opened. 

You can perform all Mail functions on the folders and messages 
displayed in this window. You can customize certain Mail features 
to suit your working environment by modifying your mail profile. 
Modifying your mail profile allows you to alter the way your 
messages are sent, stored, and displayed. To modify your mail 
profile, choose the Modify mail profile... menu item from the 
Customize menu. 

The Mail Profile dialog box has the following options: 

• Skip to next message upon deleting current one. 

• Skip to next message upon moving current one. 

• Commit changes in a folder upon closing it. 

• Renumber messages in a folder after every commit. 

• Put deleted messages into wastebasket instead of deleting 
immediately. 

• Incorporate new messages when invoking Show Unopened 

• Buttons affect the current message if no messages are 
selected. 

• Beep instead of putting up a NoN ew Mail dialog box. 

An option is on when the corresponding square is shaded. To turn 
an option off, click on the appropriate black square. 

Selecting the OK screen button saves the profile settings. 
Selecting the Cancel screen button returns the original settings to 
the profile, making no changes to the profile as it appeared when 
the dialog box was first displayed. 

For more information about customizing your mail profile and the 
Mail window, see the ULTRIX Worksystem Software reference 
page dxmail(lX). 
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Exiting from Mail 
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To exit from the Mail application, choose the Exit menu item from 
the main window's File menu. The main window and any open 
Read or Create-Send windows are closed. Open folders are closed. 
If Create-Send windows have been modified, for example, if a 
message has been created but not sent, Mail displays a dialog box 
asking if you really want to exit. 

If multiple main windows are open, the File menu contains the 
Close menu item rather than Exit. Choosing Close closes only the 
main window from which Close is chosen. When there is only one 
remaining main window, its File menu contains the Exit menu 
item. 



8 
Using the Notepad Editor 

The Notepad editor is a text program that lets you do everyday 
tasks, such as recording messages, writing letters, and building 
data files. 

The Notepad editor saves your notes in files, which you can store 
for later revision or incorporation into other files. 

This chapter describes how to 

• Start the editor 

• Type and format text 

• Edit a file 

• Name a file 

• Open a second Notepad 

• Open an existing file 

• Merge files 

• Find and replace text 

• Exit from an editing session 

tarting the Notepad Editor 
To start the Notepad editor, choose the Notepad menu item from 
UE's Applications menu. 

Notepad displays an empty editing window, in which you can 
type text from the keyboard or copy in an existing file for editing. 
Notepad is interactive, so you see the changes to a file as you 
make them. 
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Typing Text 
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To enter text in the Notepad window, give the window input focuf 
and begin typing text from the keyboard. Notepad enters the tex1 
at the position marked by the text insertion cursor. Initially, the 
insertion cursor is displayed in the upper left corner, but it movel 
right as you type. 

The Notepad inserts text into a temporary holding area called a 
buffer. The contents of the buffer appear in the Notepad windov 
At the beginning of an editing session, the buffer may contain ver 
little text, but the buffer grows longer as you add information. 
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A buffer exists only during the editing session. When you end an 
editing session, you direct the Notepad editor to save or discard 
the contents of the buffer. 

FormaHing Text 
Use the Tab key, the space bar, and the Return key to arrange 
text in the Notepad window as you want it to appear. 

You can also size the Notepad window so it has the line width you 
want. Notepad wraps text lines at the right margin automatically 
so you do not have to press the Return key at the end of every 
line. 

Scrolling the Buffer 

Editing a File 

As your text buffer grows, it extends beyond the frame of the 
Notepad window. To view text at the beginning or end of the 
buffer, use the vertical scroll bar along the right side of the 
window. The position of the slider indicates your position in the 
buffer. When the slider is at the top of the scroll bar, you are at 
the beginning of the buffer. When the slider is at the bottom of 
the scroll bar, you are at the end of the buffer. 

The Notepad navigation and editing commands let you move 
within a text buffer quickly and easily, adding or modifying 
information. 

Positioning the Cursor 
When you insert text in the buffer, Notepad adds the text at 
the current cursor position, pushing existing text to the right. 
Therefore, the cursor is normally positioned at the spot where you 
last entered text. 

To move the text insertion cursor, position the pointer anywhere 
in the Notepad window or on your workstation screen where there 
is text or spaces and click MBI. 

With a long buffer, reposition the text cursor using menu items 
from the Navigate menu. Choose the Go To Top menu item to 
move to the top of the buffer. Choose the Go To Bottom menu item 
to move to the bottom of the buffer. 
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To reposition to a specific line in the buffer: 

Choose the Go To Line... menu item from the Navigate menu. 
The Notepad displays a line dialog box. 

2 Type the line number. 

3 Press the Return key or click on the Go To Line button. 

Notepad repositions the cursor to the specified line. 

Another method of positioning on a certain line is to select the 
line number in the text buffer and choose the Go To Selected Line 
menu item on the Navigate menu. 

Selecting Text 
In order to delete, move, or copy text in a buffer, you must first 
select it. Select text by pressing and holding MB1, dragging the 
pointer over the text, and releasing MB1. This highlights the 
selected text. Notepad stores this text until you tell it what to do. 

Deleting Text 
Use the Delete key to erase a few characters. To delete a line or 
a section of text, select the text and press the Delete key or begin 
inserting new text. Inserting new text causes the selected text to 
be deleted and the new text to take its place. 

Canceling an Edit 
To cancel your most recent edit, choose the Undo menu item on 
the Edit menu. For example, if you remove text with the Cut 
menu item, you can restore the text to its former location with th4 
Undo menu item. 

Notepad keeps a detailed record of all your edits so you can undo 
a series of edits. To cancel a series of edits: 

Choose the Undo ... menu item from the Edit menu. 

Notepad displays the Undo dialog box. 

2 Click on the Undo screen button to cancel the last editing 
operation. 

Each time you click on the Undo button, the Notepad cancels 
another editing operation. 

3 If you undo an editing operation by mistake, reinstate the 
edits by clicking on the Redo screen button. 

4 To complete the operation, click on the Dismiss screen button 
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You can cancel all the edits of an editing session in one step by 
choosing the Revert menu item from the File menu. The Notepad 
restores the buffer to the state it was in when you first opened the 
file. 

Moving Text 
Because the Notepad saves the last text you selected and deleted, 
you can move text from one location in the text buffer to another 
location. 

To move text in a buffer: 

Select the text you want moved to another location. 

2 Choose the Cut menu item from the Edit menu. 

3 Move the text cursor to where you want the deleted text 
inserted by positioning the pointer and clicking MBI. 

4 Choose the Paste menu item from the Edit menu. 

The deleted text is moved to the new location. 

Copying Text 
Because Notepad keeps track of your selected text, you can copy 
text from one location in a text buffer to another location. To copy 
text in the text buffer: 

1 Select the text you want copied to another location. 

2 Choose the Copy menu item from the Edit menu to store the 
copied text. 

3 Move the text cursor to where you want the selected text 
copied by positioning the pointer and clicking MBI. 

4 Choose the Paste menu item from the Edit menu. 

The selected text is copied to the new location. 

Including an Existing File 
You can include an existing file to the text buffer that you are 
currently editing. 

To include a file 

Move the text cursor to where you want the included file 
placed. 

2 Choose the Include File... menu item from the File menu. 
Notepad displays the Open File dialog box. 
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3 Either select the file from the files listed in the dialog box or 
type the name of the file that you want to include. 

4 Press the Return key or click on the OK button. 

The contents of the included file appear in the editing window at 
the location you specified. 

Saving Text in a File 
When you add text to Notepad, the editor records the information 
in the buffer. Because a text buffer exists only for the editing 
session, if you want to save the contents of the buffer you must 
direct Notepad to write your text to a file. 

To save the text in your buffer as a file: 

Choose the Save As... menu item from the File menu. 
Notepad displays a dialog box that prompts you for the name 
of the file. 
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2 Type the name of the file, assigning a name that corresponds 
to the contents of the file so that you can easily recognize 
it. Use the Delete and arrow keys to make any necessary 
corrections. 

3 Press the Return key or click on the OK button. 

Notepad writes the contents of the buffer to the new file and post~ 
the file name in the title bar of the editing window. 

When you make changes to an existing file, it is also necessary 
to save the changes. Once a file has a name, use the Save menu 
item to update the file. 

8-6 Using the Notepad Editor 



Opening a Second Notepad 
You can open a second Notepad window without closing the first 
window. To create a second notepad window, choose the New 
menu item from the File menu. A second Notepad window opens. 

Figure 8-1 The New Notepad 
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The editing you do in the second Notepad window can be 
completely independent of the first notepad, or you can copy 
and paste text from one notepad window to the other. 

:>pening an Existing File 
When you want to edit an existing file, you direct Notepad to open 
the file and read its contents into the Notepad buffer. 

To open an existing file: 

Choose the Open... menu item from the File menu. 
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Merging Files 

Notepad displays the Open File dialog box. 
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2 Either select the file from the files listed in the dialog box or 
type the file name. 

3 Press the Return key or click on the OK button. 

The contents of the file appear in the editing window and Notepa( 
displays the file name in the title bar. 

Whether you are writing a letter or a computer program, you can 
often save time by combining pieces of information from other 
letters or programs that you have written. 

Copying Text from One Notepad to Another 
To copy text from one notepad to another: 

1 Select the text that you want to copy. 

2 Choose the Copy menu item from the Edit menu. 

3 Position the pointer in the other notepad window at the point 
where you want to insert the copied text. 
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4 Choose the Paste menu item from the Edit menu. 

Notepad inserts the copied text at the desired location, leaving the 
text in the other notepad intact. 

Searching for Text 
You can search a text buffer for any text, such as a word, a 
number, or any other characters that you can type with your 
keyboard. Because Notepad treats spaces as text, you can search 
for two or more words. The Notepad searches the buffer from the 
current cursor position and highlights the first occurrence of the 
text string. 

Choose the Next ... menu item from the Search menu. 
Notepad displays the Find dialog box. 
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2 Type the text string you want to locate. 

3 Click on the Next screen button to initiate a search from the 
current position to the end of the file. 

You can continue to search for the text string by clicking on the 
Next screen button in the Find dialog box. 

By default, the Notepad performs a case sensitive search. Choose 
the Set Search Options... menu item from the Options menu to 
make searches insensitive to case. A highlighted case sensitive 
button indicates that a case sensitive search is in effect. 

Notepad can also search a text buffer for a character pattern. 
You can add characters or delete characters from the search 
string during the search operation, and the Notepad returns to 
the initial search position in the buffer and looks again for the 
modified pattern. Choose the Next Incremental... menu item to 
search for patterns. 
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Replacing Text 
The Notepad editor can replace one text string with another 
text string. This is especially useful if you have spelled a word 
incorrectly throughout a long file and you want to fix every 
occurrence of the misspelled word. 

To replace a text string: 

Choose the Replace AlL. menu item from the Search menu. 

Notepad displays a dialog box. 
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2 Type the old text that you want the Notepad to replace and 
press the Tab key to move the cursor to the next text entry 
field. 

3 Type the new text that you want substituted and press the 
Return key. 

4 Click on the Replace All button to initiate the replacement. 

5 Click on the Dismiss button. 

If you choose individual replacements, the Notepad searches 
the buffer from the current cursor position and highlights the 
first occurrence of the text. Click on the Replace Once button to 
replace the text with the new text. To skip an occurrence, click 
on the Skip button. To replace text in a selected range, select the 
text you want to perform a replace operation on and choose the 
Replace Within Selected Area... menu item from the Search menu. 

Exiting from an Editing Session 
To discard the edits from a session and close the editing window, 
choose the Quit menu item from the File menu. 
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Using Journal Files 
The Notepad editor keeps a record of changes made to a file 
so it can reconstruct any editing session that is interrupted 
because of a system failure. (Failures occur for example, when a 
thunderstorm interrupts the electrical power.) 

The record, called a journal file, usually exists only while an 
editing session is active. However, the file remains if the session 
ends abnormally. 

When you attempt to edit a file that has a journal file associated 
with it, Notepad displays the Recover dialog box, and asks you 
whether you want the previous edits restored. 

If a session is interrupted before you create a file, the Notepad still 
saves your keystrokes in a journal file and assigns the untitled 
buffer a file name. The file name has the format nnnnnnnn.JNL, 
where nnnnnnnn is a process number that uniquely identifies the 
file. 

To recover the session: 

1 Choose the Open... menu item from the File menu. 

2 Look at the list of files in your current directory. Select a file 
in the nnnnnnnn.JNL format, created on the appropriate day. 
The Notepad displays a Recover dialog box, asking you to 
confirm the recovery. 

3 Click on the Yes button. 
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9 
Using Paint 

Paint is a graphics program that lets you create any kind of 
simple picture, such as a sketch, an illustration, or a map. From 
an assortment of art tools, you can choose those that enhance your 
picture, adding any details and accents it requires. 

The Paint program can save your pictures for later use, print them 
on different kinds of printers, or copy them to other applications. 
You can also project these pictures on your terminal screen with 
the DDIF Viewer. 

This chapter describes how to 

• Start Paint 

• Select tools and menu items 

• Erase 

• Draw lines and shapes 

• Introduce patterns into paintings 

• Use the paintbrush 

• Edit paintings 

• Insert text 

• Size and scroll the canvas 

• Print paintings 

• Exit from Paint 
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Starting Paint 
To start Paint, enter the following command in a DECterm 
terminal emulator window: 

% dxpaint & 

The Paint program displays a drawing window that is bordered by 
a tool palette. 

~jj 

fiil 

T 

" ""' D 0 
0 0 
'6 ~ 

ZK-0119A-GE 

The Paint window frames a portion of the canvas. Horizontal and 
vertical scroll bars indicate the percentage of the canvas displayed 
in the Paint window. 

Learning the Basics 
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Paint is a bitmap graphics program, which means that it treats 
pictures as a collection of dots called pixels. Different drawing 
tools, such as the pencil, the paintbrush, and the text tool, edit th€ 
color of the pixels to either the foreground color or the background 
color to create a pattern. Because the Paint canvas has so many 
pixels in every square inch, you do not actually see patterns of 
dots. Instead you see a collection of lines, shapes, and text. 



You can begin to understand Paint by modifying a sample picture 
called the Clock Tower. To display the Clock Tower: 

In the Paint window, choose the Open... menu item from the 
File menu. 
The Open Picture dialog box displays the names of any 
gra phics files in the current directory. 
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2 Type in the picture file name, 
/usr/examplesIDDIF ~aphics/clocktower.ddif. 

DDIF is the standard format of a Paint file. 

3 Click on the OK button or press the Return key. 

Paint displays the Clock Tower picture. See Figure 9-1. You can 
use the Clock Tower to practice selecting tools and to experiment 
with some of the Paint menu items. 

Using Paint 9-3 



9-4 Using Paint 

Figure 9-1 The Clock Tower 
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Picking Out Tools 
The tool palette offers a variety of art tools and basic shapes. Ym 
can work with a pencil, a paintbrush, a can of spray paint, or a 
paint bucket. The shapes on the tool palette let you build picture 
quickly and easily. 



Notice in Figure 9-1 that the paintbrush tool is highlighted, 
indicating it is the current default. Only one tool on the tool 
palette is active at a time and that tool remains active until you 
make another selection. 

Try changing the time on the Clock Tower. First, select the eraser 
to delete the current time. To use the eraser: 

Place the pointer in the tool palette, position it on the eraser 
tool, and click MB1. 

2 Move the pointer into the drawing window, position it in the 
center of the clock face, and click MB1. 

The eraser is now active in the window. 

3 Gently drag the eraser along each hand of the clock, 
eliminating the current time. 

Now, draw in the current time, using the straight line tool: 

Point to the straight line tool on the tool palette and click 
MB1. 

2 Position the pointer in the center of the clock face and press 
MBl. 

The straight line tool is now active, and one end of the line is 
anchored at the center of the clock. You can stretch and swing 
the line from the center point by moving the mouse. Try it. 

3 Drag the pointer from the center of the clock to the current 
hour postion. Once the line points to the correct time, release 
MB1. 

4 Add a second line in the same manner for the minute hand. 

If you make a mistake, choose the Undo menu item from the Edit 
menu. 

Selecting Menu Items 
Using the menu items in the Paint program, you can create 
special effects with a painting. 

For example, the Invert menu item on the Edit menu creates a 
negative image of a painting. The Paint program can reverse the 
tones of the Clock Tower, switching the foreground color and the 
background color. 

1 Click on the selection box tool. 

2 Move the pointer into the drawing window and select the 
Clock Tower. 
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3 Choose the Invert menu item from the Edit menu. 

Paint repaints the Clock Tower, making a negative of the original 
image. 

Saving a Painting 
To save your version of the Clock Tower: 

Choose the Save As... menu item from the File menu. 

Paint displays a dialog box and prompts you for a file name. 
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2 Type a file name using the form ""/filename.DDIF 
so that Paint saves the picture in your login directory. 

3 Click on the OK button or press the Return key. 

Printing a Painting 
To print the Clock Tower, choose one of the Print menu items 
from the File menu. The Print menu item sends the painting to 
the default printer, whereas the Print As... menu item displays 
the print dialog box. Complete the dialog box as described in the 
DECwindows User's Guide. 

Paint supports output to both PostScript and sixel printers, such 
as the LA50 and LAI00. When printing on a LA50, set an aspect 
ratio of 2:1. All other printers have a 1:1 ratio. 



Erasing 
There are several ways to erase in Paint: 

• Use the eraser tool. 

• Select the area using the selection box tool or the scissors tool. 
Or, select the entire canvas using the Select All menu item 
from the Edit menu. Then choose the Clear menu item from 
the Edit menu. 

• Choose the Undo menu item from the Edit menu to erase the 
last Paint operation. 

Drawing Lines and Shapes 
The bottom half of the tool palette contains a collection of line and 
shape tools that you use in a similar way. Whenever you draw a 
straight line or a shape, the point where you click MBl becomes 
its reference point. That is, you can stretch and swing the line 
or shape from this reference point by dragging the pointer, as 
illustrated in Figure 9-2. When the shape is correct, anchor it in 
place by releasing MB1. 

For example, to draw a rectangle: 

Click on the rectangle tool. 

2 Position the pointer in the drawing window where you want 
one corner of the rectangle to be. Press MBl and drag the 
pointer diagonally across the drawing surface until the 
rectangle has the desired width and height. (Notice how you 
can stretch and shrink the rectangle, even flip it over.) 

3 Release MBl to anchor the shape. 
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Figure 9-2 Drawing Simple Shapes 
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If you want to line up a series of shapes or draw them equidistant 
to each other, choose the Grid menu item from the Options menu. 
It superimposes a horizontal and vertical pattern of dots on the 
drawing window, as shown in Figure 9-3, that serves as a guide, 
yet does not become part of your picture. 



Figure 9-3 Drawing Aids 
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Varying Line Width 
Lines drawn with the shape tools can be thick or thin. To change 
the current line width: 

Choose the Line Width... menu item from the Options menu. 

Paint displays a dialog box. 
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2 Click on the line thickness you want. 

For example, to draw polygons with different kinds of borders, 
choose the line width you want and then do the following: 

1 Click on the polyline tool to make it active. 

2 Mter positioning the pointer in the drawing window, drag 
the pointer to create one side of the polygon. Drag to create 
additional sides and double-click on the final corner. 

Most of the time, geometric shapes or figures are opaque so 
you cannot see what lies behind them. However, using the 
Transparent menu item from the Options menu, you can let 
background images show through foreground images. 
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Using PaHerns 
Lines and shapes do not need to be a solid color. They can be 
striped, speckled, woven, dotted, and so on. 

The line and shape tools, the spray can tool, and the paintbrush 
tool can paint patterned lines and borders. To use patterned lines: 

Choose the Patterns... menu item from the Options menu. 

Paint displays the Patterns palette, which provides a selection 
of designs. See Figure 9-4. 
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2 Click on the outline button to change the current outline 
pattern, which is solid. 

3 Click on any pattern. 
Notice that the pattern you clicked on is displayed in the 
outline button, indicating it is the active pattern. 

4 Click on the shape tool you want to use. 

To create shapes with patterned centers: 

Choose the Patterns... menu item from the Options menu. 

Paint displays the Patterns palette, illustrated in Figure 9-4. 

2 Click on the Fill button to select a fill pattern. 

3 Click on any pattern on the palette. 

Notice that the pattern you click on is displayed in the Fill 
button, indicating it is the current default. 

4 Click on any tool you want to use. The geometric shape tools 
and the paint bucket tool use the current fill pattern. 

S After positioning the pointer in the drawing window, drag the 
pointer to create a shape with a patterned center. 

If you are using the paint bucket tool, position the pointer 
inside an enclosed shape. Any opening in the border causes 
the paint to spill out onto the canvas. 



Creating Your Own Patterns 
With Paint, you can create your own patterns and store them 
on the pattern palette during a Paint session. You create your 
own pattern from any of the patterns on the palette except the 
solid foreground and solid background patterns, illustrated in 
Figure 9-4. 

To create your own pattern: 

Decide whether you want an outline or a fill pattern, then 
click on the appropriate button on the Pattern palette. 

2 Choose a pattern from the palette that is closest to what you 
want and click on it. Paint also provides a few blank patterns 
at the end of the palette that you can customize. 

3 Choose the Edit Pattern... menu item from the Options menu. 
Paint displays a dialog box. 
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Notice that this dialog box contains two boxes. In the left­
hand box you see the pattern you chose from the palette. In 
the right-hand box you see the same pattern magnified. 

While you are editing a pattern, the Edit Pattern dialog box 
has input focus, and the pointer assumes the shape of a pencil. 

4 In the Edit Pattern dialog box, edit the magnified version of 
the pattern to create the effect you want. 

Use the pencil to draw over pixels or click on individual pixels. 
The pencil tool turns a background pixel to the foreground 
color and a foreground pixel to the background color. 

Refer to the pattern shown in the left-hand box to see how the 
magnified pattern looks under normal conditions. 

5 Click on the OK button to complete the pattern and return to 
the drawing window. 
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The edited pattern is available on the Pattern palette for the rest 
of the session, replacing the original pattern. 

Using the Paintbrush 

9-14 Using Paint 

For an elegant stroke, one that creates a calligraphic effect, use 
the paintbrush. The paintbrush tool applies paint along the path 
of the pointer. Initially, the paintbrush has a solid stroke, but you 
can choose a patterned stroke by changing the outline pattern on 
the Patterns palette, as described in section Using Patterns. 

To shape the tip of the paintbrush: 

1 Click on the paintbrush tool. 

2 Choose the Brush Shape... menu item from the Options menu. 
Paint displays a dialog box. 
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3 Click on the brush shape you want. 

4 Move the pointer into the drawing window and try out the 
new brush stroke. 



Editing Paintings 
With Paint's electronic canvas, you can easily rearrange images in 
the drawing window. You can delete images entirely, move them 
to another part of the window, or copy them. The Paint program 
can also size selected images, shrinking them or enlarging them 
as you wish. It can also crop a painting, retaining one section of 
the canvas while discarding the rest. For further effect, Paint can 
invert the foreground and background colors in a selected area. 

Selecting Images 
Two selection tools, the box and the scissors, mark a portion of the 
drawing window for a graphics operation. The selection box tool 
marks a rectangular area, while the selection scissors tool marks 
an area with an arbitrary shape. You can select the entire canvas 
with the Select All menu item on the Edit menu. 

To use the selection box tool, position the pointer in one corner 
of the area to be selected and drag the pointer over the desired 
image. 

To use the selection scissors tool, drag the pointer around the 
boundary of the desired object until you reach the starting point. 

Paint stores the selected image until you tell it what to do. 

Moving Images 
You can move an image from one location in the Paint window to 
another. To move an image: 

1 Select the image. 

2 Position the pointer inside the selected area and drag the 
image to the desired location. 

You can cancel the selection by clicking in another part of the 
window or by selecting another tool. 

Copying Images 
Once you select an image on the canvas, you can copy the image 
to the clipboard, leaving the original image intact. Then paste the 
clipboard image onto the canvas. Paint can paste graphic images 
from the clipboard, but it cannot paste text. 

To copy an image: 

Select the image. 
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2 Choose the Copy menu item from the Edit menu. 
Paint copies the image to the clipboard. 

3 Choose the Paste menu item from the Edit menu. 

Paint takes the image from the clipboard and puts it on the 
canvas, leaving it selected. 

4 Position the pointer in the selected image and drag it to the 
proper location on the screen. 
You can cancel the selection by clicking on another tool or by 
selecting another image. 

Resizing Images 
You can also modify the proportions of selected images. Use 
the Scale menu item from the Edit menu to enlarge or shrink a 
selected image. To scale an image: 

1 Select the image. 

2 Choose the Scale menu item from the Edit menu. 
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3 Type a number less than 100 to shrink the figure by the 
desired percentage or a number greater than 100 to expand 
the figure. 

4 Click on the OK button to complete the operation. 



Cropping a Picture 
Many times, one section of a painting develops so well that you 
decide to keep it, discarding the rest of the canvas. Use the Crop 
menu item to extract a portion of the picture. To crop a picture: 

1 Select the section of the picture you want to keep. 

2 Choose the Crop menu item from the Edit menu. 

Paint repositions the cropped picture in the upper left corner 
of the window and discards the rest of the painting. You can 
restore the original picture with the Undo menu item. 

Editing in Detail 
Not only does Paint magnify patterns in the Edit Patterns dialog 
box so you can see them better, it also magnifies portions of the 
canvas with the Zoom On menu item. Zoom acts like a magnifying 
glass in the drawing window, enlarging an image to eight times 
its original size. 

To magnify a portion of a painting: 

Choose the Zoom On menu item from the Options menu. 

The Zoom window opens beside the Paint window and a 
magnifying frame is displayed in the Paint window itself. 
The magnifying frame in the Paint window demonstrates the 
size of the image that Paint magnifies in the Zoom window. 
You can resize the Zoom window to edit a larger area of the 
canvas. 
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2 Place the pointer inside the magnifying frame and drag the 
frame over the image that you want to edit. 
Notice that the Zoom window contains an enlarged version 
of the image that is defined by the magnifying frame in the 
Paint window. 

3 Select the pencil tool from the tool palette. 

4 Bring the pointer into the Zoom window and use the pencil to 
add fine details to the image. Either click on individual pixels 
or draw over them. 

Notice that the image in the drawing window changes as you 
edit in the Zoom window, so you can see how the modified 
figure looks in normal proportions. Continue editing pixels 
until you are satisfied with the overall effect. 

S To edit other areas of the drawing window, drag the 
magnifying frame to the next location. 

Edit the pixels in the Zoom window as before. 

To close the Zoom window, display the Options menu and click on 
the Zoom Off menu item. 



Inserting Text 
You can insert text anywhere in the Paint window. The text can 
be different fonts, sizes, and styles, as illustrated in Figure 9-5. 
You can change the appearance of text in the drawing window up 
until the moment you click to complete the text entry. Mer that, 
Paint incorporates the text into the graphic image. To insert text: 

1 Select the text tool. 

2 Position the pointer in the Paint window where you want to 
insert text and click MBI. 

Paint inserts a left corner bracket to mark the left margin of 
the text entry and displays the text insertion cursor next to it. 

3 Type in text from the keyboard, formatting it with the Tab 
and Return keys. 

4 To modify the text font, choose the Family menu item from the 
Font menu and display the pop-up menu. Click on the type of 
font that you want. 

5 Change the text from normal to bold face by choosing the 
Style menu item on the Font menu. Display the pop-up menu 
from the Style item and click on Bold. 

6 To adjust the size of the text, choose the Size menu item and 
display the pop-up menu. Click on the pica size that you want. 

Paint applies the selections you make to the text you have 
already entered. 

7 To complete the entry with its current characteristics, either 
move the pointer to another part of the window and click MBI 
or select another tool. 

The inserted text becomes part of the picture. You can no longer 
erase text with the delete key or change its characteristics with 
items from the Font menu. 
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Sizing the Canvas 

9-20 USing Paint 

The default Paint window shows only a portion of the canvas. Tl: 
scroll bars along the right side and the bottom of the window let 
you view the entire canvas. The position of the slider indicates 
your position in the canvas. When the slider is at the top of the 
scroll bar, you are at the beginning of the canvas. When the slidE 
is at the bottom of the scroll bar, you are at the end of the canva: 

You can resize the Paint window to frame the entire canvas by 
clicking on the resize button. 

You can also tailor the size of a Paint canvas. To alter the canva: 

Choose the Picture Size... menu item from the Customize 
menu. 
Paint displays a dialog box. 
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The Picture Size dialog box shows the current canvas size 
with its dimensions converted to pixels, inches, or centimeters. 

2 Click on the Size menu item to display a pop-up menu. 

3 Choose the desired canvas size. 

4 Click on the Dismiss screen button. 

Exiting from Paint 

Tool Summary 

To exit from Paint, choose the Quit menu item from the File 
menu. 

Table 9-1 lists the tools available on the Paint palette. 
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Table 9-1 

Tool 

Box 

Scissors 

Spray can 

Pencil 

Eraser 

Paintbrush 

Text 

Paint bucket 

Line 

Arc 

Rectangle 

Square 

Ellipse 

Circle 

Free-hand 
stroke 

Polyline 

Tool Summary 

Action 

Select a rectangular area for editing. 

Select a shape for editing. 

Apply paint in the current outline pattern. (The 
slower the drag, the darker the coat.) 

Draw a thin line. 

Delete the image in the path of the pointer. 

Paint a free stroke. 

Print what is typed at the keyboard. 

Fill a closed shape with the current fill pattern. 

Draw a straight line. Shift-click for a 90-degree or a 
45-degree line. 

Sketch a horizontal or vertical arc, depending on 
the initial movement after the click. Shift-click for a 
quarter circle. 

Draw a rectangle. Shift-click for a square. 

Draw a square. 

Draw an oval shape. Shift-click for a circle. 

Draw a circle. 

Draw a free-hand line in the selected line width and 
pattern. 

Draw a multisided figure with'rounded corners. 
Click at each corner, double-click to complete shape. 
Shift-click for 45- or 90-degree angles. 



10 
Using the PostScript Previewer 

The PostScript@ Previewer lets you view formatted PostScript 
files on your workstation screen without printing them, thus 
saving you paper and trips to the printer. 

This chapter describes how to 

• Start the PostScript Previewer 

• View a PostScript file 

• Customize your PostScript display 

• Exit from the PostScript Previewer 

.tarfing the PostScript Previewer 
To start the PostScript Previewer, enter the following command in 
a terminal emulator window: 

% dxpsview & 

You can specify several options on the command line to specify the 
file to be displayed or characteristics of the PostScript Previewer 
window. See the ULTRIX Worksystem Software reference page 
on the dxpsview(lX) command for information about these 
command options. 

The PostScript Previewer displays its main window, which is 
where you view PostScript files. ' 

® PostScript is a registered trademark of Adobe Systems Incorporated. 
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Viewing PostScript Files 
To view a PostScript file in the PostScript Previewer window, you 
must open it, To open a PostScript file: 

Choose the Open... menu item from the File menu. 
The Previewer displays a dialog box that prompts you for the 
name of the file you want to view. The file list box lists the 
nameS of any PostScript files in the current directory. 
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2 Double click on the file name you want to view. 

The PostScript Previewer displays the file you specified. 

If you want to view a PostScript file that is not listed, type the 
name of that file in the Selection text entry field and click on the 
OK button. Or, use the File Filter text entry field to list a subset 
of files that you can then select from. For example, to list all files 
in another directory with the file type PS, type the full directory 
path -/jones/project!*.ps-in the File filter text entry field and click 
on the Filter button. Then double click on the file name of the file 
you want to view. 

If the file name of the file you want to view appears in any other 
window, you can select that file name and view the file. To view a 
file whose file name appears in another window: 

1 Select the file name you want to view. 

2 Choose the Open Selected menu item from the File menu. 
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The PostScript file you selected is displayed. 

Paging Through the Displayed File 
The number of the page currently displayed appears in the Status 
area in the lower left corner of the window. To view another page 
in the displayed file, you can 

• Specify the number of the page you want to see 

• Specify the next page 

• Specify the previous page 

To view a page whose number you specify: 

1 Choose the Display... menu item from the Page menu. 

2 Enter the number of the page you want to see. 

3 Click on the OK button. 

The PostScript Previewer displays that page. 

To view the next page, you can either choose the third menu 
item from the Page menu or click on the Next Page button at 
the bottom of the Previewer window. You can continue to page 
through the file by choosing the appropriate menu item from the 
Page menu or by clicking on the Next Page and Previous Page 
buttons. 

If you are viewing the first page in the file, the first menu item on 
the Page menu and the Previous Page button are unavailable. If 
you are viewing the last page in the file, the last menu item on 
the Page menu and Next Page push button are unavailable. 

Revisiting the Current File 
If you make changes to a PostScript file based on what you see 
when you view it, you do not have to close the file to see those 
changes in effect. By revisting the file currently displayed, you 
can see the changes you made. This means you can modify the file 
in one window while you are viewing it in another, reprocess the 
file to produce new PostScript output, and view the modified file. 

To revisit the currently displayed file, choose the Revisit Current 
menu item from the File menu. The file is redisplayed from the 
beginning. 
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Customizing the PostScript Previewer 
By customizing the PostScript Previewer, you can 

• Change the page size and orientation 

• View a specific page without first having to view preceding 
pages 

• View files either for format or content 

• View files that contain unsupported PostScript tray size 
directives 

• View PostScript files produced by VAX DOCUMENT 

Changing the Page Size and Orientation 
You can change the size and orientation of a page you want to 
view. Changing the page size does not change the size of the 
PostScript Previewer window. Instead, the display is formatted (in 
length and width) for the page size you specify. Unless you specify 
otherwise, the display page size is Letter (8.5 x 11 inches). 

To change the page size of the file currently displayed: 

Choose the Sheet Selection ... menu item from the Options 
menu. 
The Previewer displays a dialog box. 
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2 To choose a sheet size, click on the appropriate size. 

The new sheet size takes effect at the next page operation, when 
another file is opened, or when the current file is reopened with 
the Revisit Current menu item. 

You can choose from the following tray sizes: 

• Letter (8.5 x 11 inches) 

• Legal (8.5 x 14 inches) 

• Ledger (11 x 1 7 inches) 

• Executive (7.5 x 10.5 inches) 
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Unless you specify otherwise, the page is displayed upright at ° degrees. You can view the page at 0, 90, 180, or 270 degrees. To 
change the orientation of the page in the Previewer window, click 
on the appropriate orientation symbol. The new page orientation 
takes effect at the next page operation, when another file is 
opened, or when the current file is reopened with the Revisit 
Current menu item. 

Using Comments 
When you choose the Use Comments menu item from the Options 
menu, the PostScript Previewer enables special formatting 
conventions (if they are already present in the file) that format 
pages independently of each other. This means that you can view 
page five of a file without having first viewed pages one through 
four. 

The Use Comments menu item is in effect by default. This is 
indicated by the shaded Use Comments option button. If this 
option is disabled (indicated by the absence of a shaded option 
button) and you receive an error message when attempting to 
view a PostScript file, try correcting the problem by choosing the 
Use Com.ments menu item. 

The Use Comments menu item does not take effect until another 
file is opened or the current file is reopened with the Revisit 
Current menu item. 

Using Bitmap Widths 
The' Previewer displays files whose characters are well spaced and 
easily read. Notice, however, that the file may not appear on the 
screen exactly as it would look when printed. 

Sometimes, you may want to view a file for format and layout 
and are less concerned with reading the actual text. If you are 
viewing a file that looks different on your terminal than it does 
when printed-perhaps the columns are not aligned precisely or a 
paragraph formatted for right justification appears instead with a 
ragged right margin-choose the Using Bitmap Widths menu item 
from the Options menu. When you choose this menu item, the 
Previewer adjusts the spacing between characters to approximate 
the look of a printed page. Notice, however, that the characters 
may be densely spaced and difficult to read. 

The Use Bitmap Widths menu item, which is off by default, is in 
effect if its option button is highlighted. Any changes you make to 
this setting will be in effect at the next page operation. 
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Using Fake Trays 
Some PostScript files contains tray size directives. These are 
device-specific PostScript programming language instructions that 
tell the printer which tray size to use. For example, a file might 
contain tray size directives that instruct the printer to switch from 
the letter tray (8.5 x 11) to the ledger tray (11 x 17) while that file 
is being printed. 

The Previewer does not, however, permit the addition of tray 
size directives to PostScript files in this way. If you try to view 
a file that contains PostScript tray size directives, the Previewer 
displays an error message. To continue viewing the file: 

Press RETURN to acknowledge the error message. 

2 Choose the Use Fake Trays menu item on the Options menu. 

The Use Fake Trays menu item, which is off by default, is in 
effect if its option button is highlighted. 

3 Choose the Revisit Current menu item from the File menu 
The file is redisplayed from the beginning and the tray size 
remains the same. 

To change the tray size, use the Sheet Selection dialog box. 

Using VAX DOCUMENT Mode 
U sing the PostScript Previewer, you can view PostScript files 
produced by the VAX. DOCUMENT electronic publishing system. 
However, VAX. DOCUMENT Version 1.0 produces PostScript 
output that contains at least one font not available in the 
Previewer. In addition, special formatting conventions that allow 
you to view a page in the middle of a file without having first 
viewed the preceding pages are not enabled in VAX. DOCUMENT 
PostScript files. 

If you try to view a PostScript file produced by VAX. DOCUMENT 
Version 1.0 and receive an error message reporting that a font is 
unrecognized, correct the problem by choosing the DOCUMENT 
Mode menu item. The DOCUMENT Mode menu item, which is off 
by default, is in effect if its option button is highlighted. 

The DOCUMENT Mode menu item does not take effect until 
another file is opened or the current file is reopened with the 
Revisit Current menu item. 
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PostScript files produced by VAX DOCUMENT Version 1.1 or later 
do not require you to enable the DOCUMENT Mode menu item. 
To see which version of VAX DOCUMENT has been used to create 
a PostScript file, type the PostScript file and look at the first two 
lines. If these lines contain the following text, do not enable the 
DOCUMENT Mode menu item. 

%!PS-Adobe-2.0 
%%Creator: VAX DOCUMENT Vl.l 

Exiting from the PostScript Previewer 
To exit from the PostScript Previewer, choose the Exit menu item 
from the File menu. Before exiting, the PostScript Previewer 
closes the file being viewed. 

Using the PostScript Previewer 10-9 





1 1 
Puzzling 

The Puzzle is a video version of a number puzzle with slidable 
squares. 

Starting the Puzzle 

•••• •••• •••• ••• 

To start the Puzzle, enter the following command in a DECterm 
terminal emulator window: 

% dxpuzzle & 

The Puzzle is displayed . 
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Playing Around with the Puzzle 

11-2 Puzzling 

The puzzle squares are scrambled. The trick is to arrange them 
in ascending order in the fewest possible moves. The Puzzle keeps 
track of the number of moves you make. 

Click on the square you want to move. Although you can move 
only those squares that are adjacent to the blank square, you can 
slide an entire row at a time. 

To make the Puzzle easier or more challenging, choose the 
Settings... menu item from the Customize menu and change the 
settings. 

Try increasing the number of squares displayed per side. To 
change the number of squares on each side, place the pointer on 
the number in the slider and drag to the left or right. Click on thE 
OK button to change the settings, or the Cancel button to return 
to the Puzzle without changing any settings. 



Starting a New Game 
You do not have to win one game to start another. To start a new 
game and rescramble the squares, choose the New Game menu 
item from the File menu. 

Exiting from the Puzzle 
To exit from the Puzzle, choose the Quit menu item from the File 
menu. 
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DDIF 

displaying, 5-1 

Horizontal scroll bar 
setting in a DECterm window, 6-4 

Index topic 
changing, 3-6 



K 

'"", Key, 6-15 
Keyboard 

changing operating features, 6-13 
Keyclick, 6-14 

L 

Light Text, dark background, 6-7 
Lines 

saving, 6-4 
Little Font, 6-5 
Lock UDKs, 6-8 
Lock User Features, 6-8 

M 
VI ail 

Create-Send window 
described, 7-4 
illustrated, 7-3 
opening, 7-3 

exiting, 7-18 
folders 

creating, 7-13 
deleting, 7-13 
described, 7-2 

main window 
illustrated, 7-1 
opening a new, 7-1 7 

Read window 
closing, 7-9 
described, 7-8 
illustrated, 7-7 
opening, 7-7 

starting, 7-1 
({ail message 

copying, 7-13 
creating, 7-3 

including a draft, 7-5 
including a ·file, 7-5 

creating a subset of, 7-14 
creating files from a, 7-12 
deleting, 7-12 

Mail message (cont'd.) 
extracting, 7-12 
forwarding, 7-10 
moving, 7-13 
picking, 7-14 
printing, 7-11 
reading, 7-7 
reading new messages, 7-7 
replying to, 7-10 
retrieving deleted, 7-12 
selecting, 7-7 
sending, 7-3, 7-5 

Mail messages 
sorting, 7-14 

Margin bell, 6-14 
Memory display 

calculator, 1-4 

N 
New Line, 6-8 
Normal/80, Condensedll32, 6-5 
Normal Cursor Keys, 6-9 
Normal Font (80 columns), 6-5 
Notepad 

cancelling edits, 8-4 
exiting, 8-10 
formatting text, 8-3 
merging files, 8-8 
navigating, 8-3 
opening a new one, 8-7 
recoveri'ng lost edits, 8-11 
replacing text, 8-10 
saving text, 8-6 
scrolling, 8-3 
searching for text, 8-9 
starting, 8-1 
typing text, 8-2 
using journal file, 8-11 

Numeric Keypad, 6-9 

p 

Paint 
exiting, 9-21 

Index-3 



Paint (cont'd.) 
starting, 9-2 

Paintbrush tool, 9-14 
Painting 

changing line width, 9-7,9-10 
changing scale, 9-16 
copying images, 9-15 
erasing, 9-7 
inserting text, 9-19 
inverting colors, 9-5 
magnifying, 9-17 
moving images, 9-15 
opening graphics file, 9-3 
printing, 9-6 
saving, 9-6 
selecting an image, 9-15 
sizing the canvas, 9-20 
using a grid, 9-8 

Paint window 
clearing, 9-7 
scrolling the canvas, 9-20 

Pattern 
adding to painting, 9-12 
creating your own, 9-13 
using, 9-7,9-12 

Pixel, 9-2 
PostScript file 

paging through a, 10-4 
PostScript files 

handling tray size directives in, 10-8 
viewing, 10-2 

PostScript Previewer 
changing page size of display, 10-5 
customizing, 10-5 
exiting, 10-9 
handling structuring conventions 

with, 10-7 
illustrated, 10-1 
opening files with, 10-2 
paging through file with, 10-4 
starting, 10-1 
viewing files for content with, 10-7 
viewing files for form with, 10-7 

Puzzle 

Index-4 

Puzzle (cont'd.) 

R 

changing settings, 11-2 
exiting, 11-3 
starting, 11-1 

Repeat intervals, 2-6 
Reposition 

Calendar display, 2-17 
Resetting DECterm, 6-33 
Resize 

Calendar display, 2-1 7 
Calendar entry, 2-5 

Resizing a DECterm Window, 6-33 
Restoring Original System Settings 

6-31 ' 

5 

Saving and naming a customized file 
6-30 ' 

Saving the current file, 6-30 
Scroll bar 

using in the Cardfiler, 3-4 
Setting the Compose Character Key 

6-15 ' 
Setup 

see Customize 
Shift Lock, 6-15 

T 
Terminal emulator 

creating, 6-1 
Terminal ID, 6-9 
Terminal Size (Rows and Columns) 

6-6 ' 
Text 

copying, 8-5 
copying in card file, 3-8 
deleting in card file, 3-7 
finding in card file, 3-4 
in a painting, 9-20 
Including, 8-5 
moving, 8-5 



Text (cont'd.) 
moving in card file, 3-7, 3-8 
selecting in card file, 3-7 

Text cursor 
moving in card file, 3-7 

Today menu item, 2-3 
Tool 

choosing in Paint, 9-4 
drawing lines and shapes, 9-5 
summary of Paint palette, 9-21 
using shapes in Paint, 9-7 

Transparent background, 9-10 

u 
Underline Cursor, 6-7 
UPSS DEC Supplemental, 6-9 
UPSS ISO Latin 1, 6-9 
Use Last Saved Settings, 6-31 

v 
Vertical scroll bar 

setting in a DECterm window, 6-4 
VT100 Terminal Mode, 6-13 
VT300 terminal mode, 7 -bit controls, 

6-13 
VT300 terminal mode, 8-bit controls, 

6-13 
VT52 terminal mode, 6-13 

w 
Warning bell, 6-14 

Z 
Zoom, 9-17 

Index-5 





HOW TO ORDER ADDITIONAL DOCUMENTATION 

DIRECT TELEPHONE ORDERS 

In Continental USA 
and New Hampshire, 
Alaska or Hawaii 
call BOO-DIGITAL 

In Canada 
call BOO-267 -621 5 

DIRECT MAIL ORDERS (U.S. and Puerto Rico*) 

DIGITAL EQUIPMENT CORPORATION 
P.O. Box CS2008 

Nashua, New Hampshire 03061 

DIRECT MAIL ORDERS (Canada) 

DIGITAL EQUIPMENT OF CANADA LTD. 

100 Herzberg Road 
Kanata, Ontario K2K 2A6 
Attn: Direct Order Desk 

I INTERNATIONAL I 
DIGITAL EQUIPMENT CORPORATION 

PSG Business Manager 
c/o Digital's local subsidiary 

or approved distributor 

Internal orders should be placed through the Software Distribution Center (SOC), Digital 
Equipment Corporation, Westminster, Massachusetts 01473 

* Any prepaid order from Puerto Rico must be placed 
with the Local Digital Subsidiary: 

809-754-7575 
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submitted on this form at the company's discretion. If you require a writ­
ten reply and are eligible to receive one under Software Performance 
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